uci: update to version 2020-10-06
authorPetr Štetiar <ynezz@true.cz>
Tue, 6 Oct 2020 07:34:24 +0000 (09:34 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 27 Oct 2020 21:51:59 +0000 (22:51 +0100)
52bbc99f69ea Replace malloc() + memset() with calloc()
3fbd6c923434 ucimap: Check return of malloc()
eae126f66663 file: Check buffer size after strtok()
7f574273180a file: use size_t for position and pointer
19770b6949b9 file: use dynamic memory allocation for tempfile name
aa46546794ac file: uci_file_commit: fix memory leak
671c7554bfde uci: silence UBSAN error by using offsetof macro from compiler
ea5bbd57d0e1 tests: cram: add uci import testing on fuzzer corpus
31f78bfbf75f cmake: add uci-san cli built with clang sanitizers
a3e650911f5e file: uci_parse_package: fix heap use after free
9bd361ca3236 tests: add libFuzzer based fuzzing

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/system/uci/Makefile

index 8c11f4c5766e344387c14051b4441b6fb62eca0b..9e632ac8dab6a6f90e2209207e014a95cdef957f 100644 (file)
@@ -13,8 +13,8 @@ PKG_RELEASE:=3
 
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/uci.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE=2020-04-24
-PKG_SOURCE_VERSION:=ec8d3233948603485e1b97384113fac9f1bab5d6
+PKG_SOURCE_DATE=2020-10-06
+PKG_SOURCE_VERSION:=52bbc99f69ea6f67b6fe264f424dac91bde5016c
 PKG_MIRROR_HASH:=b3cdc66a8ec4f05a102ce5520a3f8ff69ca4a49930c5bb01065467ef68f0808b
 
 PKG_LICENSE:=LGPL-2.1