package: fix cmake packages build with ninja
authorRosen Penev <rosenp@gmail.com>
Sun, 6 Jun 2021 21:24:43 +0000 (14:24 -0700)
committerFelix Fietkau <nbd@nbd.name>
Sat, 12 Jun 2021 08:46:39 +0000 (10:46 +0200)
+= is needed for CMAKE_OPTIONS.

mt76 needs Ninja disabled as the kernel stuff uses normal make.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/kernel/mt76/Makefile
package/libs/libubox/Makefile
package/network/services/uhttpd/Makefile
package/system/ubus/Makefile
package/system/uci/Makefile

index e4051d8347dcfb08b02c95a6ed2ab6f40b9b2a31..74d5950545228dc5bb389ec4d8d4a8662c311662 100644 (file)
@@ -13,6 +13,7 @@ PKG_SOURCE_VERSION:=22b690334c0f49b11534cc2e331c9d5e17c4a0bc
 PKG_MIRROR_HASH:=ff5e563935919d2e40c1e7254ef3bc06f7ecc5e69f8ddd12903e8f5de942d630
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_USE_NINJA:=0
 PKG_BUILD_PARALLEL:=1
 
 PKG_CONFIG_DEPENDS += \
index ac4effb6f8641bbb3c53f45eccd8c19b85271b08..aec4c9cc02f9acdb0f6f516861f41cd1182533bb 100644 (file)
@@ -67,7 +67,7 @@ define Package/libubox-lua
 endef
 
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
-CMAKE_OPTIONS = \
+CMAKE_OPTIONS += \
        -DLUAPATH=/usr/lib/lua \
        -DABIVERSION="$(PKG_ABI_VERSION)"
 
index 87b3690515cd2f1e19a0f8215567e97fae83bd11..8f58271127658bc37b16182f70f1b34079a12b2f 100644 (file)
@@ -85,7 +85,7 @@ endif
 
 TARGET_LDFLAGS += -lcrypt
 
-CMAKE_OPTIONS = -DTLS_SUPPORT=on
+CMAKE_OPTIONS += -DTLS_SUPPORT=on
 
 define Package/uhttpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
index 885307107bd1eb1b5838ab661d77529e46f46bd3..a29521e9a58e28bbd89768b5e172ff9dabc6c5be 100644 (file)
@@ -53,7 +53,7 @@ endef
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include -flto
 TARGET_LDFLAGS += -flto
 
-CMAKE_OPTIONS = \
+CMAKE_OPTIONS += \
        -DLUAPATH=/usr/lib/lua \
        -DABIVERSION="$(PKG_ABI_VERSION)"
 
index 3c1e168717e2018e8d4b5381a7f891baee1f9dff..cdb6883bc110d646b7beecea815c05fc7d055c4b 100644 (file)
@@ -55,7 +55,7 @@ endef
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
 TARGET_LDFLAGS += -L$(STAGING_DIR)/usr/lib
 
-CMAKE_OPTIONS = \
+CMAKE_OPTIONS += \
        -DLUAPATH=/usr/lib/lua \
        $(if $(DEBUG),-DUCI_DEBUG=ON)