ath79: add support for Netgear WNR1000 v2
authorMichal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
Wed, 16 Oct 2019 10:42:44 +0000 (12:42 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 21 Oct 2019 11:15:46 +0000 (13:15 +0200)
This patch adds ath79 support for Netgear WNR1000v2.
Router was previously supported by ar71xx target only.
Note: this is a 4_32 device with limited upgrade capabilities.

Specification
=============
  * Description: Netgear WNR1000 v2
  * Loader: U-boot
  * SOC: Atheros AR7240 (340 MHz)
  * RAM: 32 MiB
  * Flash: 4 MiB (SPI NOR)
- U-boot binary: 256 KiB
- U-boot environment: 64 KiB
- Firmware: 3712 KiB
- ART: 64 KiB
  * Ethernet: 4 x 10/100 LAN + 1 x 10/100 WAN
  * Wireless: 2.4 GHz b/g/n (Atheros AR9285)
  * USB: no
  * Buttons:
- Reset
- WiFi (rfkill)
- WPS
  * LEDs:
- Power (amber/green)
- WAN (amber/green)
- WLAN (blue)
- 4 x LAN (amber/green)
- WPS (green)
  * UART: 4-pin connector JP2, 3.3V (Vcc, TX, RX, GND), 115200 8N1
  * Power supply: DC 12V 1A
  * MAC addresses: LAN on case label, WAN +1, WLAN +2

Installation
============
  * TFTP recovery
  * TFTP via U-boot prompt
  * sysupgrade
  * Web interface

Test build configuration
========================
CONFIG_TARGET_ath79=y
CONFIG_TARGET_ath79_tiny=y
CONFIG_TARGET_ath79_tiny_DEVICE_netgear_wnr1000-v2=y
CONFIG_ALL_KMODS=y
CONFIG_DEVEL=y
CONFIG_CCACHE=y
CONFIG_COLLECT_KERNEL_DEBUG=y
CONFIG_IMAGEOPT=y
CONFIG_KERNEL_DEBUG_INFO=y
CONFIG_KERNEL_DEBUG_KERNEL=y

Signed-off-by: Michal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/dts/ar7240_netgear_wnr1000-v2.dts [new file with mode: 0644]
target/linux/ath79/image/tiny-netgear.mk

index 97598ce45c10f4de443ae493cb18c7e801533c1c..499fe0031c614d7b25cd7e435c1846ee9898bc06 100755 (executable)
@@ -111,6 +111,7 @@ glinet,gl-ar300m-lite)
 glinet,gl-x750)
        ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth1"
        ;;
+netgear,wnr1000-v2|\
 netgear,wnr2000-v3)
        ucidef_set_led_netdev "wan-amber" "WAN (amber)" "netgear:amber:wan" "eth0"
        ucidef_set_led_switch "lan1green" "LAN1 (green)" "netgear:green:lan1" "switch0" "0x02" "0x04"
index 5b50a6270ba35611d0c4d6a4dcc9d18ee865deca..c40c07a9061edf04f033d09ff4df774b4ff09d08 100755 (executable)
@@ -205,6 +205,7 @@ ath79_setup_interfaces()
                ucidef_add_switch_port_attr "switch0" 2 led 9
                ucidef_add_switch_port_attr "switch0" 5 led 2
                ;;
+       netgear,wnr1000-v2|\
        netgear,wnr2000-v3|\
        netgear,wnr612-v2|\
        on,n150r|\
index 96b4fb0f8a2c5bad3bfc77d770d7a32a2f96e56b..2d760e2091d4f47aff34e8f12cfd1e2f695aa434 100644 (file)
@@ -79,6 +79,7 @@ case "$FIRMWARE" in
        winchannel,wb2000)
                caldata_extract "art" 0x5000 0x440
                ;;
+       netgear,wnr1000-v2|\
        netgear,wnr2000-v3|\
        netgear,wnr612-v2|\
        on,n150r|\
diff --git a/target/linux/ath79/dts/ar7240_netgear_wnr1000-v2.dts b/target/linux/ath79/dts/ar7240_netgear_wnr1000-v2.dts
new file mode 100644 (file)
index 0000000..5660ea5
--- /dev/null
@@ -0,0 +1,203 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar7240.dtsi"
+
+/ {
+       compatible = "netgear,wnr1000-v2", "qca,ar7240";
+       model = "Netgear WNR1000 v2";
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-boot = &power_amber;
+               led-failsafe = &power_amber;
+               led-running = &power_green;
+               led-upgrade = &power_amber;
+               label-mac-device = &eth1;
+       };
+
+       ath9k-keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+
+               wps {
+                       label = "wps";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&ath9k 6 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&ath9k 7 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+
+               rfkill {
+                       label = "rfkill";
+                       linux,code = <KEY_RFKILL>;
+                       gpios = <&ath9k 8 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               pinctrl-names = "default";
+               pinctrl-0 = <&jtag_disable_pins &switch_led_disable_pins &clks_disable_pins>;
+
+               power_green: power_green {
+                       label = "netgear:green:power";
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+               };
+
+               power_amber: power_amber {
+                       label = "netgear:amber:power";
+                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+                       default-state = "keep";
+               };
+
+               wan_green {
+                       label = "netgear:green:wan";
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               };
+
+               wan_amber {
+                       label = "netgear:amber:wan";
+                       gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+               };
+
+               lan1_green {
+                       label = "netgear:green:lan1";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               };
+
+               lan1_amber {
+                       label = "netgear:amber:lan1";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+               };
+
+               lan2_green {
+                       label = "netgear:green:lan2";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               lan2_amber {
+                       label = "netgear:amber:lan2";
+                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+               };
+
+               lan3_green {
+                       label = "netgear:green:lan3";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+
+               lan3_amber {
+                       label = "netgear:amber:lan3";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               };
+
+               lan4_green {
+                       label = "netgear:green:lan4";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+
+               lan4_amber {
+                       label = "netgear:amber:lan4";
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       ath9k-leds {
+               compatible = "gpio-leds";
+
+               wps_green {
+                       label = "netgear:green:wps";
+                       gpios = <&ath9k 5 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan_blue {
+                       label = "netgear:blue:wlan";
+                       gpios = <&ath9k 1 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x40000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x40000 0x10000>;
+                       };
+
+                       partition@50000 {
+                               label = "firmware";
+                               reg = <0x50000 0x3a0000>;
+                               compatible = "netgear,uimage";
+                       };
+
+                       art: partition@3f0000 {
+                               label = "art";
+                               reg = <0x3f0000 0x10000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&art 0x0>;
+};
+
+&eth1 {
+       status = "okay";
+
+       mtd-mac-address = <&art 0x6>;
+};
+
+&pcie {
+       status = "okay";
+
+       ath9k: wifi@0,0 {
+               compatible = "pci168c,002b";
+               reg = <0x0000 0 0 0 0>;
+               mtd-mac-address = <&art 0x0>;
+               mtd-mac-address-increment = <1>;
+               qca,no-eeprom;
+               #gpio-cells = <2>;
+               gpio-controller;
+       };
+};
+
+&uart {
+       status = "okay";
+};
index b5fed1b88b9270adacac5b441c2a4e3f89468f86..0df19390bb5f29afd3a00f39ee35e735be049cea 100644 (file)
@@ -28,6 +28,18 @@ define Device/on_n150r
 endef
 TARGET_DEVICES += on_n150r
 
+define Device/netgear_wnr1000-v2
+  ATH_SOC := ar7240
+  DEVICE_MODEL := WNR1000
+  DEVICE_VARIANT := v2
+  NETGEAR_KERNEL_MAGIC := 0x31303031
+  IMAGE_SIZE := 3712k
+  IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
+  SUPPORTED_DEVICES += wnr1000-v2
+  $(Device/netgear_ath79)
+endef
+TARGET_DEVICES += netgear_wnr1000-v2
+
 define Device/netgear_wnr2000-v3
   ATH_SOC := ar7241
   DEVICE_MODEL := WNR2000