build: fix `which` detection on Fedora & MacOS
authorPaul Spooren <mail@aparcar.org>
Sat, 2 Oct 2021 01:56:27 +0000 (15:56 -1000)
committerPaul Spooren <mail@aparcar.org>
Sun, 3 Oct 2021 05:53:24 +0000 (19:53 -1000)
Fix Fedora 34/35 issue where 'which' detection of 'which' wasn't working
because Fedora use alias and proc

Fixup of fca5ad55d2 prereq-build: fix `which` detection on Fedora

Reported-by: Jani Partanen <rtfm@iki.fi>
Suggest-by: Etienne Champetier <champetier.etienne@gmail.com>
Tested-by: Georgi Valkov <gvalkov@abv.bg>
Signed-off-by: Paul Spooren <mail@aparcar.org>
include/prereq-build.mk

index 9242407b1896321b376701a8f8928157c95cfcd0..e1993444f7855695c95ce86d9d8a23825b340d97 100644 (file)
@@ -186,7 +186,9 @@ $(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
        rsync --version </dev/null))
 
 $(eval $(call SetupHostCommand,which,Please install 'which', \
-       which which | grep which))
+       /usr/bin/which which, \
+       /bin/which which, \
+       which which))
 
 $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
        mkdir -p $(dir $@)