move init scripts and related out of ipkg/
authorNicolas Thill <nico@openwrt.org>
Mon, 12 Dec 2005 03:52:27 +0000 (03:52 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 12 Dec 2005 03:52:27 +0000 (03:52 +0000)
SVN-Revision: 2637

openwrt/package/snort-wireless/Makefile
openwrt/package/snort-wireless/files/snort-wireless.default [new file with mode: 0644]
openwrt/package/snort-wireless/files/snort-wireless.init [new file with mode: 0644]
openwrt/package/snort-wireless/ipkg/snort-wireless.default [deleted file]
openwrt/package/snort-wireless/ipkg/snort-wireless.init [deleted file]
openwrt/package/snort/Makefile
openwrt/package/snort/files/snort.default [new file with mode: 0644]
openwrt/package/snort/files/snort.init [new file with mode: 0644]
openwrt/package/snort/ipkg/snort.default [deleted file]
openwrt/package/snort/ipkg/snort.init [deleted file]

index a0abd732e2619396ca0f70d3e39b18aae6d591a0..2d0fd7637681951d5effc03a81c486b6f6dad8e2 100644 (file)
@@ -107,13 +107,11 @@ $(PKG_BUILD_DIR)/$(2): $(PKG_BUILD_DIR)/.prepared
        mv $(PKG_BUILD_DIR)/src/snort $(PKG_BUILD_DIR)/$(2)
 
 $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.installed $(PKG_BUILD_DIR)/$(2)
-       rm -rf $$(IDIR_$(1))
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $$(IDIR_$(1)) ./ipkg/$(2).control $(3) $(4)
        install -m0644 ./ipkg/snort-wireless.conffiles $$(IDIR_$(1))/CONTROL/conffiles
        install -d -m0755 $$(IDIR_$(1))/etc/default
-       install -m0644 ./ipkg/snort-wireless.default $$(IDIR_$(1))/etc/default/snort
+       install -m0644 ./files/snort-wireless.default $$(IDIR_$(1))/etc/default/snort
        install -d -m0755 $$(IDIR_$(1))/etc/init.d
-       install -m0755 ./ipkg/snort-wireless.init $$(IDIR_$(1))/etc/init.d/snort
+       install -m0755 ./files/snort-wireless.init $$(IDIR_$(1))/etc/init.d/snort
        install -d -m0755 $$(IDIR_$(1))/etc/snort
        install -m0644 $(PKG_BUILD_DIR)/etc/snort.conf $$(IDIR_$(1))/etc/snort/
        install -m0644 $(PKG_BUILD_DIR)/etc/classification.config $$(IDIR_$(1))/etc/snort/
diff --git a/openwrt/package/snort-wireless/files/snort-wireless.default b/openwrt/package/snort-wireless/files/snort-wireless.default
new file mode 100644 (file)
index 0000000..796a893
--- /dev/null
@@ -0,0 +1,2 @@
+INTERFACE="vlan1" # WAN
+OPTIONS="-i $INTERFACE -c /etc/snort/snort.conf -D -N -q -s"
diff --git a/openwrt/package/snort-wireless/files/snort-wireless.init b/openwrt/package/snort-wireless/files/snort-wireless.init
new file mode 100644 (file)
index 0000000..8c019c4
--- /dev/null
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+DEFAULT=/etc/default/snort
+LOG_D=/var/log/snort
+RUN_D=/var/run
+[ -f $DEFAULT ] && . $DEFAULT
+PID_F=$RUN_D/snort_$INTERFACE.pid
+
+case $1 in
+ start)
+  [ -d $LOG_D ] || mkdir -p $LOG_D
+  [ -d $RUN_D ] || mkdir -p $RUN_D
+  snort $OPTIONS
+  ;;
+ stop)
+  [ -f $PID_F ] && kill $(cat $PID_F)
+  ;;
+ *)
+  echo "usage: $0 (start|stop)"
+  exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/snort-wireless/ipkg/snort-wireless.default b/openwrt/package/snort-wireless/ipkg/snort-wireless.default
deleted file mode 100644 (file)
index 796a893..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-INTERFACE="vlan1" # WAN
-OPTIONS="-i $INTERFACE -c /etc/snort/snort.conf -D -N -q -s"
diff --git a/openwrt/package/snort-wireless/ipkg/snort-wireless.init b/openwrt/package/snort-wireless/ipkg/snort-wireless.init
deleted file mode 100644 (file)
index 8c019c4..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-
-DEFAULT=/etc/default/snort
-LOG_D=/var/log/snort
-RUN_D=/var/run
-[ -f $DEFAULT ] && . $DEFAULT
-PID_F=$RUN_D/snort_$INTERFACE.pid
-
-case $1 in
- start)
-  [ -d $LOG_D ] || mkdir -p $LOG_D
-  [ -d $RUN_D ] || mkdir -p $RUN_D
-  snort $OPTIONS
-  ;;
- stop)
-  [ -f $PID_F ] && kill $(cat $PID_F)
-  ;;
- *)
-  echo "usage: $0 (start|stop)"
-  exit 1
-esac
-
-exit $?
index 630ac127ec61c88fcfee1d0b2f482f2411133279..9f265508f0de428fa66aab9ac74936f5e60c07f0 100644 (file)
@@ -109,13 +109,11 @@ $(PKG_BUILD_DIR)/$(2): $(PKG_BUILD_DIR)/.prepared
        mv $(PKG_BUILD_DIR)/src/snort $(PKG_BUILD_DIR)/$(2)
 
 $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.installed $(PKG_BUILD_DIR)/$(2)
-       rm -rf $$(IDIR_$(1))
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $$(IDIR_$(1)) ./ipkg/$(2).control $(3) $(4)
        install -m0644 ./ipkg/snort.conffiles $$(IDIR_$(1))/CONTROL/conffiles
        install -d -m0755 $$(IDIR_$(1))/etc/default
-       install -m0644 ./ipkg/snort.default $$(IDIR_$(1))/etc/default/snort
+       install -m0644 ./files/snort.default $$(IDIR_$(1))/etc/default/snort
        install -d -m0755 $$(IDIR_$(1))/etc/init.d
-       install -m0755 ./ipkg/snort.init $$(IDIR_$(1))/etc/init.d/snort
+       install -m0755 ./files/snort.init $$(IDIR_$(1))/etc/init.d/snort
        install -d -m0755 $$(IDIR_$(1))/etc/snort
        install -m0644 $(PKG_BUILD_DIR)/etc/snort.conf $$(IDIR_$(1))/etc/snort/
        install -m0644 $(PKG_BUILD_DIR)/etc/classification.config $$(IDIR_$(1))/etc/snort/
diff --git a/openwrt/package/snort/files/snort.default b/openwrt/package/snort/files/snort.default
new file mode 100644 (file)
index 0000000..796a893
--- /dev/null
@@ -0,0 +1,2 @@
+INTERFACE="vlan1" # WAN
+OPTIONS="-i $INTERFACE -c /etc/snort/snort.conf -D -N -q -s"
diff --git a/openwrt/package/snort/files/snort.init b/openwrt/package/snort/files/snort.init
new file mode 100644 (file)
index 0000000..8c019c4
--- /dev/null
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+DEFAULT=/etc/default/snort
+LOG_D=/var/log/snort
+RUN_D=/var/run
+[ -f $DEFAULT ] && . $DEFAULT
+PID_F=$RUN_D/snort_$INTERFACE.pid
+
+case $1 in
+ start)
+  [ -d $LOG_D ] || mkdir -p $LOG_D
+  [ -d $RUN_D ] || mkdir -p $RUN_D
+  snort $OPTIONS
+  ;;
+ stop)
+  [ -f $PID_F ] && kill $(cat $PID_F)
+  ;;
+ *)
+  echo "usage: $0 (start|stop)"
+  exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/snort/ipkg/snort.default b/openwrt/package/snort/ipkg/snort.default
deleted file mode 100644 (file)
index 796a893..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-INTERFACE="vlan1" # WAN
-OPTIONS="-i $INTERFACE -c /etc/snort/snort.conf -D -N -q -s"
diff --git a/openwrt/package/snort/ipkg/snort.init b/openwrt/package/snort/ipkg/snort.init
deleted file mode 100644 (file)
index 8c019c4..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-
-DEFAULT=/etc/default/snort
-LOG_D=/var/log/snort
-RUN_D=/var/run
-[ -f $DEFAULT ] && . $DEFAULT
-PID_F=$RUN_D/snort_$INTERFACE.pid
-
-case $1 in
- start)
-  [ -d $LOG_D ] || mkdir -p $LOG_D
-  [ -d $RUN_D ] || mkdir -p $RUN_D
-  snort $OPTIONS
-  ;;
- stop)
-  [ -f $PID_F ] && kill $(cat $PID_F)
-  ;;
- *)
-  echo "usage: $0 (start|stop)"
-  exit 1
-esac
-
-exit $?