iptables: add ip{,6}tables-legacy{,-restore,-save} symlinks
authorEtienne Champetier <champetier.etienne@gmail.com>
Wed, 26 Jan 2022 19:23:23 +0000 (14:23 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 2 Feb 2022 23:02:31 +0000 (00:02 +0100)
Now that we can have both legacy and nft iptables variants
installed at the same time, install the legacy symlinks

Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
package/network/utils/iptables/Makefile

index cf87d6de064a02fcd733f9bac97c3beb4893b2e8..e936a57380f84a18e4375a1f7a66a1399658c8e4 100644 (file)
@@ -614,6 +614,7 @@ endef
 define Package/iptables/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/xtables-legacy-multi $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/iptables-legacy{,-restore,-save} $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/iptables
 endef
 
@@ -626,6 +627,7 @@ endef
 
 define Package/ip6tables/install
        $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables-legacy{,-restore,-save} $(1)/usr/sbin/
 endef
 
 define Package/ip6tables-nft/install