fixes dependencies of pjsip and ltq-vmmc
authorJohn Crispin <john@openwrt.org>
Sun, 3 Jul 2011 17:38:52 +0000 (17:38 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 3 Jul 2011 17:38:52 +0000 (17:38 +0000)
SVN-Revision: 27409

package/ltq-vmmc/Makefile
package/pjsip/Makefile

index 2f3e834f2de5e768b2d8ef90b67c372660394e86..8ca4e2398f0dbfd8985194cc5d93cd8525c9ae1c 100644 (file)
@@ -22,7 +22,7 @@ define KernelPackage/ltq-vmmc
   SUBMENU:=Voice over IP
   TITLE:=TAPI LL driver for Voice Macro
   URL:=http://www.lantiq.com/
-  DEPENDS:=+kmod-ltq-tapi @TARGET_lantiq_xway
+  DEPENDS:=+kmod-ltq-tapi @TARGET_lantiq
   FILES:=$(PKG_BUILD_DIR)/src/drv_vmmc.ko
   AUTOLOAD:=$(call AutoLoad,25,drv_vmmc)
   MAINTAINER:=John Crispin <blogic@openwrt.org>
index c1021f3594cd1667a81ecd1b11297cf746f69ad2..4f385723aba32830dc86dc63c77e92b88a456102 100644 (file)
@@ -18,6 +18,8 @@ PKG_INSTALL:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/pjproject-$(PKG_VERSION)
 
+PKG_BUILD_DEPENDS:=TARGET_lantiq:kmod-ltq-tapi TARGET_lantiq:kmod-ltq-vmmc
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pjsip-template
@@ -64,7 +66,7 @@ EXTRA_CFLAGS:=-I$(STAGING_DIR)/usr/include/drv_tapi -I$(STAGING_DIR)/usr/include
 endif
 
 Package/pjsip-oss=$(call Package/pjsip-template,oss,)
-Package/pjsip-ltq-tapi=$(call Package/pjsip-template,ltq-tapi,@TARGET_lantiq +TARGET_lantiq:kmod-ltq-tapi +TARGET_lantiq:kmod-ltq-vmmc)
+Package/pjsip-ltq-tapi=$(call Package/pjsip-template,ltq-tapi,@TARGET_lantiq +kmod-ltq-tapi +kmod-ltq-vmmc)
 
 define Build/Prepare
        $(PKG_UNPACK)