mpc85xx: p1020: convert Aerohive AP330/AP350 to simpleImage
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 7 Mar 2024 21:43:41 +0000 (22:43 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 8 Mar 2024 16:24:14 +0000 (17:24 +0100)
with 6.1, the kernel no longer fitted into the 16 MiB and
kicking down the can and increasing KERNEL_SIZE to 20 MiB
didn't help as the device failed to boot.

Using 'kernel-bin | gzip | uimage gzip' didn't work since the
uboot does not have enough heap to decompress these big kernels.

And finally playing around with uboot was more a hassle than
converting this device to take the simpleImage-boot-route in
the future.

Note: The device now takes even longer on the first boot-up after
the flash due to JFFS2 initializing all the remaining flash.
Be prepared to wait up to 10 minutes before the green status LED
stops blinking and will shine a solid green!

(On the plus site: the device now has ~10 MiB of additional
space for rootfs+rootfs_data).

Note2: This patch includes a kernel patch refresh.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
13 files changed:
target/linux/mpc85xx/files/arch/powerpc/boot/dts/hiveap-330.dts
target/linux/mpc85xx/image/p1020.mk
target/linux/mpc85xx/p1020/target.mk
target/linux/mpc85xx/patches-5.15/101-powerpc-85xx-hiveap-330-support.patch
target/linux/mpc85xx/patches-5.15/107-powerpc-85xx-add-ws-ap3825i-support.patch
target/linux/mpc85xx/patches-5.15/109-powerpc-85xx-add-ws-ap3715i-support.patch
target/linux/mpc85xx/patches-5.15/110-powerpc-85xx-br200-wp-support.patch
target/linux/mpc85xx/patches-5.15/900-powerpc-bootwrapper-disable-uImage-generation.patch
target/linux/mpc85xx/patches-6.1/101-powerpc-85xx-hiveap-330-support.patch
target/linux/mpc85xx/patches-6.1/107-powerpc-85xx-add-ws-ap3825i-support.patch
target/linux/mpc85xx/patches-6.1/109-powerpc-85xx-add-ws-ap3715i-support.patch
target/linux/mpc85xx/patches-6.1/110-powerpc-85xx-br200-wp-support.patch
target/linux/mpc85xx/patches-6.1/900-powerpc-bootwrapper-disable-uImage-generation.patch

index 6ad5c4ccd6d4132684fe2fca4c60cad739e4e833..7ba282766e2b61bcafd688adb2c9608730e6b0b3 100644 (file)
                spi0 = &spi0;
        };
 
+       chosen {
+               /*
+                * not yet implemented.
+                * stdout-path = &serial0 ":9600n8";
+                * <https://www.spinics.net/lists/devicetree-compiler/msg02487.html>
+                *
+                * this should work... but it doesn't because CONFIG_CMDLINE in our
+                * OpenWrt's target config sets "console=ttyS0,115200"
+                * stdout-path = "/soc@ffe00000/serial@4500:9600n8";
+                */
+
+               bootargs = "console=ttyS0,9600n8";
+       };
+
+       cpus {
+               PowerPC,P1020@0 {
+                       i-cache-sets = <0x80>;
+                       i-cache-size = <0x8000>;
+                       i-cache-block-size = <0x20>;
+                       d-cache-sets = <0x80>;
+                       d-cache-size = <0x8000>;
+                       d-cache-block-size = <0x20>;
+                       status = "okay";
+                       clock-frequency = <533333328>; /* 533.33 MHz */
+                       bus-frequency = <266666664>;  /* 266.66 MHz */
+                       timebase-frequency = <33333333>; /* 33.33 MHz */
+               };
+
+               PowerPC,P1020@1 {
+                       i-cache-sets = <0x80>;
+                       i-cache-size = <0x8000>;
+                       i-cache-block-size = <0x20>;
+                       d-cache-sets = <0x80>;
+                       d-cache-size = <0x8000>;
+                       d-cache-block-size = <0x20>;
+                       cpu-release-addr = <0x00 0xffff240>;
+                       enable-method = "spin-table";
+                       status = "disabled";
+                       clock-frequency = <533333328>;
+                       bus-frequency = <266666664>;
+                       timebase-frequency = <33333333>;
+               };
+       };
+
        memory {
+               #address-cells = <2>;
+               #size-cells = <2>;
+
+               reg = <0x00 0x00 0x00 0x10000000>;
                device_type = "memory";
        };
 
+       /*
+        * Usually, u-boot provided /memreserve/ properties by adding them during boot.
+        * these have been converted to reserved-memory entries.
+        */
+       reserved-memory {
+               #address-cells = <2>;
+               #size-cells = <2>;
+               ranges;
+
+               /*
+                * /memreserve/   0x0000000000ffa000 0x0000000000004000;
+                * The kernel complains when booting:
+                *
+                * | OF: fdt: Reserved memory: failed to reserve memory for node
+                *              'firmware@ffa000': base 0x00ffa000, size 0 MiB
+                *
+                * But this likely uboot's bootargs + modified DTB. And if so, we don't care.
+                * This is because we rely on our own dtb that's in the simpleImage.
+                *
+                * Note: This is backed up by u-boot. just before the kernel executes
+                *       it prints this final line:
+                *       |  Loading Device Tree to 00ff9000, end 00fff1c4 ... OK
+                *
+                * firmware@ffa000 {
+                *      reg = <0x0 0xffa000 0x0 0x4000>;
+                *      no-map;
+                * };
+                */
+
+               // /memreserve/   0x000000000fe2f000 0x0000000000000021;
+               firmware@fe2f000 {
+                       reg = <0x0 0xfe2f000 0x0 0x21>;
+                       no-map;
+               };
+
+               /*
+                * /memreserve/   0x000000000ffff000 0x0000000000001000;
+                * that's the spin-table - see second CPU core binding.
+                */
+               firmware@ffff000 {
+                       reg = <0x0 0xffff000 0x0 0x1000>;
+                       no-map;
+               };
+       };
+
        board_lbc: lbc: localbus@ffe05000 {
+               bus-frequency = <16666666>; /* 16.66 MHz */
                reg = <0 0xffe05000 0 0x1000>;
                ranges = <0x0 0x0 0x0 0xec000000 0x4000000>;
 
 
        board_soc: soc: soc@ffe00000 {
                ranges = <0x0 0x0 0xffe00000 0x100000>;
+               bus-frequency = <266666664>;
 
                spi0: spi@7000 {
+                       #address-cells = <1>;
+                       #size-cells = <0>;
+
                        temperature-sensor@1 {
                                compatible = "ti,tmp125";
                                reg = <1>;
                                compatible = "national,lp5521";
                                reg = <0x32>;
                                clock-mode = /bits/ 8 <2>;
+                               #address-cells = <1>;
+                               #size-cells = <0>;
+
 #if 1
                                led_fault_red: led@0 {
                                        reg = <0>;
                };
 
                enet0: ethernet@b0000 {
+                       rx-stash-idx = <0x00>;
+                       rx-stash-len = <0x60>;
+                       bd-stash;
                        status = "okay";
                        phy-handle = <&phy0>;
                        phy-connection-type = "rgmii-id";
                };
 
                enet2: ethernet@b2000 {
+                       rx-stash-idx = <0x00>;
+                       rx-stash-len = <0x60>;
+                       bd-stash;
                        status = "okay";
                        phy-handle = <&phy1>;
                        phy-connection-type = "rgmii-id";
 
        pci0: pcie@ffe09000 {
                reg = <0x0 0xffe09000 0x0 0x1000>;
-               ranges = <0x2000000 0x0 0xa0000000 0x0 0xa0000000 0x0 0x20000000
-                       0x1000000 0x0 0x00000000 0x0 0xffc30000 0x0 0x10000>;
+               ranges = <0x2000000 0x0 0xa0000000 0x0 0xa0000000 0x0 0x20000000>,
+                        <0x1000000 0x0 0x00000000 0x0 0xffc30000 0x0 0x10000>;
                pcie@0 {
-                       ranges = <0x2000000 0x0 0xa0000000
-                                 0x2000000 0x0 0xa0000000
-                                 0x0 0x20000000
-
-                                 0x1000000 0x0 0x0
-                                 0x1000000 0x0 0x0
-                                 0x0 0x100000>;
+                       ranges = <0x2000000 0x0 0xa0000000 0x2000000 0x0 0xa0000000 0x0 0x20000000>,
+                                <0x1000000 0x0 0x00000000 0x1000000 0x0 0x00000000 0x0 0x00100000>;
                };
        };
 
        pci1: pcie@ffe0a000 {
                reg = <0x0 0xffe0a000 0x0 0x1000>;
-               ranges = <0x2000000 0x0 0xc0000000 0x0 0xc0000000 0x0 0x20000000
-                     0x1000000 0x0 0x00000000 0x0 0xffc20000 0x0 0x10000>;
-               pcie@0 {
-                       ranges = <0x2000000 0x0 0xc0000000
-                             0x2000000 0x0 0xc0000000
-                                 0x0 0x20000000
+               ranges = <0x2000000 0x0 0xc0000000 0x0 0xc0000000 0x0 0x20000000>,
+                        <0x1000000 0x0 0x00000000 0x0 0xffc20000 0x0 0x10000>;
 
-                                 0x1000000 0x0 0x0
-                                 0x1000000 0x0 0x0
-                                 0x0 0x100000>;
+               pcie@0 {
+                       ranges = <0x2000000 0x0 0xc0000000 0x2000000 0x0 0xc0000000 0x0 0x20000000>,
+                                <0x1000000 0x0 0x00000000 0x1000000 0x0 0x00000000 0x0 0x00100000>;
                };
        };
 
                };
        };
 };
+
 /include/ "fsl/p1020si-post.dtsi"
+&serial0 {
+       clock-frequency = <266666664>;
+};
+
+&serial1 {
+       clock-frequency = <266666664>;
+};
 
 /*
  * For the OpenWrt 22.03 release, since Linux 5.10.138 now uses
index d3d7f93ddda4b46d7f45651923c5033cd21d68c4..1d18a63dc023821b6d4d3f28d67636b91cad6e50 100644 (file)
@@ -18,9 +18,14 @@ define Device/aerohive_hiveap-330
   DEVICE_PACKAGES := kmod-tpm-i2c-atmel kmod-hwmon-lm70
   BLOCKSIZE := 128k
   KERNEL := kernel-bin | uImage none
-  KERNEL_INITRAMFS := kernel-bin | MultiImage none
+  KERNEL_INITRAMFS := kernel-bin | uImage none
+  KERNEL_NAME := simpleImage.hiveap-330
   KERNEL_SIZE := 16m
   IMAGES := sysupgrade.bin
+  KERNEL_ENTRY := 0x1500000
+  KERNEL_LOADADDR := 0x1500000
+  # append-dtb is still needed, as otherwise u-boot bootm complains
+  # about not having a FDT to edit.
   IMAGE/sysupgrade.bin := append-dtb | pad-to 256k | append-kernel | \
        append-rootfs | pad-rootfs | check-size | append-metadata
   IMAGE_SIZE = 63m
index 8770edb9a9146f6551f84abc48a6845e94c802bd..5a5d0bf07d6dd41bb03351488a20233de552ce1a 100644 (file)
@@ -1,5 +1,5 @@
 BOARDNAME:=P1020
-KERNEL_IMAGES:=simpleImage.ws-ap3825i
+KERNEL_IMAGES:=simpleImage.ws-ap3825i simpleImage.hiveap-330
 
 define Target/Description
        Build firmware images for Freescale P1020 based boards.
index da95cd2716210954129a953b288d567e49573443..7d531e4ffc7ad67851d6f1e5914ff613ddfdabee 100644 (file)
  obj-$(CONFIG_MPC8540_ADS) += mpc85xx_ads.o
  obj-$(CONFIG_MPC8560_ADS) += mpc85xx_ads.o
  obj-$(CONFIG_MPC85xx_CDS) += mpc85xx_cds.o
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -163,6 +163,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+ src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
+ src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
+ src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
++src-plat-$(CONFIG_HIVEAP_330) += simpleboot.c fixed-head.S
+ src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
+ src-plat-$(CONFIG_PPC_MICROWATT) += fixed-head.S microwatt.c
+@@ -344,6 +345,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
+ image-$(CONFIG_TQM8555)                       += cuImage.tqm8555
+ image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
+ image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
++image-$(CONFIG_HIVEAP_330)            += simpleImage.hiveap-330
+ image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
+ # Board ports in arch/powerpc/platform/86xx/Kconfig
+ image-$(CONFIG_MVME7100)                += dtbImage.mvme7100
+--- a/arch/powerpc/boot/wrapper
++++ b/arch/powerpc/boot/wrapper
+@@ -339,6 +339,7 @@ adder875-redboot)
+     platformo="$object/fixed-head.o $object/redboot-8xx.o"
+     binary=y
+     ;;
++simpleboot-hiveap-330|\
+ simpleboot-tl-wdr4900-v1)
+     platformo="$object/fixed-head.o $object/simpleboot.o"
+     link_address='0x1500000'
index 51da0f4527f4c76ca144b1e7cf61653cfec5a71c..9ccd9e877f6bed4865d528914e0f706217329fa6 100644 (file)
@@ -37,17 +37,17 @@ WS-AP3825i AP.
  obj-$(CONFIG_RED_15W_REV1)    += red15w_rev1.o
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -164,6 +164,7 @@ src-plat-$(CONFIG_PPC_POWERNV) += pserie
- src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
+@@ -165,6 +165,7 @@ src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) +=
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
+ src-plat-$(CONFIG_HIVEAP_330) += simpleboot.c fixed-head.S
  src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
 +src-plat-$(CONFIG_WS_AP3825I) += simpleboot.c fixed-head.S
  
  src-plat-$(CONFIG_PPC_MICROWATT) += fixed-head.S microwatt.c
  
-@@ -345,6 +346,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
- image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
+@@ -347,6 +348,7 @@ image-$(CONFIG_TQM8560)                    += cuImage.tqm
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
+ image-$(CONFIG_HIVEAP_330)            += simpleImage.hiveap-330
  image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
 +image-$(CONFIG_WS_AP3825I)            += simpleImage.ws-ap3825i
  # Board ports in arch/powerpc/platform/86xx/Kconfig
@@ -55,10 +55,10 @@ WS-AP3825i AP.
  
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -339,6 +339,7 @@ adder875-redboot)
-     platformo="$object/fixed-head.o $object/redboot-8xx.o"
+@@ -340,6 +340,7 @@ adder875-redboot)
      binary=y
      ;;
+ simpleboot-hiveap-330|\
 +simpleboot-ws-ap3825i|\
  simpleboot-tl-wdr4900-v1)
      platformo="$object/fixed-head.o $object/simpleboot.o"
index 692cef0417db828122453d319f6e1282c9018f5f..59f31842955ef3bc7e8c94526fe0d0873e2b3a4c 100644 (file)
@@ -30,9 +30,9 @@
  obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -346,6 +346,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
- image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
+@@ -348,6 +348,7 @@ image-$(CONFIG_TQM8560)                    += cuImage.tqm
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
+ image-$(CONFIG_HIVEAP_330)            += simpleImage.hiveap-330
  image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
 +image-$(CONFIG_WS_AP3715I)            += simpleImage.ws-ap3715i
  image-$(CONFIG_WS_AP3825I)            += simpleImage.ws-ap3825i
  image-$(CONFIG_MVME7100)                += dtbImage.mvme7100
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -339,6 +339,7 @@ adder875-redboot)
-     platformo="$object/fixed-head.o $object/redboot-8xx.o"
+@@ -340,6 +340,7 @@ adder875-redboot)
      binary=y
      ;;
+ simpleboot-hiveap-330|\
 +simpleboot-ws-ap3715i|\
  simpleboot-ws-ap3825i|\
  simpleboot-tl-wdr4900-v1)
index eb70a4c4c47890148e8e50519e479aa36593fe93..21a26f1a73fb112f2769ed38f8e3f55e7d82cab3 100644 (file)
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
 +src-plat-$(CONFIG_BR200_WP) += simpleboot.c fixed-head.S
+ src-plat-$(CONFIG_HIVEAP_330) += simpleboot.c fixed-head.S
  src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
  src-plat-$(CONFIG_WS_AP3825I) += simpleboot.c fixed-head.S
-@@ -345,6 +346,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
+@@ -346,6 +347,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
  image-$(CONFIG_TQM8555)                       += cuImage.tqm8555
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
 +image-$(CONFIG_BR200_WP)              += simpleImage.br200-wp
+ image-$(CONFIG_HIVEAP_330)            += simpleImage.hiveap-330
  image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
  image-$(CONFIG_WS_AP3715I)            += simpleImage.ws-ap3715i
- image-$(CONFIG_WS_AP3825I)            += simpleImage.ws-ap3825i
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
 @@ -339,6 +339,7 @@ adder875-redboot)
@@ -52,6 +52,6 @@
      binary=y
      ;;
 +simpleboot-br200-wp|\
+ simpleboot-hiveap-330|\
  simpleboot-ws-ap3715i|\
  simpleboot-ws-ap3825i|\
- simpleboot-tl-wdr4900-v1)
index 1af5aefe0bdda14948f1a526dc255a0a9370582b..7f99bd5211b83a9f157a9f5f0634b488c1503b0d 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -274,7 +274,6 @@ image-$(CONFIG_PPC_CHRP)           += zImage.chrp
+@@ -275,7 +275,6 @@ image-$(CONFIG_PPC_CHRP)           += zImage.chrp
  image-$(CONFIG_PPC_EFIKA)             += zImage.chrp
  image-$(CONFIG_PPC_PMAC)              += zImage.pmac
  image-$(CONFIG_PPC_HOLLY)             += dtbImage.holly
@@ -24,7 +24,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  image-$(CONFIG_EPAPR_BOOT)            += zImage.epapr
  
  #
-@@ -409,15 +408,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
+@@ -411,15 +410,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
  $(obj)/vmlinux.strip: vmlinux
        $(STRIP) -s -R .comment $< -o $@
  
index fe8745361d081d2230fee51c25b71d2a19ee7da4..e8b6632f2b052ef502fdffec9e0adc43e22f9024 100644 (file)
  obj-$(CONFIG_MPC8540_ADS) += mpc85xx_ads.o
  obj-$(CONFIG_MPC8560_ADS) += mpc85xx_ads.o
  obj-$(CONFIG_MPC85xx_CDS) += mpc85xx_cds.o
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -179,6 +179,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+ src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
+ src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
+ src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
++src-plat-$(CONFIG_HIVEAP_330) += simpleboot.c fixed-head.S
+ src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
+ src-plat-$(CONFIG_PPC_MICROWATT) += fixed-head.S microwatt.c
+@@ -360,6 +361,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
+ image-$(CONFIG_TQM8555)                       += cuImage.tqm8555
+ image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
+ image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
++image-$(CONFIG_HIVEAP_330)            += simpleImage.hiveap-330
+ image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
+ # Board ports in arch/powerpc/platform/86xx/Kconfig
+ image-$(CONFIG_MVME7100)                += dtbImage.mvme7100
+--- a/arch/powerpc/boot/wrapper
++++ b/arch/powerpc/boot/wrapper
+@@ -341,6 +341,7 @@ adder875-redboot)
+     platformo="$object/fixed-head.o $object/redboot-8xx.o"
+     binary=y
+     ;;
++simpleboot-hiveap-330|\
+ simpleboot-tl-wdr4900-v1)
+     platformo="$object/fixed-head.o $object/simpleboot.o"
+     link_address='0x1500000'
index fb697e1d1fbc68ca81485972805cdc8f6459d251..63e7e46bbc5f00de7c6aaf9dc6509a3f8c25c9ce 100644 (file)
@@ -37,17 +37,17 @@ WS-AP3825i AP.
  obj-$(CONFIG_RED_15W_REV1)    += red15w_rev1.o
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -180,6 +180,7 @@ src-plat-$(CONFIG_PPC_POWERNV) += pserie
- src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
+@@ -181,6 +181,7 @@ src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) +=
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
+ src-plat-$(CONFIG_HIVEAP_330) += simpleboot.c fixed-head.S
  src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
 +src-plat-$(CONFIG_WS_AP3825I) += simpleboot.c fixed-head.S
  
  src-plat-$(CONFIG_PPC_MICROWATT) += fixed-head.S microwatt.c
  
-@@ -361,6 +362,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
- image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
+@@ -363,6 +364,7 @@ image-$(CONFIG_TQM8560)                    += cuImage.tqm
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
+ image-$(CONFIG_HIVEAP_330)            += simpleImage.hiveap-330
  image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
 +image-$(CONFIG_WS_AP3825I)            += simpleImage.ws-ap3825i
  # Board ports in arch/powerpc/platform/86xx/Kconfig
@@ -55,10 +55,10 @@ WS-AP3825i AP.
  
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -341,6 +341,7 @@ adder875-redboot)
-     platformo="$object/fixed-head.o $object/redboot-8xx.o"
+@@ -342,6 +342,7 @@ adder875-redboot)
      binary=y
      ;;
+ simpleboot-hiveap-330|\
 +simpleboot-ws-ap3825i|\
  simpleboot-tl-wdr4900-v1)
      platformo="$object/fixed-head.o $object/simpleboot.o"
index 8f34f14d5400e28f87f8efbab1b3da57ed6f0aa7..f8e33ae63791c798775a70b2d0e379c8ffdaa480 100644 (file)
@@ -30,9 +30,9 @@
  obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -362,6 +362,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
- image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
+@@ -364,6 +364,7 @@ image-$(CONFIG_TQM8560)                    += cuImage.tqm
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
+ image-$(CONFIG_HIVEAP_330)            += simpleImage.hiveap-330
  image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
 +image-$(CONFIG_WS_AP3715I)            += simpleImage.ws-ap3715i
  image-$(CONFIG_WS_AP3825I)            += simpleImage.ws-ap3825i
  image-$(CONFIG_MVME7100)                += dtbImage.mvme7100
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -341,6 +341,7 @@ adder875-redboot)
-     platformo="$object/fixed-head.o $object/redboot-8xx.o"
+@@ -342,6 +342,7 @@ adder875-redboot)
      binary=y
      ;;
+ simpleboot-hiveap-330|\
 +simpleboot-ws-ap3715i|\
  simpleboot-ws-ap3825i|\
  simpleboot-tl-wdr4900-v1)
index 430af1efb133f7769876a41ac41b3e80f97040d3..b063b3dab742f4c547ccaa48209f79df421cf3d0 100644 (file)
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
 +src-plat-$(CONFIG_BR200_WP) += simpleboot.c fixed-head.S
+ src-plat-$(CONFIG_HIVEAP_330) += simpleboot.c fixed-head.S
  src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
  src-plat-$(CONFIG_WS_AP3825I) += simpleboot.c fixed-head.S
-@@ -361,6 +362,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
+@@ -362,6 +363,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
  image-$(CONFIG_TQM8555)                       += cuImage.tqm8555
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
 +image-$(CONFIG_BR200_WP)              += simpleImage.br200-wp
+ image-$(CONFIG_HIVEAP_330)            += simpleImage.hiveap-330
  image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
  image-$(CONFIG_WS_AP3715I)            += simpleImage.ws-ap3715i
- image-$(CONFIG_WS_AP3825I)            += simpleImage.ws-ap3825i
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
 @@ -341,6 +341,7 @@ adder875-redboot)
@@ -52,6 +52,6 @@
      binary=y
      ;;
 +simpleboot-br200-wp|\
+ simpleboot-hiveap-330|\
  simpleboot-ws-ap3715i|\
  simpleboot-ws-ap3825i|\
- simpleboot-tl-wdr4900-v1)
index f1e0f73f88cb5b07559a473bc1bd771aad1656ce..648aa0421d68f7f6a2191dc761283b753c5ae361 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -290,7 +290,6 @@ image-$(CONFIG_PPC_CHRP)           += zImage.chrp
+@@ -291,7 +291,6 @@ image-$(CONFIG_PPC_CHRP)           += zImage.chrp
  image-$(CONFIG_PPC_EFIKA)             += zImage.chrp
  image-$(CONFIG_PPC_PMAC)              += zImage.pmac
  image-$(CONFIG_PPC_HOLLY)             += dtbImage.holly
@@ -24,7 +24,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  image-$(CONFIG_EPAPR_BOOT)            += zImage.epapr
  
  #
-@@ -425,15 +424,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
+@@ -427,15 +426,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
  $(obj)/vmlinux.strip: vmlinux
        $(STRIP) -s -R .comment $< -o $@