mediatek: new target mt7622-ubnt-unifi-6-lr-v1
authorHenrik Riomar <henrik.riomar@gmail.com>
Tue, 31 May 2022 17:18:06 +0000 (19:18 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 11 Jun 2022 18:50:26 +0000 (19:50 +0100)
Based on current mt7622-ubnt-unifi-6-lr, this is a preparation for
adding a v2 version of this target

* v1 - with led-bar
* v2 - two simple GPIO connected LEDs (in later commits)

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
[added SUPPORTED_DEVICES for compatibility with existing setups]
Signed-off-by: Henrik Riomar <henrik.riomar@gmail.com>
target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-ubootmod.dts
target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v1.dts [new file with mode: 0644]
target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v1.dtsi [new file with mode: 0644]
target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr.dts [deleted file]
target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr.dtsi
target/linux/mediatek/image/mt7622.mk

index e573d30912f4660b951d26663d6bc8f3d75c2f4c..8a9d0a1887cdc7ba707018fce55f2be82e61d25a 100644 (file)
@@ -1,6 +1,6 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 
-#include "mt7622-ubnt-unifi-6-lr.dtsi"
+#include "mt7622-ubnt-unifi-6-lr-v1.dtsi"
 
 / {
        model = "Ubiquiti UniFi 6 LR (U-Boot mod)";
diff --git a/target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v1.dts b/target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v1.dts
new file mode 100644 (file)
index 0000000..d0048d4
--- /dev/null
@@ -0,0 +1,100 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7622-ubnt-unifi-6-lr-v1.dtsi"
+
+/ {
+       model = "Ubiquiti UniFi 6 LR v1";
+       compatible = "ubnt,unifi-6-lr", "mediatek,mt7622";
+};
+
+&nor_partitions {
+       partition@0 {
+               label = "preloader";
+               reg = <0x0 0x40000>;
+       };
+
+       partition@40000 {
+               label = "atf";
+               reg = <0x40000 0x20000>;
+       };
+
+       partition@60000 {
+               label = "u-boot";
+               reg = <0x60000 0x60000>;
+       };
+
+       partition@c0000 {
+               label = "u-boot-env";
+               reg = <0xc0000 0x10000>;
+       };
+
+       factory: partition@d0000 {
+               label = "factory";
+               reg = <0xd0000 0x40000>;
+               read-only;
+       };
+
+       eeprom: partition@110000 {
+               label = "eeprom";
+               reg = <0x110000 0x10000>;
+               read-only;
+       };
+
+       partition@120000 {
+               label = "bs";
+               reg = <0x120000 0x10000>;
+       };
+
+       partition@130000 {
+               label = "cfg";
+               reg = <0x130000 0x100000>;
+               read-only;
+       };
+
+       partition@230000 {
+               compatible = "denx,fit";
+               label = "firmware";
+               reg = <0x230000 0x1ee0000>;
+       };
+
+       partition@2110000 {
+               label = "kernel1";
+               reg = <0x2110000 0x1ee0000>;
+       };
+};
+
+&wmac {
+       mediatek,mtd-eeprom = <&factory 0x0>;
+       nvmem-cells = <&macaddr_eeprom_0>;
+       nvmem-cell-names = "mac-address";
+       status = "okay";
+};
+
+&slot0 {
+       wifi@0,0 {
+               reg = <0x0 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x20000>;
+               nvmem-cells = <&macaddr_eeprom_6>;
+               nvmem-cell-names = "mac-address";
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&gmac0 {
+       nvmem-cells = <&macaddr_eeprom_0>;
+       nvmem-cell-names = "mac-address";
+};
+
+&eeprom {
+       compatible = "nvmem-cells";
+       #address-cells = <1>;
+       #size-cells = <1>;
+
+       macaddr_eeprom_0: macaddr@0 {
+               reg = <0x0 0x6>;
+       };
+
+       macaddr_eeprom_6: macaddr@6 {
+               reg = <0x6 0x6>;
+       };
+};
diff --git a/target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v1.dtsi b/target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v1.dtsi
new file mode 100644 (file)
index 0000000..8f15d3f
--- /dev/null
@@ -0,0 +1,27 @@
+#include "mt7622-ubnt-unifi-6-lr.dtsi"
+
+&i2c0 {
+       pinctrl-names = "default";
+       pinctrl-0 = <&i2c0_pins>;
+       status = "okay";
+
+       led-controller@30 {
+               compatible = "ubnt,ledbar";
+               reg = <0x30>;
+
+               enable-gpio = <&pio 59 0>;
+
+               red {
+                       label = "red";
+               };
+
+               green {
+                       label = "green";
+               };
+
+               led_blue: blue {
+                       label = "blue";
+               };
+       };
+};
+
diff --git a/target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr.dts b/target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr.dts
deleted file mode 100644 (file)
index 9b676b4..0000000
+++ /dev/null
@@ -1,100 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "mt7622-ubnt-unifi-6-lr.dtsi"
-
-/ {
-       model = "Ubiquiti UniFi 6 LR";
-       compatible = "ubnt,unifi-6-lr", "mediatek,mt7622";
-};
-
-&nor_partitions {
-       partition@0 {
-               label = "preloader";
-               reg = <0x0 0x40000>;
-       };
-
-       partition@40000 {
-               label = "atf";
-               reg = <0x40000 0x20000>;
-       };
-
-       partition@60000 {
-               label = "u-boot";
-               reg = <0x60000 0x60000>;
-       };
-
-       partition@c0000 {
-               label = "u-boot-env";
-               reg = <0xc0000 0x10000>;
-       };
-
-       factory: partition@d0000 {
-               label = "factory";
-               reg = <0xd0000 0x40000>;
-               read-only;
-       };
-
-       eeprom: partition@110000 {
-               label = "eeprom";
-               reg = <0x110000 0x10000>;
-               read-only;
-       };
-
-       partition@120000 {
-               label = "bs";
-               reg = <0x120000 0x10000>;
-       };
-
-       partition@130000 {
-               label = "cfg";
-               reg = <0x130000 0x100000>;
-               read-only;
-       };
-
-       partition@230000 {
-               compatible = "denx,fit";
-               label = "firmware";
-               reg = <0x230000 0x1ee0000>;
-       };
-
-       partition@2110000 {
-               label = "kernel1";
-               reg = <0x2110000 0x1ee0000>;
-       };
-};
-
-&wmac {
-       mediatek,mtd-eeprom = <&factory 0x0>;
-       nvmem-cells = <&macaddr_eeprom_0>;
-       nvmem-cell-names = "mac-address";
-       status = "okay";
-};
-
-&slot0 {
-       wifi@0,0 {
-               reg = <0x0 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x20000>;
-               nvmem-cells = <&macaddr_eeprom_6>;
-               nvmem-cell-names = "mac-address";
-               ieee80211-freq-limit = <5000000 6000000>;
-       };
-};
-
-&gmac0 {
-       nvmem-cells = <&macaddr_eeprom_0>;
-       nvmem-cell-names = "mac-address";
-};
-
-&eeprom {
-       compatible = "nvmem-cells";
-       #address-cells = <1>;
-       #size-cells = <1>;
-
-       macaddr_eeprom_0: macaddr@0 {
-               reg = <0x0 0x6>;
-       };
-
-       macaddr_eeprom_6: macaddr@6 {
-               reg = <0x6 0x6>;
-       };
-};
index ae587a11a0a7f03a365f3ae1a624e02416fd3b48..0827f18e4800bf82c1d1c688077c8aa5be6a2e86 100644 (file)
        /* MT7915 Bluetooth */
 };
 
-&i2c0 {
-       pinctrl-names = "default";
-       pinctrl-0 = <&i2c0_pins>;
-       status = "okay";
-
-       led-controller@30 {
-               compatible = "ubnt,ledbar";
-               reg = <0x30>;
-
-               enable-gpio = <&pio 59 0>;
-
-               red {
-                       label = "red";
-               };
-
-               green {
-                       label = "green";
-               };
-
-               led_blue: blue {
-                       label = "blue";
-               };
-       };
-};
-
 &watchdog {
        pinctrl-names = "default";
        pinctrl-0 = <&watchdog_pins>;
index aba8bdfe0ba622e80a7bb8ff4cd3570a0a517246..d6308f2ef63f0f533e2adc66adf93bcec7e772f2 100644 (file)
@@ -242,15 +242,17 @@ define Device/totolink_a8000ru
 endef
 TARGET_DEVICES += totolink_a8000ru
 
-define Device/ubnt_unifi-6-lr
+define Device/ubnt_unifi-6-lr-v1
   DEVICE_VENDOR := Ubiquiti
   DEVICE_MODEL := UniFi 6 LR
+  DEVICE_VARIANT := v1
   DEVICE_DTS_CONFIG := config@1
-  DEVICE_DTS := mt7622-ubnt-unifi-6-lr
+  DEVICE_DTS := mt7622-ubnt-unifi-6-lr-v1
   DEVICE_DTS_DIR := ../dts
   DEVICE_PACKAGES := kmod-mt7915e kmod-leds-ubnt-ledbar
+  SUPPORTED_DEVICES += ubnt,unifi-6-lr
 endef
-TARGET_DEVICES += ubnt_unifi-6-lr
+TARGET_DEVICES += ubnt_unifi-6-lr-v1
 
 define Device/ubnt_unifi-6-lr-ubootmod
   DEVICE_VENDOR := Ubiquiti