uboot-sunxi: bump to 2020.07
authorStijn Tintel <stijn@linux-ipv6.be>
Wed, 21 Dec 2022 20:00:49 +0000 (22:00 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Fri, 31 Mar 2023 22:22:19 +0000 (01:22 +0300)
This is the newest release where 210-sunxi-deactivate-binman.patch still
applies.

Tested on A64-Olinuxino-eMMC.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
13 files changed:
package/boot/uboot-sunxi/Makefile
package/boot/uboot-sunxi/patches/003-add-theobroma-a31-pangolin.patch
package/boot/uboot-sunxi/patches/062-A20-improve-gmac-upload.patch
package/boot/uboot-sunxi/patches/091-sun6i-sync-PLL1-multdiv-with-Boot1.patch
package/boot/uboot-sunxi/patches/093-sun6i-fix-PLL-LDO-voltselect.patch
package/boot/uboot-sunxi/patches/101-sun6i-support-console-on-UART2.patch
package/boot/uboot-sunxi/patches/200-mkimage-check-environment-for-dtc-binary-location.patch
package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch
package/boot/uboot-sunxi/patches/230-disable-axp209-on-a13-olinuxino.diff
package/boot/uboot-sunxi/patches/250-sun8i-h3-zeropi-add-device-tree.patch
package/boot/uboot-sunxi/patches/252-sunxi-h3-add-support-for-nanopi-r1.patch
package/boot/uboot-sunxi/patches/253-sunxi-h5-add-support-for-nanopi-r1s-h5.patch
package/boot/uboot-sunxi/patches/270-arm-sunxi-increase-SYS_MALLOC_F_LEN.patch [new file with mode: 0644]

index ae5d12e381f7a610a3990ec2b9f448e4531ac120..cb0c93281d4ee5b22a0c9aa9e0512972d14cd6c4 100644 (file)
@@ -9,9 +9,9 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-PKG_VERSION:=2020.04
+PKG_VERSION:=2020.07
 
-PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
+PKG_HASH:=c1f5bf9ee6bb6e648edbf19ce2ca9452f614b08a9f886f1a566aa42e8cf05f6a
 
 PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
index 29969a71abeb4cde0c487f1bda7635009a6593f0..fab06e6a8e712bc971a6614adb4607ecdfdb50c7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -455,6 +455,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
+@@ -475,6 +475,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
        sun6i-a31-m9.dtb \
        sun6i-a31-mele-a1000g-quad.dtb \
        sun6i-a31-mixtile-loftq.dtb \
index b805bbd16937e841094382cd0450afca441acae1..27b476472cfefbd8d5f121107598b763358d206e 100644 (file)
@@ -2,7 +2,7 @@
 
 --- a/configs/A20-OLinuXino-Lime2_defconfig
 +++ b/configs/A20-OLinuXino-Lime2_defconfig
-@@ -22,6 +22,7 @@ CONFIG_ETH_DESIGNWARE=y
+@@ -23,6 +23,7 @@ CONFIG_ETH_DESIGNWARE=y
  CONFIG_RGMII=y
  CONFIG_MII=y
  CONFIG_SUN7I_GMAC=y
index f2a2b5e48fc94bc41f5aa7cc8fa68d2a741fcdf4..c637ccb792ac4538b93e6de31269b02f10824854 100644 (file)
@@ -14,7 +14,7 @@ More specifically, the following settings are now used:
 
 --- a/arch/arm/mach-sunxi/clock_sun6i.c
 +++ b/arch/arm/mach-sunxi/clock_sun6i.c
-@@ -112,11 +112,12 @@ void clock_set_pll1(unsigned int clk)
+@@ -114,11 +114,12 @@ void clock_set_pll1(unsigned int clk)
        struct sunxi_ccm_reg * const ccm =
                (struct sunxi_ccm_reg *)SUNXI_CCM_BASE;
        const int p = 0;
index b62209e1dcb96b5e45ec1d68eab494af54a41c98..c20db1352edfa3664671ca64541ddf0e244267de 100644 (file)
@@ -18,7 +18,7 @@ required setting for the PLL LDO is 1.37v as per the A31 manual.
 
 --- a/arch/arm/mach-sunxi/clock_sun6i.c
 +++ b/arch/arm/mach-sunxi/clock_sun6i.c
-@@ -25,13 +25,26 @@ void clock_init_safe(void)
+@@ -27,13 +27,26 @@ void clock_init_safe(void)
        struct sunxi_prcm_reg * const prcm =
                (struct sunxi_prcm_reg *)SUNXI_PRCM_BASE;
  
index 823c1568090b7acd80102173af9c7b6ffb3465ac..4cbf0ea1d8a733f3d21f6da1c3fda84f91927953 100644 (file)
@@ -6,7 +6,7 @@ Subject: ARM: sun6i: Support console on UART2 (GPG6/GPG7)
 
 --- a/arch/arm/mach-sunxi/board.c
 +++ b/arch/arm/mach-sunxi/board.c
-@@ -129,6 +129,10 @@ static int gpio_init(void)
+@@ -132,6 +132,10 @@ static int gpio_init(void)
        sunxi_gpio_set_cfgpin(SUNXI_GPG(3), SUN5I_GPG_UART1);
        sunxi_gpio_set_cfgpin(SUNXI_GPG(4), SUN5I_GPG_UART1);
        sunxi_gpio_set_pull(SUNXI_GPG(4), SUNXI_GPIO_PULL_UP);
index 482aa1a3693cb0c9997ebb8dca978386611d5cce..8aeae91ef46f94cedcb0498e5afd0fb449c7d8f9 100644 (file)
@@ -17,7 +17,7 @@ Cc: Simon Glass <sjg@chromium.org>
 
 --- a/tools/fit_image.c
 +++ b/tools/fit_image.c
-@@ -726,9 +726,14 @@ static int fit_handle_file(struct image_
+@@ -751,9 +751,14 @@ static int fit_handle_file(struct image_
                }
                *cmd = '\0';
        } else if (params->datafile) {
index 5efebbd056b092617720448025004d87d4f90700..48ddf6d318dba26350b9e5088c55672007cdae83 100644 (file)
@@ -12,7 +12,7 @@ old way of generating images.
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1555,8 +1555,10 @@ endif
+@@ -1607,8 +1607,10 @@ endif
  
  ifneq ($(CONFIG_ARCH_SUNXI),)
  ifeq ($(CONFIG_ARM64),)
@@ -27,7 +27,7 @@ old way of generating images.
        $(call if_changed,cat)
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -962,7 +962,6 @@ config ARCH_SOCFPGA
+@@ -995,7 +995,6 @@ config ARCH_SOCFPGA
  
  config ARCH_SUNXI
        bool "Support sunxi (Allwinner) SoCs"
index b846cbf506d206eda2474027da0359c94a49cb68..bc8bd144d6a4dbde3300672a7cf6b16154eccb3e 100644 (file)
@@ -8,7 +8,7 @@
  # CONFIG_VIDEO_HDMI is not set
  CONFIG_VIDEO_VGA_VIA_LCD=y
  CONFIG_VIDEO_VGA_VIA_LCD_FORCE_SYNC_ACTIVE_HIGH=y
-@@ -21,7 +20,7 @@ CONFIG_CMD_USB_MASS_STORAGE=y
+@@ -20,7 +19,7 @@ CONFIG_CMD_USB_MASS_STORAGE=y
  CONFIG_DEFAULT_DEVICE_TREE="sun5i-a13-olinuxino"
  CONFIG_DFU_RAM=y
  CONFIG_FASTBOOT_CMD_OEM_FORMAT=y
index 4250e4e9dbbe1584c89e57ddc722dc2cda5c8d15..152e6089516d508088d1f8f83fc4f845ad799fef 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -539,7 +539,8 @@ dtb-$(CONFIG_MACH_SUN8I_H3) += \
+@@ -559,7 +559,8 @@ dtb-$(CONFIG_MACH_SUN8I_H3) += \
        sun8i-h3-orangepi-plus.dtb \
        sun8i-h3-orangepi-plus2e.dtb \
        sun8i-h3-orangepi-zero-plus2.dtb \
index 058b29d95bfb25a87aa601d0b332a56a9d0d6a83..5b3a68c602b108ec0657a475b4db9026a669e280 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Jayantajit Gogoi <jayanta.gogoi525@gmail.com>
 
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -531,6 +531,7 @@ dtb-$(CONFIG_MACH_SUN8I_H3) += \
+@@ -551,6 +551,7 @@ dtb-$(CONFIG_MACH_SUN8I_H3) += \
        sun8i-h3-nanopi-m1-plus.dtb \
        sun8i-h3-nanopi-neo.dtb \
        sun8i-h3-nanopi-neo-air.dtb \
index c6a8cd70d189f4f0882e6df358118330b65443c7..2c8d5a94593a657f1de963aea1f13d1909dd710d 100644 (file)
@@ -25,11 +25,9 @@ Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
  create mode 100644 arch/arm/dts/sun50i-h5-nanopi-r1s-h5.dts
  create mode 100644 configs/nanopi_r1s_h5_defconfig
 
-diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
-index b8a382d1539..ed3d360bb10 100644
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -555,6 +555,7 @@ dtb-$(CONFIG_MACH_SUN50I_H5) += \
+@@ -575,6 +575,7 @@ dtb-$(CONFIG_MACH_SUN50I_H5) += \
        sun50i-h5-libretech-all-h5-cc.dtb \
        sun50i-h5-nanopi-neo2.dtb \
        sun50i-h5-nanopi-neo-plus2.dtb \
@@ -37,9 +35,6 @@ index b8a382d1539..ed3d360bb10 100644
        sun50i-h5-orangepi-zero-plus.dtb \
        sun50i-h5-orangepi-pc2.dtb \
        sun50i-h5-orangepi-prime.dtb \
-diff --git a/arch/arm/dts/sun50i-h5-nanopi-r1s-h5.dts b/arch/arm/dts/sun50i-h5-nanopi-r1s-h5.dts
-new file mode 100644
-index 00000000000..55bcdf8d1a0
 --- /dev/null
 +++ b/arch/arm/dts/sun50i-h5-nanopi-r1s-h5.dts
 @@ -0,0 +1,190 @@
@@ -233,8 +228,6 @@ index 00000000000..55bcdf8d1a0
 +      usb0_vbus-supply = <&reg_usb0_vbus>;
 +      status = "okay";
 +};
-diff --git a/board/sunxi/MAINTAINERS b/board/sunxi/MAINTAINERS
-index 2543c94de79..56a0ee3689b 100644
 --- a/board/sunxi/MAINTAINERS
 +++ b/board/sunxi/MAINTAINERS
 @@ -358,6 +358,11 @@ M:        Jelle van der Waa <jelle@vdwaa.nl>
@@ -249,9 +242,6 @@ index 2543c94de79..56a0ee3689b 100644
  NANOPI-A64 BOARD
  M:    Jagan Teki <jagan@amarulasolutions.com>
  S:    Maintained
-diff --git a/configs/nanopi_r1s_h5_defconfig b/configs/nanopi_r1s_h5_defconfig
-new file mode 100644
-index 00000000000..27cf172d72a
 --- /dev/null
 +++ b/configs/nanopi_r1s_h5_defconfig
 @@ -0,0 +1,14 @@
diff --git a/package/boot/uboot-sunxi/patches/270-arm-sunxi-increase-SYS_MALLOC_F_LEN.patch b/package/boot/uboot-sunxi/patches/270-arm-sunxi-increase-SYS_MALLOC_F_LEN.patch
new file mode 100644 (file)
index 0000000..6ce2be9
--- /dev/null
@@ -0,0 +1,29 @@
+From 20abdd7feefbb4fccef5c653e045911670237e8b Mon Sep 17 00:00:00 2001
+From: Stijn Tintel <stijn@linux-ipv6.be>
+Date: Thu, 22 Dec 2022 00:35:07 +0200
+Subject: [PATCH] arm: sunxi: increase SYS_MALLOC_F_LEN
+
+Version 2020.10 throws the following output after loading bl31:
+alloc space exhausted
+
+This has been fixed in v2022.07, but the change is too intrusive to
+backport. Instead, just modify the default for ARCH_SUNXI for now.
+
+See e05689242238 ("Kconfig: Change SYS_MALLOC_F_LEN default to 0x2000").
+
+Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
+---
+ Kconfig | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/Kconfig
++++ b/Kconfig
+@@ -146,7 +146,7 @@ config SYS_MALLOC_F_LEN
+       default 0x2000 if (ARCH_IMX8 || ARCH_IMX8M || ARCH_MX7 || \
+                          ARCH_MX7ULP || ARCH_MX6 || ARCH_MX5 || \
+                          ARCH_LS1012A || ARCH_LS1021A || ARCH_LS1043A || \
+-                         ARCH_LS1046A || ARCH_QEMU)
++                         ARCH_LS1046A || ARCH_QEMU || ARCH_SUNXI)
+       default 0x400
+       help
+         Before relocation, memory is very limited on many platforms. Still,