toolchain: glibc: Increase minimum kernel version to 5.4
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 28 Dec 2021 20:28:53 +0000 (21:28 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 7 Jan 2022 21:30:40 +0000 (22:30 +0100)
Increase the minimum kernel version needed by the glibc compiled for
OpenWrt to version 5.4. With this setting the glibc build will remove
all code needed to support older kernel versions.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
toolchain/glibc/common.mk

index aa8458360f5b3ffca090b44323bcbec019b94025..19610c1e904e8b983dfd51d82f8619021d51dcd8 100644 (file)
@@ -63,7 +63,7 @@ GLIBC_CONFIGURE:= \
                --$(if $(CONFIG_SOFT_FLOAT),without,with)-fp \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),--enable-stack-protector=yes) \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_STRONG),--enable-stack-protector=strong) \
-               --enable-kernel=4.14.0
+               --enable-kernel=5.4.0
 
 export libc_cv_ssp=no
 export libc_cv_ssp_strong=no