hostapd: fix broke noscan option for mesh
authorChristian Marangi <ansuelsmth@gmail.com>
Wed, 8 Nov 2023 15:46:12 +0000 (16:46 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 9 Nov 2023 14:58:37 +0000 (15:58 +0100)
noscan option for mesh was broken and actually never applied.

This is caused by a typo where ssid->noscan value is check instead of
conf->noscan resulting in the logic swapped and broken.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/network/services/hostapd/Makefile
package/network/services/hostapd/patches/301-mesh-noscan.patch

index 73ec5e198dad5034abdee654f8a4a74a427d87dd..f46c6275ef62d770cf2929cc2d367117e01e94c0 100644 (file)
@@ -5,7 +5,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 6b5416f0ea57ec73b85d7bd6d8cc17fc3465be8f..0e654febd5781c3645bc9477d6047658d8899c40 100644 (file)
@@ -24,8 +24,8 @@
                           frequency);
                goto out_free;
        }
-+      if (ssid->noscan)
-+              conf->noscan = 1;
++      if (conf->noscan)
++              ssid->noscan = 1;
  
        if (ssid->mesh_basic_rates == NULL) {
                /*