uboot-mvebu: don't default to enable a3700 builds
authorAndre Heider <a.heider@gmail.com>
Sun, 20 Sep 2020 05:51:31 +0000 (07:51 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 11 Oct 2020 14:38:16 +0000 (16:38 +0200)
u-boot binaries for this SoC are only required for the atf package,
disable them per default so they don't get build unnecessarily.

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/boot/uboot-mvebu/Makefile

index 3ee1e985f9edafc0cac9e25f95c6d669db79e2b9..903b9da5fff149ae99370f7def394adeca6103c1 100644 (file)
@@ -38,14 +38,12 @@ endef
 
 define U-Boot/espressobin
   NAME:=Marvell ESPRESSObin
-  BUILD_DEVICES:=globalscale_espressobin globalscale_espressobin-v7
   BUILD_SUBTARGET:=cortexa53
   UBOOT_CONFIG:=mvebu_espressobin-88f3720
 endef
 
 define U-Boot/espressobin-emmc
   NAME:=Marvell ESPRESSObin
-  BUILD_DEVICES:=globalscale_espressobin-emmc globalscale_espressobin-v7-emmc
   BUILD_SUBTARGET:=cortexa53
   UBOOT_CONFIG:=mvebu_espressobin-88f3720
   UBOOT_MAKE_FLAGS+=DEVICE_TREE=armada-3720-espressobin-emmc
@@ -53,7 +51,6 @@ endef
 
 define U-Boot/uDPU
   NAME:=Methode uDPU
-  BUILD_DEVICES:=methode_udpu
   BUILD_SUBTARGET:=cortexa53
 endef