kernel: bump 5.15 to 5.15.118
authorJohn Audia <therealgraysky@proton.me>
Wed, 21 Jun 2023 16:17:06 +0000 (12:17 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 23 Jun 2023 21:05:45 +0000 (23:05 +0200)
All patches automatically rebased.

Build system: x86_64
Build-tested: ramips/tplink_archer-a6-v3, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: ramips/tplink_archer-a6-v3, filogic/xiaomi_redmi-router-ax6000-ubootmod

Signed-off-by: John Audia <therealgraysky@proton.me>
31 files changed:
include/kernel-5.15
target/linux/ath25/patches-5.15/107-ar5312_gpio.patch
target/linux/ath79/patches-5.15/0032-MIPS-ath79-sanitize-symbols.patch
target/linux/ath79/patches-5.15/910-unaligned_access_hacks.patch
target/linux/bcm63xx/patches-5.15/322-MIPS-BCM63XX-switch-to-IRQ_DOMAIN.patch
target/linux/bmips/patches-5.15/202-mips-bmips-tweak-Kconfig-options.patch
target/linux/bmips/patches-5.15/600-mips-bmips-add-pci-support.patch
target/linux/generic/backport-5.15/600-v5.18-page_pool-Add-allocation-stats.patch
target/linux/generic/backport-5.15/707-v6.3-net-pcs-add-driver-for-MediaTek-SGMII-PCS.patch
target/linux/generic/backport-5.15/790-v6.4-0011-net-dsa-mt7530-introduce-separate-MDIO-driver.patch
target/linux/generic/backport-5.15/790-v6.4-0013-net-dsa-mt7530-introduce-driver-for-MT7988-built-in-.patch
target/linux/generic/backport-5.15/791-v6.2-01-net-phy-Add-driver-for-Motorcomm-yt8521-gigabit-ethernet.patch
target/linux/generic/backport-5.15/804-v5.18-0009-nvmem-Add-driver-for-OCOTP-in-Sunplus-SP7021.patch
target/linux/generic/backport-5.15/806-v6.0-0001-nvmem-microchip-otpc-add-support.patch
target/linux/generic/backport-5.15/810-v5.17-net-qmi_wwan-add-ZTE-MF286D-modem-19d2-1485.patch
target/linux/generic/hack-5.15/251-kconfig.patch
target/linux/generic/hack-5.15/280-rfkill-stubs.patch
target/linux/generic/hack-5.15/721-net-add-packet-mangeling.patch
target/linux/generic/hack-5.15/780-usb-net-MeigLink_modem_support.patch
target/linux/generic/pending-5.15/300-mips_expose_boot_raw.patch
target/linux/generic/pending-5.15/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/pending-5.15/760-net-core-add-optional-threading-for-backlog-processi.patch
target/linux/lantiq/patches-5.15/0152-lantiq-VPE.patch
target/linux/layerscape/patches-5.15/701-staging-add-fsl_ppfe-driver.patch
target/linux/mediatek/patches-5.15/730-net-phy-add-driver-for-MediaTek-SoC-built-in-GE-PHYs.patch
target/linux/mvebu/patches-5.15/907-MAINTAINERS-Add-an-entry-for-the-IEI-WT61P803-PUZZLE.patch
target/linux/octeon/patches-5.15/100-mips_image_cmdline_hack.patch
target/linux/ramips/patches-5.15/314-MIPS-add-bootargs-override-property.patch
target/linux/ramips/patches-5.15/315-owrt-hack-fix-mt7688-cache-issue.patch
target/linux/realtek/patches-5.15/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch
target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch

index fc637450b53dfa13dd991d505129d7ed333e56f5..aa4541d277a71eca02667da76e42a7797dae2b3d 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.15 = .117
-LINUX_KERNEL_HASH-5.15.117 = a9a8331f3c0e004b40a41f30d688b53bf85405597ac41c2c89be7f4fbcf7239f
+LINUX_VERSION-5.15 = .118
+LINUX_KERNEL_HASH-5.15.118 = 4e6bf4dadb04d5d11d1d4cc37c0eabcf33bc333b7dd3dc2143c3099a823eb5b3
index 4ad1d40facd2fbb1c5422c917eba0dc39d2fa123..e6e1290d35a4b8ba8de511f0b56e8f142ab9a311 100644 (file)
 +subsys_initcall(ar5312_gpio_init);
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -230,6 +230,7 @@ config ATH25
+@@ -231,6 +231,7 @@ config ATH25
        select CEVT_R4K
        select CSRC_R4K
        select DMA_NONCOHERENT
index 9bce3a2633305fa29dec4dc10b690b852809e30c..9d014434ecb339042fd6ad5451a4fa6b542d8567 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -256,6 +256,8 @@ config ATH79
+@@ -257,6 +257,8 @@ config ATH79
        select SYS_SUPPORTS_BIG_ENDIAN
        select SYS_SUPPORTS_MIPS16
        select SYS_SUPPORTS_ZBOOT_UART_PROM
index c2b646643e03896e7e2088ca96a3609f8760d9ed..ad685fb13b81f9b64d5ffda88a96dd0f2b4f94cd 100644 (file)
@@ -784,7 +784,7 @@ SVN-Revision: 35130
  
 --- a/include/net/neighbour.h
 +++ b/include/net/neighbour.h
-@@ -275,8 +275,10 @@ static inline bool neigh_key_eq128(const
+@@ -270,8 +270,10 @@ static inline bool neigh_key_eq128(const
        const u32 *n32 = (const u32 *)n->primary_key;
        const u32 *p32 = pkey;
  
index a848165ac5f5166f23500978f25d341b4b50271a..aff3f4a1a0e4b039f819352c36b94b0dd5de589c 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -331,6 +331,9 @@ config BCM63XX
+@@ -332,6 +332,9 @@ config BCM63XX
        select SYNC_R4K
        select DMA_NONCOHERENT
        select IRQ_MIPS_CPU
index c39df850a03448b21ae66ce73afc4cd66828ad79..eb3f1c1d5cecb7d5596432e2d049a3e6e521f0b8 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -274,25 +274,20 @@ config BMIPS_GENERIC
+@@ -275,25 +275,20 @@ config BMIPS_GENERIC
        select SYNC_R4K
        select COMMON_CLK
        select BCM6345_L1_IRQ
index 36b09105b7272176f4b8b27a07eda3b0693133c2..e2ca75a3930e71a9f2c6f56f9f7d761df16d7dc2 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -274,6 +274,7 @@ config BMIPS_GENERIC
+@@ -275,6 +275,7 @@ config BMIPS_GENERIC
        select SYNC_R4K
        select COMMON_CLK
        select BCM6345_L1_IRQ
index f4c5b9afee4dd9c4d112d8bc2cf41ea6eb97a2df..dca1062be9c95b7dfae4541a6bfd222f3d8e4e1d 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  struct page *page_pool_alloc_pages(struct page_pool *pool, gfp_t gfp);
 --- a/net/Kconfig
 +++ b/net/Kconfig
-@@ -434,6 +434,19 @@ config NET_DEVLINK
+@@ -432,6 +432,19 @@ config NET_DEVLINK
  config PAGE_POOL
        bool
  
index 9743a3f2062fb275d8b940af6086802d1b1696e4..3668a821ef758f106d5be0d4124afa9ed2183672 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Jakub Kicinski <kuba@kernel.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11789,6 +11789,14 @@ L:    netdev@vger.kernel.org
+@@ -11782,6 +11782,14 @@ L:    netdev@vger.kernel.org
  S:    Maintained
  F:    drivers/net/ethernet/mediatek/
  
index 51346d0620d3a97efd54746bdacd25f0bda1e4ef..d5ba5dbf66260c690f3556541658822c8e9e40f5 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11901,6 +11901,7 @@ M:     Landen Chao <Landen.Chao@mediatek.com
+@@ -11894,6 +11894,7 @@ M:     Landen Chao <Landen.Chao@mediatek.com
  M:    DENG Qingfang <dqfext@gmail.com>
  L:    netdev@vger.kernel.org
  S:    Maintained
index 00f4b25c44e1dedddc148e41ce55c49fa9882eae..b748fb5f8f19daa92ab09a13cf47d163de33e343 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11899,9 +11899,11 @@ MEDIATEK SWITCH DRIVER
+@@ -11892,9 +11892,11 @@ MEDIATEK SWITCH DRIVER
  M:    Sean Wang <sean.wang@mediatek.com>
  M:    Landen Chao <Landen.Chao@mediatek.com>
  M:    DENG Qingfang <dqfext@gmail.com>
index e2a0e25a7941f71c88b7a7ca7fb28e2e7ff84b94..eb51b410b544413c2728fbf266f39ab21f6216f6 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -12700,6 +12700,7 @@ F:     include/uapi/linux/meye.h
+@@ -12693,6 +12693,7 @@ F:     include/uapi/linux/meye.h
  
  MOTORCOMM PHY DRIVER
  M:    Peter Geis <pgwipeout@gmail.com>
index ae177e0cb036e65f54de082a041243d2c56daac0..6ad9257d60e4e18c26986ca33eed482cf9d094b4 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17965,6 +17965,11 @@ L:    netdev@vger.kernel.org
+@@ -17958,6 +17958,11 @@ L:    netdev@vger.kernel.org
  S:    Maintained
  F:    drivers/net/ethernet/dlink/sundance.c
  
index ad0460d4f36fdf328e650f4b852332ce6f9825ae..f7ea61626c506971a930800ec9f4522250b8ce14 100644 (file)
@@ -57,7 +57,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -12364,6 +12364,14 @@ S:    Supported
+@@ -12357,6 +12357,14 @@ S:    Supported
  F:    Documentation/devicetree/bindings/mtd/atmel-nand.txt
  F:    drivers/mtd/nand/raw/atmel/*
  
index 25802be7e3d03699bc959370cbb05e974217fb8f..41d3e121de195fe2927e915e5d97ecdda4d8f3c1 100644 (file)
@@ -49,7 +49,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/usb/qmi_wwan.c
 +++ b/drivers/net/usb/qmi_wwan.c
-@@ -1314,6 +1314,7 @@ static const struct usb_device_id produc
+@@ -1316,6 +1316,7 @@ static const struct usb_device_id produc
        {QMI_FIXED_INTF(0x19d2, 0x1426, 2)},    /* ZTE MF91 */
        {QMI_FIXED_INTF(0x19d2, 0x1428, 2)},    /* Telewell TW-LTE 4G v2 */
        {QMI_FIXED_INTF(0x19d2, 0x1432, 3)},    /* ZTE ME3620 */
index 0e24c3e8041f3474d141a52eae89240f9aacdc9e..9350e366d8668c2808ac73eb5ea2b0a05e307e35 100644 (file)
@@ -199,7 +199,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
        bool
 --- a/net/Kconfig
 +++ b/net/Kconfig
-@@ -432,7 +432,7 @@ config NET_DEVLINK
+@@ -430,7 +430,7 @@ config NET_DEVLINK
        default n
  
  config PAGE_POOL
index 7a650d132eb3aec49136b735b30651b371d85f4b..ff6638f7a05b4c62090d365fab8c3d06c23ed35e 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
   * @name: name of the struct -- the string is not copied internally
 --- a/net/Makefile
 +++ b/net/Makefile
-@@ -52,7 +52,7 @@ obj-$(CONFIG_TIPC)           += tipc/
+@@ -51,7 +51,7 @@ obj-$(CONFIG_TIPC)           += tipc/
  obj-$(CONFIG_NETLABEL)                += netlabel/
  obj-$(CONFIG_IUCV)            += iucv/
  obj-$(CONFIG_SMC)             += smc/
index b4e92b4a185dc52f8f887ffe32c4a41c52711ac8..69771cef398d902bf6c73b194a4301d1769bfbf6 100644 (file)
@@ -38,7 +38,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  /* Specifies the type of the struct net_device::ml_priv pointer */
  enum netdev_ml_priv_type {
-@@ -2015,6 +2020,7 @@ struct net_device {
+@@ -2014,6 +2019,7 @@ struct net_device {
        /* Read-mostly cache-line for fast-path access */
        unsigned int            flags;
        unsigned int            priv_flags;
@@ -46,7 +46,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        const struct net_device_ops *netdev_ops;
        int                     ifindex;
        unsigned short          gflags;
-@@ -2075,6 +2081,11 @@ struct net_device {
+@@ -2074,6 +2080,11 @@ struct net_device {
        const struct tlsdev_ops *tlsdev_ops;
  #endif
  
@@ -58,7 +58,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        const struct header_ops *header_ops;
  
        unsigned char           operstate;
-@@ -2149,6 +2160,10 @@ struct net_device {
+@@ -2145,6 +2156,10 @@ struct net_device {
        struct mctp_dev __rcu   *mctp_ptr;
  #endif
  
index 367d66fc666dc427b15f67bf68d6049bec5e701f..96d800669a81e6ce605502c346ac2fa7c3ed075b 100644 (file)
@@ -29,7 +29,7 @@ Subject: [PATCH] net/usb/qmi_wwan: add MeigLink modem support
  
  #define QUECTEL_VENDOR_ID                     0x2c7c
  /* These Quectel products use Quectel's vendor ID */
-@@ -1169,6 +1171,11 @@ static const struct usb_device_id option
+@@ -1173,6 +1175,11 @@ static const struct usb_device_id option
          .driver_info = ZLP },
        { USB_DEVICE(QUECTEL_VENDOR_ID, QUECTEL_PRODUCT_BG96),
          .driver_info = RSVD(4) },
index 05d024925df0d977ed7162cb27337d35e6311b01..436c2cc767cffe0a4eb593123e50029cdb2a9b36 100644 (file)
@@ -9,7 +9,7 @@ Acked-by: Rob Landley <rob@landley.net>
 ---
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1100,9 +1100,6 @@ config FW_ARC
+@@ -1101,9 +1101,6 @@ config FW_ARC
  config ARCH_MAY_HAVE_PC_FDC
        bool
  
@@ -19,7 +19,7 @@ Acked-by: Rob Landley <rob@landley.net>
  config CEVT_BCM1480
        bool
  
-@@ -3182,6 +3179,18 @@ choice
+@@ -3183,6 +3180,18 @@ choice
                bool "Extend builtin kernel arguments with bootloader arguments"
  endchoice
  
index 4ccf229026a288b1d5a55844381e3f9c15311062..f01348d349df7310699e3ce843ece2f15c3fa06d 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -2101,6 +2101,8 @@ struct net_device {
+@@ -2100,6 +2100,8 @@ struct net_device {
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
index d846a05a2487bc9bf53237237151a20fc632d13d..1ccdea6d993e1483f162d8b0bf532750ec888a82 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  /**
   *    napi_disable - prevent NAPI from scheduling
-@@ -3368,6 +3369,7 @@ struct softnet_data {
+@@ -3364,6 +3365,7 @@ struct softnet_data {
        unsigned int            processed;
        unsigned int            time_squeeze;
        unsigned int            received_rps;
@@ -162,7 +162,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  void netif_napi_add(struct net_device *dev, struct napi_struct *napi,
                    int (*poll)(struct napi_struct *, int), int weight)
  {
-@@ -11371,6 +11446,9 @@ static int dev_cpu_dead(unsigned int old
+@@ -11369,6 +11444,9 @@ static int dev_cpu_dead(unsigned int old
        raise_softirq_irqoff(NET_TX_SOFTIRQ);
        local_irq_enable();
  
@@ -172,7 +172,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #ifdef CONFIG_RPS
        remsd = oldsd->rps_ipi_list;
        oldsd->rps_ipi_list = NULL;
-@@ -11710,6 +11788,7 @@ static int __init net_dev_init(void)
+@@ -11708,6 +11786,7 @@ static int __init net_dev_init(void)
                sd->cpu = i;
  #endif
  
index bf2962a3ffb7e8593bfcc7e8c914a6f705b128a3..6776d35ecec37a88b7e770e0ceefa02196a6d2c7 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Stefan Koch <stefan.koch10@gmail.com>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2429,6 +2429,12 @@ config MIPS_VPE_LOADER
+@@ -2430,6 +2430,12 @@ config MIPS_VPE_LOADER
          Includes a loader for loading an elf relocatable object
          onto another VPE and running it.
  
index 6130bf0030ff3fa2d3b4212ff9c063d822e8c303..e8a69153500f8b922d0d142ee0c6b4c8b0a5cedf 100644 (file)
@@ -854,7 +854,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
 +};
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -7526,6 +7526,14 @@ F:      drivers/ptp/ptp_qoriq.c
+@@ -7519,6 +7519,14 @@ F:      drivers/ptp/ptp_qoriq.c
  F:    drivers/ptp/ptp_qoriq_debugfs.c
  F:    include/linux/fsl/ptp_qoriq.h
  
index 6af9e843357a0ebaed76ee0794576e3d105719a5..43876deb66cbc34f5e12d9d4309bf3d4057b9c45 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11797,6 +11797,15 @@ S:    Maintained
+@@ -11790,6 +11790,15 @@ S:    Maintained
  F:    drivers/net/pcs/pcs-mtk-lynxi.c
  F:    include/linux/pcs/pcs-mtk-lynxi.h
  
index b8accf180bb0053eb5e95da099bcc1da4a14076c..242a6c1e00abba3f45f4e0eb7a1cf2dff74cb338 100644 (file)
@@ -16,7 +16,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -9063,6 +9063,22 @@ F:      include/net/nl802154.h
+@@ -9056,6 +9056,22 @@ F:      include/net/nl802154.h
  F:    net/ieee802154/
  F:    net/mac802154/
  
index 15e233aceb2c12c625699bc65bc5aafbf0c47f2f..4b225277f9deb859e9c4d6770cad64d333740ee6 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1180,6 +1180,10 @@ config MIPS_MSC
+@@ -1181,6 +1181,10 @@ config MIPS_MSC
  config SYNC_R4K
        bool
  
index 07635a9d86a8d9a9eba5e21cb443a295eebd8c51..ef45aac61bda92c85dde432eaf2d91137ec5b656 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 
 --- a/arch/mips/kernel/setup.c
 +++ b/arch/mips/kernel/setup.c
-@@ -544,8 +544,28 @@ static int __init bootcmdline_scan_chose
+@@ -545,8 +545,28 @@ static int __init bootcmdline_scan_chose
  
  #endif /* CONFIG_OF_EARLY_FLATTREE */
  
@@ -46,7 +46,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
        bool dt_bootargs = false;
  
        /*
-@@ -559,6 +579,14 @@ static void __init bootcmdline_init(void
+@@ -560,6 +580,14 @@ static void __init bootcmdline_init(void
        }
  
        /*
index f36f028cab3845a12b967e7d1c988f401373473a..d49429f7a3b862e9559bdd12ea942c295093af4f 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/arch/mips/kernel/setup.c
 +++ b/arch/mips/kernel/setup.c
-@@ -686,7 +686,6 @@ static void __init arch_mem_init(char **
+@@ -687,7 +687,6 @@ static void __init arch_mem_init(char **
        mips_reserve_vmcore();
  
        mips_parse_crashkernel();
@@ -18,7 +18,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
        /*
         * In order to reduce the possibility of kernel panic when failed to
-@@ -803,6 +802,7 @@ void __init setup_arch(char **cmdline_p)
+@@ -804,6 +803,7 @@ void __init setup_arch(char **cmdline_p)
  
        cpu_cache_init();
        paging_init();
index 17ff729f5256509eae048f8e18a358a9964fbad1..dfe7ab28d73b9e3a3940c1d5d3c815dc8df0ec86 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Guenter Roeck <linux@roeck-us.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -15902,6 +15902,13 @@ S:    Maintained
+@@ -15895,6 +15895,13 @@ S:    Maintained
  F:    include/sound/rt*.h
  F:    sound/soc/codecs/rt*
  
index 6407a49fb6b627b643c7ad58b988654f07e30200..f853ef4feef7525f4629ce93254efc703cd816f5 100644 (file)
@@ -25,7 +25,7 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
  platform-$(CONFIG_SGI_IP28)           += sgi-ip22/
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1053,8 +1053,58 @@ config NLM_XLP_BOARD
+@@ -1054,8 +1054,58 @@ config NLM_XLP_BOARD
          This board is based on Netlogic XLP Processor.
          Say Y here if you have a XLP based board.