build: create $(PKG_SYMVERS_DIR) if non-existent
authorSebastian Kemper <sebastian_ml@gmx.net>
Wed, 18 Nov 2020 21:58:58 +0000 (22:58 +0100)
committerJo-Philipp Wich <jo@mein.io>
Thu, 19 Nov 2020 17:52:15 +0000 (18:52 +0100)
Commit 5d76065 moved the creation of the symvers directory to
include/kernel-build.mk. This is fine when building from scratch. But
when unpacking an SDK the directory doesn't exist and because the kernel
won't be built (again) this directory will not be created by the build
system, causing build failure if make tries to copy files into it.

This moves the creation of the symvers directory back into
include/kernel.mk so that the directory is created in any case.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
include/kernel-build.mk
include/kernel.mk

index a698deec3ca441385c5ebefc208e0f4f36650853..22f7c4c7c7e6b04a9012c389debd0c1f6636f293 100644 (file)
@@ -136,7 +136,6 @@ define BuildKernel
   $(LINUX_DIR)/.modules: export PKG_CONFIG_LIBDIR=$$(STAGING_DIR_HOST)/lib/pkgconfig
   $(LINUX_DIR)/.modules: $(STAMP_CONFIGURED) $(LINUX_DIR)/.config FORCE
        $(Kernel/CompileModules)
-       mkdir -p $(PKG_SYMVERS_DIR)
        touch $$@
 
   $(LINUX_DIR)/.image: export STAGING_PREFIX=$$(STAGING_DIR_HOST)
index 1ae9c6be29c41f7c04500fd2cd59b0ed68fad179..1466048b0c1edb220557ca3a4c79a54513b8bda5 100644 (file)
@@ -149,6 +149,7 @@ define collect_module_symvers
                        grep -F $$$$realdir $(PKG_BUILD_DIR)/$$$$subdir/Module.symvers >> $(PKG_BUILD_DIR)/Module.symvers.tmp; \
        done; \
        sort -u $(PKG_BUILD_DIR)/Module.symvers.tmp > $(PKG_BUILD_DIR)/Module.symvers; \
+       mkdir -p $(PKG_SYMVERS_DIR); \
        mv $(PKG_BUILD_DIR)/Module.symvers $(PKG_SYMVERS_DIR)/$(PKG_NAME).symvers
 endef