add .25 patches (kernel boots fine on LS2, LS5, FON2200 and on WRT55AG v2)
authorGabor Juhos <juhosg@openwrt.org>
Sat, 3 May 2008 05:43:29 +0000 (05:43 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 3 May 2008 05:43:29 +0000 (05:43 +0000)
SVN-Revision: 11016

target/linux/atheros/config-2.6.25 [new file with mode: 0644]
target/linux/atheros/patches-2.6.25/100-board.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.25/110-spiflash.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.25/130-ar2313_ethernet.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.25/140-redboot_partition_scan.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.25/150-bridge-printk.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.25/900-cevt_r4k_irq_disable_hazard.patch [new file with mode: 0644]
target/linux/atheros/patches-2.6.25/901-get_c0_compare_irq_function.patch [new file with mode: 0644]

diff --git a/target/linux/atheros/config-2.6.25 b/target/linux/atheros/config-2.6.25
new file mode 100644 (file)
index 0000000..4b97840
--- /dev/null
@@ -0,0 +1,214 @@
+CONFIG_32BIT=y
+# CONFIG_64BIT is not set
+CONFIG_AR2313=y
+# CONFIG_ARCH_HAS_ILOG2_U32 is not set
+# CONFIG_ARCH_HAS_ILOG2_U64 is not set
+CONFIG_ARCH_POPULATES_NODE_MAP=y
+# CONFIG_ARCH_SUPPORTS_MSI is not set
+CONFIG_ARCH_SUPPORTS_OPROFILE=y
+CONFIG_ARCH_SUSPEND_POSSIBLE=y
+CONFIG_ATHEROS=y
+CONFIG_ATHEROS_AR5312=y
+CONFIG_ATHEROS_AR5315=y
+# CONFIG_ATM is not set
+CONFIG_BASE_SMALL=0
+# CONFIG_BCM47XX is not set
+CONFIG_BITREVERSE=y
+# CONFIG_BROADCOM_PHY is not set
+# CONFIG_BT is not set
+CONFIG_CEVT_R4K=y
+CONFIG_CLASSIC_RCU=y
+CONFIG_CMDLINE="console=ttyS0,9600 rootfstype=squashfs,jffs2 init=/etc/preinit"
+CONFIG_CPU_BIG_ENDIAN=y
+CONFIG_CPU_HAS_LLSC=y
+CONFIG_CPU_HAS_PREFETCH=y
+CONFIG_CPU_HAS_SYNC=y
+# CONFIG_CPU_LITTLE_ENDIAN is not set
+# CONFIG_CPU_LOONGSON2 is not set
+CONFIG_CPU_MIPS32=y
+CONFIG_CPU_MIPS32_R1=y
+# CONFIG_CPU_MIPS32_R2 is not set
+# CONFIG_CPU_MIPS64_R1 is not set
+# CONFIG_CPU_MIPS64_R2 is not set
+CONFIG_CPU_MIPSR1=y
+# CONFIG_CPU_NEVADA is not set
+# CONFIG_CPU_R10000 is not set
+# CONFIG_CPU_R3000 is not set
+# CONFIG_CPU_R4300 is not set
+# CONFIG_CPU_R4X00 is not set
+# CONFIG_CPU_R5000 is not set
+# CONFIG_CPU_R5432 is not set
+# CONFIG_CPU_R6000 is not set
+# CONFIG_CPU_R8000 is not set
+# CONFIG_CPU_RM7000 is not set
+# CONFIG_CPU_RM9000 is not set
+# CONFIG_CPU_SB1 is not set
+CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
+CONFIG_CPU_SUPPORTS_HIGHMEM=y
+# CONFIG_CPU_TX39XX is not set
+# CONFIG_CPU_TX49XX is not set
+# CONFIG_CPU_VR41XX is not set
+CONFIG_CRYPTO_AEAD=m
+CONFIG_CRYPTO_AUTHENC=m
+CONFIG_CRYPTO_GF128MUL=m
+CONFIG_CSRC_R4K=y
+# CONFIG_DM9000 is not set
+CONFIG_DMA_NEED_PCI_MAP_STATE=y
+CONFIG_DMA_NONCOHERENT=y
+# CONFIG_FIXED_PHY is not set
+CONFIG_FS_POSIX_ACL=y
+CONFIG_GENERIC_CLOCKEVENTS=y
+CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
+CONFIG_GENERIC_CMOS_UPDATE=y
+CONFIG_GENERIC_FIND_NEXT_BIT=y
+CONFIG_GENERIC_GPIO=y
+# CONFIG_GENERIC_HARDIRQS_NO__DO_IRQ is not set
+CONFIG_GPIO_DEVICE=y
+CONFIG_HAS_DMA=y
+CONFIG_HAS_IOMEM=y
+CONFIG_HAS_IOPORT=y
+CONFIG_HAVE_IDE=y
+# CONFIG_HAVE_KPROBES is not set
+# CONFIG_HAVE_KRETPROBES is not set
+CONFIG_HAVE_OPROFILE=y
+# CONFIG_HOSTAP is not set
+CONFIG_HW_RANDOM=y
+# CONFIG_I2C is not set
+# CONFIG_IBM_NEW_EMAC_EMAC4 is not set
+# CONFIG_IBM_NEW_EMAC_RGMII is not set
+# CONFIG_IBM_NEW_EMAC_TAH is not set
+# CONFIG_IBM_NEW_EMAC_ZMII is not set
+CONFIG_ICPLUS_PHY=y
+# CONFIG_IDE is not set
+# CONFIG_IEEE80211 is not set
+CONFIG_INITRAMFS_SOURCE=""
+CONFIG_IRQ_CPU=y
+# CONFIG_LEDS_ALIX is not set
+# CONFIG_LEDS_GPIO is not set
+# CONFIG_LEMOTE_FULONG is not set
+CONFIG_LZO_COMPRESS=m
+CONFIG_LZO_DECOMPRESS=m
+# CONFIG_MACH_ALCHEMY is not set
+# CONFIG_MACH_DECSTATION is not set
+# CONFIG_MACH_JAZZ is not set
+# CONFIG_MACH_VR41XX is not set
+# CONFIG_MDIO_BITBANG is not set
+# CONFIG_MEMSTICK is not set
+CONFIG_MIPS=y
+# CONFIG_MIPS_ATLAS is not set
+# CONFIG_MIPS_COBALT is not set
+CONFIG_MIPS_L1_CACHE_SHIFT=5
+# CONFIG_MIPS_MALTA is not set
+CONFIG_MIPS_MT_DISABLED=y
+# CONFIG_MIPS_MT_SMP is not set
+# CONFIG_MIPS_MT_SMTC is not set
+# CONFIG_MIPS_SEAD is not set
+# CONFIG_MIPS_SIM is not set
+CONFIG_MTD=y
+# CONFIG_MTD_ABSENT is not set
+CONFIG_MTD_BLKDEVS=y
+CONFIG_MTD_BLOCK=y
+# CONFIG_MTD_BLOCK2MTD is not set
+CONFIG_MTD_CFI=y
+CONFIG_MTD_CFI_ADV_OPTIONS=y
+CONFIG_MTD_CFI_AMDSTD=y
+# CONFIG_MTD_CFI_BE_BYTE_SWAP is not set
+# CONFIG_MTD_CFI_GEOMETRY is not set
+CONFIG_MTD_CFI_I1=y
+CONFIG_MTD_CFI_I2=y
+# CONFIG_MTD_CFI_I4 is not set
+# CONFIG_MTD_CFI_I8 is not set
+# CONFIG_MTD_CFI_INTELEXT is not set
+# CONFIG_MTD_CFI_LE_BYTE_SWAP is not set
+CONFIG_MTD_CFI_NOSWAP=y
+# CONFIG_MTD_CFI_STAA is not set
+CONFIG_MTD_CFI_UTIL=y
+CONFIG_MTD_CHAR=y
+# CONFIG_MTD_CMDLINE_PARTS is not set
+CONFIG_MTD_COMPLEX_MAPPINGS=y
+# CONFIG_MTD_CONCAT is not set
+# CONFIG_MTD_DEBUG is not set
+# CONFIG_MTD_DOC2000 is not set
+# CONFIG_MTD_DOC2001 is not set
+# CONFIG_MTD_DOC2001PLUS is not set
+CONFIG_MTD_GEN_PROBE=y
+# CONFIG_MTD_JEDECPROBE is not set
+CONFIG_MTD_MAP_BANK_WIDTH_1=y
+# CONFIG_MTD_MAP_BANK_WIDTH_16 is not set
+CONFIG_MTD_MAP_BANK_WIDTH_2=y
+# CONFIG_MTD_MAP_BANK_WIDTH_32 is not set
+CONFIG_MTD_MAP_BANK_WIDTH_4=y
+# CONFIG_MTD_MAP_BANK_WIDTH_8 is not set
+# CONFIG_MTD_MTDRAM is not set
+# CONFIG_MTD_ONENAND is not set
+# CONFIG_MTD_OTP is not set
+CONFIG_MTD_PARTITIONS=y
+# CONFIG_MTD_PHRAM is not set
+CONFIG_MTD_PHYSMAP=y
+CONFIG_MTD_PHYSMAP_BANKWIDTH=0
+CONFIG_MTD_PHYSMAP_LEN=0x0
+CONFIG_MTD_PHYSMAP_START=0x0
+# CONFIG_MTD_PLATRAM is not set
+# CONFIG_MTD_RAM is not set
+CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-3
+CONFIG_MTD_REDBOOT_PARTS=y
+CONFIG_MTD_REDBOOT_PARTS_READONLY=y
+# CONFIG_MTD_ROM is not set
+# CONFIG_MTD_SLRAM is not set
+CONFIG_MTD_SPIFLASH=y
+CONFIG_NEW_GPIO=y
+# CONFIG_NO_IOPORT is not set
+# CONFIG_PAGE_SIZE_16KB is not set
+CONFIG_PAGE_SIZE_4KB=y
+# CONFIG_PAGE_SIZE_64KB is not set
+# CONFIG_PAGE_SIZE_8KB is not set
+CONFIG_PHYLIB=y
+# CONFIG_PMC_MSP is not set
+# CONFIG_PMC_YOSEMITE is not set
+# CONFIG_PNX8550_JBS is not set
+# CONFIG_PNX8550_STB810 is not set
+# CONFIG_QSEMI_PHY is not set
+# CONFIG_REALTEK_PHY is not set
+# CONFIG_RTC is not set
+CONFIG_RTC_LIB=y
+CONFIG_RWSEM_GENERIC_SPINLOCK=y
+CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
+CONFIG_SCSI_WAIT_SCAN=m
+# CONFIG_SERIAL_8250_EXTENDED is not set
+CONFIG_SERIAL_8250_NR_UARTS=1
+CONFIG_SERIAL_8250_RUNTIME_UARTS=1
+# CONFIG_SGI_IP22 is not set
+# CONFIG_SGI_IP27 is not set
+# CONFIG_SGI_IP28 is not set
+# CONFIG_SGI_IP32 is not set
+# CONFIG_SIBYTE_BIGSUR is not set
+# CONFIG_SIBYTE_CARMEL is not set
+# CONFIG_SIBYTE_CRHINE is not set
+# CONFIG_SIBYTE_CRHONE is not set
+# CONFIG_SIBYTE_LITTLESUR is not set
+# CONFIG_SIBYTE_RHONE is not set
+# CONFIG_SIBYTE_SENTOSA is not set
+# CONFIG_SIBYTE_SWARM is not set
+CONFIG_SLABINFO=y
+# CONFIG_SMSC_PHY is not set
+# CONFIG_SOFT_WATCHDOG is not set
+# CONFIG_SPARSEMEM_STATIC is not set
+# CONFIG_SPARSEMEM_VMEMMAP_ENABLE is not set
+CONFIG_SSB_POSSIBLE=y
+CONFIG_SYSVIPC_SYSCTL=y
+CONFIG_SYS_HAS_CPU_MIPS32_R1=y
+CONFIG_SYS_SUPPORTS_32BIT_KERNEL=y
+CONFIG_SYS_SUPPORTS_ARBIT_HZ=y
+CONFIG_SYS_SUPPORTS_BIG_ENDIAN=y
+# CONFIG_THERMAL is not set
+CONFIG_TICK_ONESHOT=y
+# CONFIG_TOSHIBA_JMR3927 is not set
+# CONFIG_TOSHIBA_RBTX4927 is not set
+# CONFIG_TOSHIBA_RBTX4938 is not set
+CONFIG_TRAD_SIGNALS=y
+# CONFIG_USB_ARCH_HAS_EHCI is not set
+# CONFIG_USB_ARCH_HAS_HCD is not set
+# CONFIG_USB_ARCH_HAS_OHCI is not set
+# CONFIG_VGASTATE is not set
+CONFIG_VIDEO_V4L2_COMMON=m
+CONFIG_ZONE_DMA_FLAG=0
diff --git a/target/linux/atheros/patches-2.6.25/100-board.patch b/target/linux/atheros/patches-2.6.25/100-board.patch
new file mode 100644 (file)
index 0000000..30f001a
--- /dev/null
@@ -0,0 +1,72 @@
+Index: linux-2.6.25.1/arch/mips/Kconfig
+===================================================================
+--- linux-2.6.25.1.orig/arch/mips/Kconfig
++++ linux-2.6.25.1/arch/mips/Kconfig
+@@ -59,6 +59,18 @@ config BCM47XX
+       help
+        Support for BCM47XX based boards
++config ATHEROS
++      bool "Atheros SoC support (EXPERIMENTAL)"
++      depends on EXPERIMENTAL
++      select DMA_NONCOHERENT
++      select CEVT_R4K
++      select CSRC_R4K
++      select IRQ_CPU
++      select SYS_HAS_CPU_MIPS32_R1
++      select SYS_SUPPORTS_BIG_ENDIAN
++      select SYS_SUPPORTS_32BIT_KERNEL
++      select GENERIC_GPIO
++
+ config MIPS_COBALT
+       bool "Cobalt Server"
+       select CEVT_R4K
+@@ -683,6 +695,7 @@ config WR_PPMC
+ endchoice
++source "arch/mips/atheros/Kconfig"
+ source "arch/mips/au1000/Kconfig"
+ source "arch/mips/basler/excite/Kconfig"
+ source "arch/mips/jazz/Kconfig"
+Index: linux-2.6.25.1/arch/mips/Makefile
+===================================================================
+--- linux-2.6.25.1.orig/arch/mips/Makefile
++++ linux-2.6.25.1/arch/mips/Makefile
+@@ -276,6 +276,13 @@ libs-$(CONFIG_MIPS_XXS1500)       += arch/mips
+ load-$(CONFIG_MIPS_XXS1500)   += 0xffffffff80100000
+ #
++# Atheros AR5312/AR2312 WiSoC
++#
++core-$(CONFIG_ATHEROS)                += arch/mips/atheros/
++cflags-$(CONFIG_ATHEROS)      += -Iinclude/asm-mips/mach-atheros
++load-$(CONFIG_ATHEROS)                += 0xffffffff80041000
++
++#
+ # Cobalt Server
+ #
+ core-$(CONFIG_MIPS_COBALT)    += arch/mips/cobalt/
+Index: linux-2.6.25.1/include/asm-mips/bootinfo.h
+===================================================================
+--- linux-2.6.25.1.orig/include/asm-mips/bootinfo.h
++++ linux-2.6.25.1/include/asm-mips/bootinfo.h
+@@ -94,6 +94,18 @@
+ #define MACH_MSP7120_FPGA       5     /* PMC-Sierra MSP7120 Emulation */
+ #define MACH_MSP_OTHER        255     /* PMC-Sierra unknown board type */
++/*
++ * Valid machtype for group ATHEROS
++ */
++#define MACH_GROUP_ATHEROS    26
++#define MACH_ATHEROS_AR5312   0
++#define MACH_ATHEROS_AR2312   1
++#define MACH_ATHEROS_AR2313   2
++#define MACH_ATHEROS_AR2315   3
++#define MACH_ATHEROS_AR2316   4
++#define MACH_ATHEROS_AR2317   5
++#define MACH_ATHEROS_AR2318   6
++
+ #define CL_SIZE                       COMMAND_LINE_SIZE
+ extern char *system_type;
diff --git a/target/linux/atheros/patches-2.6.25/110-spiflash.patch b/target/linux/atheros/patches-2.6.25/110-spiflash.patch
new file mode 100644 (file)
index 0000000..bb66f02
--- /dev/null
@@ -0,0 +1,24 @@
+Index: linux-2.6.25.1/drivers/mtd/devices/Kconfig
+===================================================================
+--- linux-2.6.25.1.orig/drivers/mtd/devices/Kconfig
++++ linux-2.6.25.1/drivers/mtd/devices/Kconfig
+@@ -77,6 +77,10 @@ config MTD_M25P80
+         if you want to specify device partitioning or to use a device which
+         doesn't support the JEDEC ID instruction.
++config MTD_SPIFLASH
++      tristate "Atheros AR2315/6/7 SPI Flash support"
++      depends on ATHEROS_AR5315
++
+ config MTD_SLRAM
+       tristate "Uncached system RAM"
+       help
+Index: linux-2.6.25.1/drivers/mtd/devices/Makefile
+===================================================================
+--- linux-2.6.25.1.orig/drivers/mtd/devices/Makefile
++++ linux-2.6.25.1/drivers/mtd/devices/Makefile
+@@ -17,3 +17,4 @@ obj-$(CONFIG_MTD_LART)               += lart.o
+ obj-$(CONFIG_MTD_BLOCK2MTD)   += block2mtd.o
+ obj-$(CONFIG_MTD_DATAFLASH)   += mtd_dataflash.o
+ obj-$(CONFIG_MTD_M25P80)      += m25p80.o
++obj-$(CONFIG_MTD_SPIFLASH)    += spiflash.o
diff --git a/target/linux/atheros/patches-2.6.25/130-ar2313_ethernet.patch b/target/linux/atheros/patches-2.6.25/130-ar2313_ethernet.patch
new file mode 100644 (file)
index 0000000..2d2ce45
--- /dev/null
@@ -0,0 +1,29 @@
+Index: linux-2.6.25.1/drivers/net/Kconfig
+===================================================================
+--- linux-2.6.25.1.orig/drivers/net/Kconfig
++++ linux-2.6.25.1/drivers/net/Kconfig
+@@ -367,6 +367,12 @@ config AX88796_93CX6
+       help
+         Select this if your platform comes with an external 93CX6 eeprom.
++config AR2313
++      tristate "AR2313 Ethernet support"
++      depends on NET_ETHERNET && ATHEROS
++      help
++        Support for the AR231x/531x ethernet controller
++
+ config MACE
+       tristate "MACE (Power Mac ethernet) support"
+       depends on PPC_PMAC && PPC32
+Index: linux-2.6.25.1/drivers/net/Makefile
+===================================================================
+--- linux-2.6.25.1.orig/drivers/net/Makefile
++++ linux-2.6.25.1/drivers/net/Makefile
+@@ -194,6 +194,7 @@ obj-$(CONFIG_MVME147_NET) += mvme147.o 7
+ obj-$(CONFIG_EQUALIZER) += eql.o
+ obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
+ obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
++obj-$(CONFIG_AR2313) += ar2313/
+ obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
+ obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
+ obj-$(CONFIG_DECLANCE) += declance.o
diff --git a/target/linux/atheros/patches-2.6.25/140-redboot_partition_scan.patch b/target/linux/atheros/patches-2.6.25/140-redboot_partition_scan.patch
new file mode 100644 (file)
index 0000000..467fcad
--- /dev/null
@@ -0,0 +1,56 @@
+Index: linux-2.6.25.1/drivers/mtd/redboot.c
+===================================================================
+--- linux-2.6.25.1.orig/drivers/mtd/redboot.c
++++ linux-2.6.25.1/drivers/mtd/redboot.c
+@@ -59,31 +59,32 @@ static int parse_redboot_partitions(stru
+       static char nullstring[] = "unallocated";
+ #endif
++      buf = vmalloc(master->erasesize);
++      if (!buf)
++              return -ENOMEM;
++
++ restart:
+       if ( directory < 0 ) {
+               offset = master->size + directory * master->erasesize;
+-              while (master->block_isbad && 
++              while (master->block_isbad &&
+                      master->block_isbad(master, offset)) {
+                       if (!offset) {
+                       nogood:
+                               printk(KERN_NOTICE "Failed to find a non-bad block to check for RedBoot partition table\n");
++                              vfree(buf);
+                               return -EIO;
+                       }
+                       offset -= master->erasesize;
+               }
+       } else {
+               offset = directory * master->erasesize;
+-              while (master->block_isbad && 
++              while (master->block_isbad &&
+                      master->block_isbad(master, offset)) {
+                       offset += master->erasesize;
+                       if (offset == master->size)
+                               goto nogood;
+               }
+       }
+-      buf = vmalloc(master->erasesize);
+-
+-      if (!buf)
+-              return -ENOMEM;
+-
+       printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
+              master->name, offset);
+@@ -155,6 +156,11 @@ static int parse_redboot_partitions(stru
+       }
+       if (i == numslots) {
+               /* Didn't find it */
++              if (offset + master->erasesize < master->size) {
++                      /* not at the end of the flash yet, maybe next block :) */
++                      directory++;
++                      goto restart;
++              }
+               printk(KERN_NOTICE "No RedBoot partition table detected in %s\n",
+                      master->name);
+               ret = 0;
diff --git a/target/linux/atheros/patches-2.6.25/150-bridge-printk.patch b/target/linux/atheros/patches-2.6.25/150-bridge-printk.patch
new file mode 100644 (file)
index 0000000..ffff0cd
--- /dev/null
@@ -0,0 +1,28 @@
+Index: linux-2.6.25.1/net/core/dev.c
+===================================================================
+--- linux-2.6.25.1.orig/net/core/dev.c
++++ linux-2.6.25.1/net/core/dev.c
+@@ -3755,8 +3755,8 @@ int register_netdevice(struct net_device
+       /* Fix illegal SG+CSUM combinations. */
+       if ((dev->features & NETIF_F_SG) &&
+           !(dev->features & NETIF_F_ALL_CSUM)) {
+-              printk(KERN_NOTICE "%s: Dropping NETIF_F_SG since no checksum feature.\n",
+-                     dev->name);
++              //printk(KERN_NOTICE "%s: Dropping NETIF_F_SG since no checksum feature.\n",
++              //       dev->name);
+               dev->features &= ~NETIF_F_SG;
+       }
+@@ -3769,9 +3769,9 @@ int register_netdevice(struct net_device
+       }
+       if (dev->features & NETIF_F_UFO) {
+               if (!(dev->features & NETIF_F_HW_CSUM)) {
+-                      printk(KERN_ERR "%s: Dropping NETIF_F_UFO since no "
+-                                      "NETIF_F_HW_CSUM feature.\n",
+-                                                      dev->name);
++                      //printk(KERN_ERR "%s: Dropping NETIF_F_UFO since no "
++                      //              "NETIF_F_HW_CSUM feature.\n",
++                      //                              dev->name);
+                       dev->features &= ~NETIF_F_UFO;
+               }
+               if (!(dev->features & NETIF_F_SG)) {
diff --git a/target/linux/atheros/patches-2.6.25/900-cevt_r4k_irq_disable_hazard.patch b/target/linux/atheros/patches-2.6.25/900-cevt_r4k_irq_disable_hazard.patch
new file mode 100644 (file)
index 0000000..3b72a9e
--- /dev/null
@@ -0,0 +1,12 @@
+Index: linux-2.6.25.1/arch/mips/kernel/cevt-r4k.c
+===================================================================
+--- linux-2.6.25.1.orig/arch/mips/kernel/cevt-r4k.c
++++ linux-2.6.25.1/arch/mips/kernel/cevt-r4k.c
+@@ -205,6 +205,7 @@ static int c0_compare_int_usable(void)
+       while ((int)(read_c0_count() - cnt) <= 0)
+               ;       /* Wait for expiry  */
++      irq_disable_hazard();
+       if (!c0_compare_int_pending())
+               return 0;
diff --git a/target/linux/atheros/patches-2.6.25/901-get_c0_compare_irq_function.patch b/target/linux/atheros/patches-2.6.25/901-get_c0_compare_irq_function.patch
new file mode 100644 (file)
index 0000000..1e548c8
--- /dev/null
@@ -0,0 +1,49 @@
+Index: linux-2.6.25.1/arch/mips/kernel/traps.c
+===================================================================
+--- linux-2.6.25.1.orig/arch/mips/kernel/traps.c
++++ linux-2.6.25.1/arch/mips/kernel/traps.c
+@@ -42,6 +42,7 @@
+ #include <asm/mmu_context.h>
+ #include <asm/types.h>
+ #include <asm/stacktrace.h>
++#include <asm/time.h>
+ extern asmlinkage void handle_int(void);
+ extern asmlinkage void handle_tlbm(void);
+@@ -1379,6 +1380,8 @@ void __cpuinit per_cpu_trap_init(void)
+        */
+       if (cpu_has_mips_r2) {
+               cp0_compare_irq = (read_c0_intctl() >> 29) & 7;
++              if (get_c0_compare_irq)
++                      cp0_compare_irq = get_c0_compare_irq();
+               cp0_perfcount_irq = (read_c0_intctl() >> 26) & 7;
+               if (cp0_perfcount_irq == cp0_compare_irq)
+                       cp0_perfcount_irq = -1;
+Index: linux-2.6.25.1/include/asm-mips/time.h
+===================================================================
+--- linux-2.6.25.1.orig/include/asm-mips/time.h
++++ linux-2.6.25.1/include/asm-mips/time.h
+@@ -53,6 +53,7 @@ extern int (*perf_irq)(void);
+ #ifdef CONFIG_CEVT_R4K
+ extern int mips_clockevent_init(void);
+ extern unsigned int __weak get_c0_compare_int(void);
++extern unsigned int __weak get_c0_compare_irq(void);
+ #else
+ static inline int mips_clockevent_init(void)
+ {
+Index: linux-2.6.25.1/arch/mips/atheros/board.c
+===================================================================
+--- linux-2.6.25.1.orig/arch/mips/atheros/board.c
++++ linux-2.6.25.1/arch/mips/atheros/board.c
+@@ -205,6 +205,11 @@ void (*board_time_init)(void);
+ void __init plat_time_init(void) {
+     board_time_init();
+ }
++
++unsigned int __init get_c0_compare_irq(void)
++{
++      return CP0_LEGACY_COMPARE_IRQ;
++}
+ #endif
+ void __init arch_init_irq(void)