bcm53xx: add support for ASUS RT-AC3100
authorArınç ÜNAL <arinc.unal@arinc9.com>
Thu, 10 Aug 2023 12:23:09 +0000 (15:23 +0300)
committerRafał Miłecki <rafal@milecki.pl>
Sat, 19 Aug 2023 09:03:11 +0000 (11:03 +0200)
ASUS RT-AC3100 is ASUS RT-AC88U without the external switch.

OpenWrt forum users effortless and ktmakwana have confirmed that there are
revisions with either 4366b1 or 4366c0 wireless chips.

Therefore, include firmware for 4366b1 along with 4366c0. This way, all
hardware revisions of the router will be supported by having brcmfmac use
the firmware file for the wireless chip it detects.

Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
target/linux/bcm53xx/image/Makefile

index b1eb4277b79dfac90630a36a3f9b54381539e89a..5158b432b3b1db937d28b5eddffb3ebfc20a1c7d 100644 (file)
@@ -159,6 +159,14 @@ define Device/asus
   IMAGE/trx := append-ubi | trx-nand | asus-trx
 endef
 
+define Device/asus_rt-ac3100
+  $(call Device/asus)
+  DEVICE_MODEL := RT-AC3100
+  DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+  ASUS_PRODUCTID := RT-AC3100
+endef
+TARGET_DEVICES += asus_rt-ac3100
+
 define Device/asus_rt-ac56u
   $(call Device/asus)
   DEVICE_MODEL := RT-AC56U