kernel.mk: Handle the x86_64 LINUX_KARCH case
authorFelix Fietkau <nbd@openwrt.org>
Fri, 12 Dec 2014 18:28:13 +0000 (18:28 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 12 Dec 2014 18:28:13 +0000 (18:28 +0000)
x64 is handled by the x86 architecture in Linux, add a case for it in
LINUX_KARCH.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
SVN-Revision: 43672

include/kernel.mk

index b905cb9e1936c5352b68c0859fdd12916273b0a6..eeb0c3d2bd8e34d226011af8828a3cae71ca5b19 100644 (file)
@@ -72,7 +72,7 @@ else ifneq (,$(findstring $(ARCH), mipsel mips64 mips64el))
   LINUX_KARCH := mips
 else ifneq (,$(findstring $(ARCH), sh2 sh3 sh4))
   LINUX_KARCH := sh
-else ifneq (,$(findstring $(ARCH), i386))
+else ifneq (,$(findstring $(ARCH), i386 x86_64))
   LINUX_KARCH := x86
 else
   LINUX_KARCH := $(ARCH)