ramips: rt3883: add initial support for the TRENDnet TEW-691GR board
authorGabor Juhos <juhosg@openwrt.org>
Thu, 18 Oct 2012 07:23:11 +0000 (07:23 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 18 Oct 2012 07:23:11 +0000 (07:23 +0000)
No wireless support.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 33850

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt3883/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt3883/Makefile
target/linux/ramips/files/arch/mips/ralink/rt3883/mach-tew-691gr.c [new file with mode: 0644]
target/linux/ramips/rt3883/config-3.3

index d1505824b780990a140cb1da02b5cecfece677ba..8f99ce10b3c9b74fe8993ebae41db8071b365cbd 100644 (file)
@@ -72,5 +72,6 @@ enum ramips_mach_type {
        RAMIPS_MACH_RT_N56U,            /* Asus RT-N56U */
 
        /* RT3883 based machines */
-       RAMIPS_MACH_TEW_692GR,          /* TRENDnet TEW-692GR */
+       RAMIPS_MACH_TEW_691GR,          /* TRENDnet TEW-691GR */
+       RAMIPS_MACH_TEW_692GR           /* TRENDnet TEW-692GR */
 };
index c07476a6fe44a961f7167d6cc3ca91fe8156a464..507cdb38b4e2d504f888140e9d3abb58a47218b5 100644 (file)
@@ -13,6 +13,11 @@ config RT3883_MACH_DIR_645
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT3883_MACH_TEW_691GR
+       bool "TRENDnet TEW-691GR support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT3883_MACH_TEW_692GR
        bool "TRENDnet TEW-692GR support"
        select HW_HAS_PCI
index 6c778b7d64ce858eba6ae5cbcc69b95254651a74..125471af33f55ea07957a20dec462a3fcfe7ca97 100644 (file)
@@ -13,4 +13,5 @@ obj-$(CONFIG_EARLY_PRINTK)            += early_printk.o
 
 obj-$(CONFIG_RT3883_MACH_DIR_645)      += mach-dir-645.o
 obj-$(CONFIG_RT3883_MACH_RT_N56U)      += mach-rt-n56u.o
+obj-$(CONFIG_RT3883_MACH_TEW_691GR)    += mach-tew-691gr.o
 obj-$(CONFIG_RT3883_MACH_TEW_692GR)    += mach-tew-692gr.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt3883/mach-tew-691gr.c b/target/linux/ramips/files/arch/mips/ralink/rt3883/mach-tew-691gr.c
new file mode 100644 (file)
index 0000000..cf1a7f2
--- /dev/null
@@ -0,0 +1,102 @@
+/*
+ * TRENDnet TEW-691GR board support
+ *
+ * Copyright (C) 2012 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/ethtool.h>
+#include <linux/pci.h>
+#include <linux/phy.h>
+#include <linux/rt2x00_platform.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt3883.h>
+#include <asm/mach-ralink/rt3883_regs.h>
+#include <asm/mach-ralink/ramips_eth_platform.h>
+
+#include "devices.h"
+
+#define TEW_691GR_GPIO_LED_WPS_GREEN   9
+
+#define TEW_691GR_GPIO_BUTTON_RESET    10
+#define TEW_691GR_GPIO_BUTTON_WPS      26
+
+#define TEW_691GR_GPIO_SWITCH_RFKILL   0
+
+#define TEW_691GR_KEYS_POLL_INTERVAL   20
+#define TEW_691GR_KEYS_DEBOUNCE_INTERVAL (3 * TEW_691GR_KEYS_POLL_INTERVAL)
+
+static struct gpio_led tew_691gr_leds_gpio[] __initdata = {
+       {
+               .name           = "trendnet:green:wps",
+               .gpio           = TEW_691GR_GPIO_LED_WPS_GREEN,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button tew_691gr_gpio_buttons[] __initdata = {
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = TEW_691GR_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TEW_691GR_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "WPS button",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = TEW_691GR_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TEW_691GR_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "RFKILL switch",
+               .type           = EV_SW,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = TEW_691GR_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TEW_691GR_GPIO_SWITCH_RFKILL,
+               .active_low     = 1,
+       },
+};
+
+static void __init tew_691gr_init(void)
+{
+       rt3883_gpio_init(RT3883_GPIO_MODE_I2C |
+                        RT3883_GPIO_MODE_SPI |
+                        RT3883_GPIO_MODE_UART0(RT3883_GPIO_MODE_GPIO) |
+                        RT3883_GPIO_MODE_JTAG |
+                        RT3883_GPIO_MODE_PCI(RT3883_GPIO_MODE_PCI_FNC));
+
+       rt3883_register_pflash(0);
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(tew_691gr_leds_gpio),
+                                 tew_691gr_leds_gpio);
+
+       ramips_register_gpio_buttons(-1, TEW_691GR_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(tew_691gr_gpio_buttons),
+                                    tew_691gr_gpio_buttons);
+
+       rt3883_register_wlan();
+
+       rt3883_eth_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       rt3883_eth_data.phy_mask = BIT(0);
+       rt3883_eth_data.tx_fc = 1;
+       rt3883_eth_data.rx_fc = 1;
+       rt3883_register_ethernet();
+
+       rt3883_register_wdt(false);
+}
+
+MIPS_MACHINE(RAMIPS_MACH_TEW_691GR, "TEW-691GR", "TRENDnet TEW-691GR",
+            tew_691gr_init);
index f18780f01a7592c30e832ce4ad11a625c6d444ac..c4ddbb9a7a7fb87a73da319f03f6fef9516b2891 100644 (file)
@@ -96,6 +96,7 @@ CONFIG_RALINK_RT3883=y
 CONFIG_RAMIPS_WDT=y
 CONFIG_RT3883_MACH_DIR_645=y
 CONFIG_RT3883_MACH_RT_N56U=y
+CONFIG_RT3883_MACH_TEW_691GR=y
 CONFIG_RT3883_MACH_TEW_692GR=y
 CONFIG_RTL8366_SMI=y
 CONFIG_RTL8367B_PHY=y