ath79: fix factory image generation for Netgear and Zyxel boards
authorPaul Fertser <fercerpav@gmail.com>
Sun, 14 Feb 2021 09:16:33 +0000 (12:16 +0300)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 14 Feb 2021 18:21:38 +0000 (19:21 +0100)
The factory images need to embed specific IDs to pass verification with
the OEM firmware (including TFTP recovery), so they need to be
per-device variables.

Fixes: ab1584a797ad ("ath79: netgear: trim down uImage customisations")
Fixes: 459c8c9ef816 ("ath79: add support for ZyXEL NBG6616")
Reported-by: Marcin Juszkiewicz <marcin-openwrt@juszkiewicz.com.pl>
Signed-off-by: Paul Fertser <fercerpav@gmail.com>
[minor commit message adjustments, sort DEVICE_VARS]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/image/Makefile
target/linux/ath79/image/common-netgear.mk
target/linux/ath79/image/nand.mk

index 4a51cf1fbfa0544e217142a81bf0575edc1ba3d3..c2d2474336bd6288d3babd9dc2a8d021f72d992e 100644 (file)
@@ -4,6 +4,8 @@ include $(INCLUDE_DIR)/image.mk
 KERNEL_LOADADDR = 0x80060000
 
 DEVICE_VARS += LOADER_FLASH_OFFS LOADER_TYPE
+DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
+DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION
 
 define Build/combined-image
        sh $(TOPDIR)/scripts/combined-image.sh \
index d4f43bbaca36c242247ec09ed077dd0ffaebc019..8a74fdc0c9d9fe9ac3dba625ddda707b77d4f2cc 100644 (file)
@@ -1,5 +1,3 @@
-DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
-
 define Build/netgear-rootfs
        mkimage \
                -A mips -O linux -T filesystem -C none \
index 37fcb369378fd4971055c02a9bb76eff32d3755f..abf269a8ce0d16b5e9db5e36af2d71bb87a81167 100644 (file)
@@ -1,5 +1,3 @@
-DEVICE_VARS += RAS_ROOTFS_SIZE RAS_BOARD RAS_VERSION
-
 # attention: only zlib compression is allowed for the boot fs
 define Build/zyxel-buildkerneljffs
        rm -rf  $(KDIR_TMP)/zyxelnbg6716