mac80211: make cfg80211 testmode support optional (and disabled by default)
authorFelix Fietkau <nbd@nbd.name>
Wed, 10 Jun 2020 14:52:27 +0000 (16:52 +0200)
committerFelix Fietkau <nbd@nbd.name>
Thu, 6 Aug 2020 10:36:23 +0000 (12:36 +0200)
Testmode commands are typically only used for manufacturing or vendor specific
debugging features, so they should not be in the default image

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mac80211/Makefile

index 75d9cd9e6f3f39d1c9731f8d5c3a88dd1df3bc7e..6a799496126f5d45337852502feda919f07c90eb 100644 (file)
@@ -35,6 +35,7 @@ PKG_DRIVERS = \
 
 PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_kmod-mac80211 \
+       CONFIG_PACKAGE_CFG80211_TESTMODE \
        CONFIG_PACKAGE_MAC80211_DEBUGFS \
        CONFIG_PACKAGE_MAC80211_MESH \
        CONFIG_PACKAGE_MAC80211_TRACING \
@@ -56,7 +57,6 @@ config_package=$(if $(CONFIG_PACKAGE_kmod-$(1)),m)
 
 config-y:= \
        WLAN \
-       NL80211_TESTMODE \
        CFG80211_WEXT \
        CFG80211_CERTIFICATION_ONUS \
        MAC80211_RC_MINSTREL \
@@ -80,6 +80,7 @@ config-y:= \
        WLAN_VENDOR_ZYDAS \
 
 config-$(call config_package,cfg80211) += CFG80211
+config-$(CONFIG_PACKAGE_CFG80211_TESTMODE) += NL80211_TESTMODE
 
 config-$(call config_package,mac80211) += MAC80211
 config-$(CONFIG_PACKAGE_MAC80211_MESH) += MAC80211_MESH
@@ -108,6 +109,20 @@ define KernelPackage/cfg80211/description
 cfg80211 is the Linux wireless LAN (802.11) configuration API.
 endef
 
+define KernelPackage/cfg80211/config
+  if PACKAGE_kmod-cfg80211
+
+       config PACKAGE_CFG80211_TESTMODE
+               bool "Enable testmode command support"
+               default n
+               help
+                 This is typically used for tests and calibration during
+                 manufacturing, or vendor specific debugging features
+
+  endif
+endef
+
+
 define KernelPackage/mac80211
   $(call KernelPackage/mac80211/Default)
   TITLE:=Linux 802.11 Wireless Networking Stack