ath79: fix 5GHz on QCA9886 variant of ZTE MF286
authorLech Perczak <lech.perczak@gmail.com>
Tue, 13 Sep 2022 21:40:06 +0000 (23:40 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 20 May 2023 13:19:14 +0000 (15:19 +0200)
Recently, a strange variant of ZTE MF286 was discovered, having QCA9886
radio instead of QCA9882 - like MF286A, but having MF286 flash layout
and rest of hardware.
To support both variants in one image, bind calibration data at offset
0x5000 both as "calibration" and "pre-calibration" nvmem-cells, so
ath10k can load caldata for both at runtime.

Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
target/linux/ath79/dts/qca9563_zte_mf286.dts
target/linux/ath79/image/nand.mk

index 2e528a6b97106e67ca1a65c344f1a7ccc3cf6cb2..877075c7699780f2f40b69a8519eb379ac078f07 100644 (file)
 };
 
 &wifi_ath10k {
-       nvmem-cells = <&macaddr_mac_0>, <&cal_caldata_5000>;
-       nvmem-cell-names = "mac-address", "calibration";
+       nvmem-cells = <&macaddr_mac_0>, <&cal_caldata_5000>, <&cal_caldata_5000>;
+       nvmem-cell-names = "mac-address", "calibration", "pre-calibration";
        mac-address-increment = <1>;
 };
 
index d1bd4feb1fe784202f35d9ee8214d051b4bd8e8d..84a589809f0cda0124abb7f0c6584fc2f71bd470 100644 (file)
@@ -426,8 +426,8 @@ TARGET_DEVICES += zte_mf282
 define Device/zte_mf286
   $(Device/zte_mf28x_common)
   DEVICE_MODEL := MF286
-  DEVICE_PACKAGES += ath10k-firmware-qca988x-ct kmod-usb-net-qmi-wwan \
-       kmod-usb-serial-option uqmi
+  DEVICE_PACKAGES += ath10k-firmware-qca988x-ct ath10k-firmware-qca9888-ct \
+       kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
 endef
 TARGET_DEVICES += zte_mf286