bcm53xx: enable Linksys EA6300 & EA9200 builds
authorRafał Miłecki <rafal@milecki.pl>
Mon, 18 Oct 2021 13:59:43 +0000 (15:59 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Mon, 18 Oct 2021 14:09:36 +0000 (16:09 +0200)
Both should be supported since:
1. Adding NVMEM driver for NVRAM
2. Using NVRAM info for determining active firmware partition

Linksys EA9500 uses very similar design and works fine.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/bcm53xx/image/Makefile

index 45355e1ec988a65ae760eabf96a709876c3891ee..a10c6fe240da4efa3c1a007239725a62f072fecf 100644 (file)
@@ -242,13 +242,11 @@ define Device/dlink_dir-885l
 endef
 TARGET_DEVICES += dlink_dir-885l
 
-# Linksys devices are disabled due to problem with 2 TRX partitions
 define Device/linksys_ea6300-v1
   DEVICE_VENDOR := Linksys
   DEVICE_MODEL := EA6300
   DEVICE_VARIANT := v1
   DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
-  BROKEN := y
 endef
 TARGET_DEVICES += linksys_ea6300-v1
 
@@ -265,7 +263,6 @@ define Device/linksys_ea9200
   DEVICE_MODEL := EA9200
   DEVICE_VARIANT := v1
   DEVICE_PACKAGES := $(BRCMFMAC_43602A1) $(USB3_PACKAGES)
-  BROKEN := y
 endef
 TARGET_DEVICES += linksys_ea9200