openvpn: increase procd termination timeout to 15s
authorJo-Philipp Wich <jo@mein.io>
Tue, 17 Jul 2018 14:01:46 +0000 (16:01 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 17 Jul 2018 14:03:56 +0000 (16:03 +0200)
Increase the termination timeout to 15s to let OpenVPN properly tear down
its connections, especially when weak links or complex down scripts are
involved.

Fixes FS#859.
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/openvpn/Makefile
package/network/services/openvpn/files/openvpn.init

index f532a1312d73a845a82a0e1d4fea854707910ce2..51ae9a384030ce115ff4d17c41e7fe68c6209ee5 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=openvpn
 
 PKG_VERSION:=2.4.5
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE_URL:=\
        https://build.openvpn.net/downloads/releases/ \
index ab4f7dba0d4e2421e543591317c4a8d576e3eab3..7e6cfd9c351d70f65c9679efee60135dfd159a13 100644 (file)
@@ -67,6 +67,7 @@ openvpn_add_instance() {
                --cd "$dir" \
                --config "$conf"
        procd_set_param file "$dir/$conf"
+       procd_set_param term_timeout 15
        procd_set_param respawn
        procd_append_param respawn 3600
        procd_append_param respawn 5