kernel/gpio_keys: load module on pre-init
authorJohn Crispin <john@openwrt.org>
Fri, 26 Feb 2016 08:35:20 +0000 (08:35 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 26 Feb 2016 08:35:20 +0000 (08:35 +0000)
fix rescue mode on wdr4900

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
SVN-Revision: 48793

package/kernel/linux/modules/input.mk

index 539d2707aa61cb81cf0a8e69d02b344e1a20d87c..23ead51485d5fced0870621184b347ccaecd2dfb 100644 (file)
@@ -75,7 +75,7 @@ define KernelPackage/input-gpio-keys
        CONFIG_KEYBOARD_GPIO \
        CONFIG_INPUT_KEYBOARD=y
   FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
-  AUTOLOAD:=$(call AutoProbe,gpio_keys)
+  AUTOLOAD:=$(call AutoProbe,gpio_keys,1)
 endef
 
 define KernelPackage/input-gpio-keys/description