x86: fix upgrade by emptying SUPPORTED_DEVICES
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 23 Jan 2021 21:09:27 +0000 (22:09 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 23 Jan 2021 22:42:47 +0000 (23:42 +0100)
x86 uses append-metadata, but only for signing and not for the
metadata itself.

Since recently SUPPORTED_DEVICES was assigned with a global value
and is not empty anymore, append-metadata will now actually put
metadata into x86 images. This breaks sysupgrade on x86.

To fix it for the moment, let's just empty SUPPORTED_DEVICES for
this target again.

In the long term, one should either not add metadata to the images
if it is not desired, and/or remove the unintended fwtool check.

Fixes: f52081bcf938 ("treewide: provide global default for SUPPORTED_DEVICES")
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/x86/image/Makefile

index 85c850c1281d6db16d645373f62ea5992f7f508f..81aab20666fc6173fa2ffb244602a3286d3479ea 100644 (file)
@@ -144,6 +144,7 @@ define Device/Default
   endif
   IMAGES := $$(IMAGES-y)
   ARTIFACTS := $$(ARTIFACTS-y)
+  SUPPORTED_DEVICES :=
 endef
 
 include $(SUBTARGET).mk