elfutils: remove host build from target package
authorTony Ambardar <itugrok@yahoo.com>
Tue, 26 Jan 2021 22:37:04 +0000 (14:37 -0800)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sat, 13 Mar 2021 21:33:22 +0000 (21:33 +0000)
Commit f4da28c301 ("elfutils: Add host build") supplied a libelf host
library to fix a glib2 host build error, but this need was later removed
by b6212c8769 ("glib2: don't use libelf during host build").

More importantly, there are already two sources for libelf host libraries:
OpenWRT build prerequisites [1] and tools/libelf. A third is not needed.

Ref [1]: https://openwrt.org/docs/guide-developer/build-system/install-buildsystem#prerequisites

Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
package/libs/elfutils/Makefile

index aa6743e68818303d3738001a59e8b93bb79467d9..dd0b8ecddea7f8987da31e147499bd556a95a30e 100644 (file)
@@ -25,7 +25,6 @@ PKG_USE_MIPS16:=0
 PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
 
 include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/nls.mk
 
 define Package/elfutils/Default
@@ -99,4 +98,3 @@ endef
 $(eval $(call BuildPackage,libelf))
 $(eval $(call BuildPackage,libdw))
 $(eval $(call BuildPackage,libasm))
-$(eval $(call HostBuild))