bcm53xx: enable Broadcom 4366b1 firmware for Asus RT-AC88U
authorArınç ÜNAL <arinc.unal@arinc9.com>
Tue, 18 Oct 2022 08:54:20 +0000 (11:54 +0300)
committerRafał Miłecki <rafal@milecki.pl>
Fri, 21 Oct 2022 06:50:51 +0000 (08:50 +0200)
On some of the hardware revisions of Asus RT-AC88U, brcmfmac detects the
4366b1 wireless chip and tries to load the firmware file which doesn't
exist because it's not included in the image.

Therefore, include firmware for 4366b1 along with 4366c0. This way, all
hardware revisions of the router will be supported by having brcmfmac use
the firmware file for the wireless chip it detects.

Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
target/linux/bcm53xx/image/Makefile

index d101ff95a7b89f62ba01e2a64506380749972de7..ed0b755364f5683183e5758afce78a3905715bbb 100644 (file)
@@ -170,7 +170,7 @@ TARGET_DEVICES += asus_rt-ac87u
 define Device/asus_rt-ac88u
   $(call Device/asus)
   DEVICE_MODEL := RT-AC88U
-  DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+  DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
   ASUS_PRODUCTID := RT-AC88U
 endef
 TARGET_DEVICES += asus_rt-ac88u