kernel: Update kernel 4.14 to version 4.14.193
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 31 Jul 2020 17:55:39 +0000 (19:55 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 10 Aug 2020 17:34:37 +0000 (19:34 +0200)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/kernel-version.mk
target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/backport-4.14/950-tty-serial-exar-generalize-rs485-setup.patch
target/linux/generic/hack-4.14/220-gc_sections.patch
target/linux/generic/hack-4.14/221-module_exports.patch
target/linux/generic/pending-4.14/810-pci_disable_common_quirks.patch
target/linux/ramips/patches-4.14/0069-awake-rt305x-dwc2-controller.patch

index a061efeb753f594bfd69c22b282bf3053615ca64..1ff1a0967f74b3a6f4f663d0acbbb863e3ba3434 100644 (file)
@@ -6,11 +6,11 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .187
+LINUX_VERSION-4.14 = .193
 LINUX_VERSION-4.19 = .138
 LINUX_VERSION-5.4 = .52
 
-LINUX_KERNEL_HASH-4.14.187 = 5b223475eaeea196aa7e127d3f253bca5c35d8afdc72ca75230ce1ecdd1454bd
+LINUX_KERNEL_HASH-4.14.193 = 0b0fb41d4430e1a42738b341cbfd2f41951aa5cd02acabbd53f076119c8b9f03
 LINUX_KERNEL_HASH-4.19.138 = d15c27d05f6c527269b75b30cc72972748e55720e7e00ad8abbaa4fe3b1d5e02
 LINUX_KERNEL_HASH-5.4.52 = 037efa531120b1c20ff55e78cd3e17288b1804b3a57dc31de760837b3bea5d3a
 
index 52f48d0d0e38ddf191ad45b58aedc4d2c4961212..6938f965514472a679c167948266f262d2f649eb 100644 (file)
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3878,14 +3878,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3879,14 +3879,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index a098c4416c552eb255010a6e0dd947d2d8a36aca..4f6f5d2cfad5985410d8ff6fbedcdf9da268f177 100644 (file)
@@ -65,7 +65,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
         * Before updating sk_refcnt, we must commit prior changes to memory
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -1697,7 +1697,7 @@ u32 tcp_tso_autosize(const struct sock *
+@@ -1699,7 +1699,7 @@ u32 tcp_tso_autosize(const struct sock *
  {
        u32 bytes, segs;
  
@@ -74,7 +74,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
                    sk->sk_gso_max_size - 1 - MAX_TCP_HEADER);
  
        /* Goal is to send at least one packet per ms,
-@@ -2215,7 +2215,7 @@ static bool tcp_small_queue_check(struct
+@@ -2217,7 +2217,7 @@ static bool tcp_small_queue_check(struct
  {
        unsigned int limit;
  
index 2e08e514b7236c5bfd7a92443a22e6528448dafb..0e6aa87f9dfe49d0d436610399a237d0f5358355 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1987,7 +1987,8 @@ static const struct usb_device_id option
+@@ -1990,7 +1990,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index 353dc14949e930af8980272a93f8cc2322a69d41..c4c4cfcb717fc3bc1dee7524af30813182d06961 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/drivers/tty/serial/8250/8250_exar.c
 +++ b/drivers/tty/serial/8250/8250_exar.c
-@@ -283,8 +283,32 @@ static int xr17v35x_register_gpio(struct
+@@ -293,8 +293,32 @@ static int xr17v35x_register_gpio(struct
        return 0;
  }
  
@@ -52,7 +52,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
  };
  
  static int iot2040_rs485_config(struct uart_port *port,
-@@ -317,19 +341,7 @@ static int iot2040_rs485_config(struct u
+@@ -327,19 +351,7 @@ static int iot2040_rs485_config(struct u
        value |= mode;
        writeb(value, p + UART_EXAR_MPIOLVL_7_0);
  
index b69d8a01d631e591ce06e68f99e6e19a1a9c7804..6a4475fc6e1e4c8b0420e57c1cf755da760a7ae8 100644 (file)
@@ -238,7 +238,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
  /*
   * Data section helpers
-@@ -496,7 +497,7 @@
+@@ -497,7 +498,7 @@
  #define ENTRY_TEXT                                                    \
                ALIGN_FUNCTION();                                       \
                VMLINUX_SYMBOL(__entry_text_start) = .;                 \
@@ -247,7 +247,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
                VMLINUX_SYMBOL(__entry_text_end) = .;
  
  #define IRQENTRY_TEXT                                                 \
-@@ -603,7 +604,7 @@
+@@ -604,7 +605,7 @@
        . = ALIGN(sbss_align);                                          \
        .sbss : AT(ADDR(.sbss) - LOAD_OFFSET) {                         \
                *(.dynsbss)                                             \
index 250bf1180f0c85e4231ffcb0b8730f3440f23f25..003175c2236980973b7bc3981654f4b08aecaf3a 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #include <linux/export.h>
  
  /* Align . to a 8 byte boundary equals to maximum function alignment. */
-@@ -341,14 +351,14 @@
+@@ -342,14 +352,14 @@
        /* Kernel symbol table: Normal symbols */                       \
        __ksymtab         : AT(ADDR(__ksymtab) - LOAD_OFFSET) {         \
                VMLINUX_SYMBOL(__start___ksymtab) = .;                  \
@@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                VMLINUX_SYMBOL(__stop___ksymtab_gpl) = .;               \
        }                                                               \
                                                                        \
-@@ -410,7 +420,7 @@
+@@ -411,7 +421,7 @@
                                                                        \
        /* Kernel symbol table: strings */                              \
          __ksymtab_strings : AT(ADDR(__ksymtab_strings) - LOAD_OFFSET) {       \
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }                                                               \
                                                                        \
        /* __*init sections */                                          \
-@@ -793,6 +803,8 @@
+@@ -796,6 +806,8 @@
        EXIT_TEXT                                                       \
        EXIT_DATA                                                       \
        EXIT_CALL                                                       \
index 718b8addd4430e8d7c58e930125ea9d69d9fd0d7..1d10af647f1b851ca813e51bc417ad5a6ea5e5ec 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  /* The Mellanox Tavor device gives false positive parity errors
   * Mark this device with a broken_parity_status, to allow
   * PCI scanning code to "skip" this now blacklisted device.
-@@ -3095,6 +3096,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
+@@ -3108,6 +3109,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65f9, quirk_intel_mc_errata);
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65fa, quirk_intel_mc_errata);
  
@@ -40,7 +40,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
  /*
   * Ivytown NTB BAR sizes are misreported by the hardware due to an erratum.  To
-@@ -3151,6 +3153,8 @@ static void fixup_debug_report(struct pc
+@@ -3164,6 +3166,8 @@ static void fixup_debug_report(struct pc
        }
  }
  
@@ -49,7 +49,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  /*
   * Some BIOS implementations leave the Intel GPU interrupts enabled,
   * even though no one is handling them (f.e. i915 driver is never loaded).
-@@ -3189,6 +3193,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
+@@ -3202,6 +3206,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x010a, disable_igfx_irq);
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0152, disable_igfx_irq);
  
index 0e09e1d4e0db66060faa61cd57408e312ac3ed1c..e75d19dfce8c0c4aa8f6035177d398a620efa865 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/dwc2/platform.c
 +++ b/drivers/usb/dwc2/platform.c
-@@ -406,6 +406,12 @@ static int dwc2_driver_probe(struct plat
+@@ -407,6 +407,12 @@ static int dwc2_driver_probe(struct plat
        if (retval)
                return retval;