mt76: remove unnecessary dependency from mt7915e
authorShiji Yang <yangshiji66@qq.com>
Sat, 17 Dec 2022 12:50:42 +0000 (12:50 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 7 Jan 2023 16:11:00 +0000 (17:11 +0100)
The kmod-mt7615-common package does not contain any code that
related to mt7915e Wi-Fi6 driver, so remove it.

Tested on ramips/mt7621: SIM SIMAX1800T

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
package/kernel/mt76/Makefile

index d6f53a1d509223234493d94afb2537da1fb25cec..4d0575ab3b5df50cb26af6660e369a781c590718 100644 (file)
@@ -221,7 +221,7 @@ endef
 define KernelPackage/mt7915e
   $(KernelPackage/mt76-default)
   TITLE:=MediaTek MT7915e wireless driver
-  DEPENDS+=@PCI_SUPPORT +kmod-mt7615-common +kmod-hwmon-core +kmod-thermal +@DRIVER_11AX_SUPPORT +@KERNEL_RELAY
+  DEPENDS+=@PCI_SUPPORT +kmod-mt76-connac +kmod-hwmon-core +kmod-thermal +@DRIVER_11AX_SUPPORT +@KERNEL_RELAY
   FILES:= $(PKG_BUILD_DIR)/mt7915/mt7915e.ko
   AUTOLOAD:=$(call AutoProbe,mt7915e)
 endef