mediatek: use updated device tree overlay mechanism for BPi-R64
authorDaniel Golle <daniel@makrotopia.org>
Sun, 4 Jun 2023 18:55:11 +0000 (19:55 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 5 Jun 2023 10:36:32 +0000 (11:36 +0100)
Use new device tree overlay mechanism for the BananaPi BPi-R64 board.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mediatek/image/mt7622.mk
target/linux/mediatek/mt7622/base-files/etc/board.d/05_compat-version [new file with mode: 0644]
target/linux/mediatek/patches-5.15/900-dts-mt7622-bpi-r64-aliases-for-dtoverlay.patch

index 92824ff24a6f77564c5b0a3ba063d7f2b45e18f3..c02390100b4b27cea1dbb8113fc71dfb34a30da6 100644 (file)
@@ -96,6 +96,8 @@ define Device/bananapi_bpi-r64
   KERNEL                       := kernel-bin | gzip
   KERNEL_INITRAMFS             := kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb with-initrd | pad-to 128k
   IMAGE/sysupgrade.itb         := append-kernel | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb external-static-with-rootfs | append-metadata
+  DEVICE_COMPAT_VERSION := 1.1
+  DEVICE_COMPAT_MESSAGE := Device tree overlay mechanism needs bootloader update
 endef
 TARGET_DEVICES += bananapi_bpi-r64
 
diff --git a/target/linux/mediatek/mt7622/base-files/etc/board.d/05_compat-version b/target/linux/mediatek/mt7622/base-files/etc/board.d/05_compat-version
new file mode 100644 (file)
index 0000000..c8fb2c0
--- /dev/null
@@ -0,0 +1,15 @@
+
+. /lib/functions.sh
+. /lib/functions/uci-defaults.sh
+
+board_config_update
+
+case "$(board_name)" in
+       bananapi,bpi-r64)
+               ucidef_set_compat_version "1.1"
+               ;;
+esac
+
+board_config_flush
+
+exit 0
index b15d04f8bb0945954237094f46b01ad1f130d0c2..f779c1e0473ab26921d816d1931a0879531c61b6 100644 (file)
@@ -10,7 +10,7 @@
                gpios = <90 GPIO_ACTIVE_HIGH>;
                output-high;
 --- /dev/null
-+++ b/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64-sata.dts
++++ b/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64-sata.dtso
 @@ -0,0 +1,31 @@
 +/* SPDX-License-Identifier: (GPL-2.0-only OR MIT) */
 +
@@ -44,7 +44,7 @@
 +      };
 +};
 --- /dev/null
-+++ b/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64-pcie1.dts
++++ b/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64-pcie1.dtso
 @@ -0,0 +1,17 @@
 +/* SPDX-License-Identifier: (GPL-2.0-only OR MIT) */
 +