nettle: disable assembler on ppc64
authorStijn Tintel <stijn@linux-ipv6.be>
Sun, 15 Aug 2021 16:00:02 +0000 (19:00 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Tue, 21 Dec 2021 19:36:55 +0000 (21:36 +0200)
As of version 3.7, Nettle added PowerPC64 assembly for several
algorithms. Unfortunately, they cause build to fail due to ABI mismatch:

gcm-hash.o: ABI version 1 is not compatible with ABI version 2 output

Disable assembler when ppc64 and musl are used for now.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Acked-by: Rui Salvaterra <rsalvaterra@gmail.com>
package/libs/nettle/Makefile

index 3b4bd9d05343764355da4cdb657942fd208d554c..87853baa829927c42964938c42eccf5e8c2c6594 100644 (file)
@@ -44,7 +44,8 @@ CONFIGURE_ARGS += \
        --enable-fat \
        --disable-openssl \
        --disable-documentation \
-       --enable-static
+       --enable-static \
+       $(if $(CONFIG_powerpc64), $(if $(CONFIG_USE_MUSL),--disable-assembler))
 
 ifeq ($(CONFIG_LIBNETTLE_MINI),y)
 CONFIGURE_ARGS += --enable-mini-gmp