kernel: bump 5.4 to 5.4.118
authorJohn Audia <graysky@archlinux.us>
Tue, 11 May 2021 15:50:27 +0000 (11:50 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 23 May 2021 13:09:06 +0000 (15:09 +0200)
Manually rebased:
  ath79/patches-5.4/0033-spi-ath79-drop-pdata-support.patch

Removed uneeded patch:
  ath79/patches-5.4/0050-spi-ath79-remove-spi-master-setup-and-cleanup-assign.patch

All other patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
18 files changed:
include/kernel-version.mk
target/linux/apm821xx/patches-5.4/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/ath79/patches-5.4/0033-spi-ath79-drop-pdata-support.patch
target/linux/ath79/patches-5.4/0050-spi-ath79-remove-spi-master-setup-and-cleanup-assign.patch [deleted file]
target/linux/ath79/patches-5.4/410-spi-ath79-Implement-the-spi_mem-interface.patch
target/linux/bcm27xx/patches-5.4/950-0043-MMC-added-alternative-MMC-driver.patch
target/linux/bcm27xx/patches-5.4/950-0219-xhci-implement-xhci_fixup_endpoint-for-interval-adju.patch
target/linux/bcm27xx/patches-5.4/950-0293-xhci-Use-more-event-ring-segment-table-entries.patch
target/linux/bcm27xx/patches-5.4/950-0504-mmc-sdhci-Silence-MMC-warnings.patch
target/linux/bcm53xx/patches-5.4/180-usb-xhci-add-support-for-performing-fake-doorbell.patch
target/linux/generic/backport-5.4/080-wireguard-0052-crypto-x86-curve25519-support-assemblers-with-no-adx.patch
target/linux/generic/hack-5.4/204-module_strip.patch
target/linux/layerscape/patches-5.4/820-usb-0005-usb-dwc3-add-otg-properties-update.patch
target/linux/layerscape/patches-5.4/820-usb-0015-MLK-17380-4-usb-host-xhci-add-EH-SINGLE_STEP_SET_FEA.patch
target/linux/layerscape/patches-5.4/820-usb-0018-MLK-18794-1-usb-host-xhci-add-.bus_suspend-override.patch
target/linux/mvebu/patches-5.4/020-arm64-dts-marvell-armada-37xx-Set-pcie_reset_pin-to-.patch
target/linux/mvebu/patches-5.4/021-arm64-dts-marvell-armada-37xx-Move-PCIe-comphy-handl.patch
target/linux/mvebu/patches-5.4/022-arm64-dts-marvell-armada-37xx-Move-PCIe-max-link-spe.patch

index 1fc005f8952616ad22a0728fee11a03b7058892e..dcf884af247872a4587406e1743bc58589cfd14a 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .117
+LINUX_VERSION-5.4 = .118
 LINUX_VERSION-5.10 = .39
 
-LINUX_KERNEL_HASH-5.4.117 = 4e989b5775830092e5c76b5cca65ebff862ad0c87d0b58c3a20d415c3d4ec770
+LINUX_KERNEL_HASH-5.4.118 = d970509c274fd2f5a9257a63c56f7a8b3e50ec12015bd6864dc4b76b38dc821b
 LINUX_KERNEL_HASH-5.10.39 = 5738a515ca97853481767360c568eae46c8d777d98a69e018a3299baa6b3f614
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 9d474f2d6237a7ce4e5ca23b0e6c5cbddf7adc5a..f248407fdbbe8fd50a4e57652136cf7d9697b291 100644 (file)
@@ -23,7 +23,7 @@ produce a noisy warning.
                xhci->quirks |= XHCI_RESET_ON_RESUME;
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -423,10 +423,14 @@ static int xhci_try_enable_msi(struct us
+@@ -427,10 +427,14 @@ static int xhci_try_enable_msi(struct us
                free_irq(hcd->irq, hcd);
        hcd->irq = 0;
  
index 8fd99bd3334284bb1148af866d6e34ce355c6170..162a82bda3d2dd3a7aa9e814ae13c3c895592e8d 100644 (file)
@@ -52,7 +52,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
        unsigned long rate;
        int ret;
  
-@@ -152,16 +150,10 @@ static int ath79_spi_probe(struct platfo
+@@ -152,15 +150,9 @@ static int ath79_spi_probe(struct platfo
        master->dev.of_node = pdev->dev.of_node;
        platform_set_drvdata(pdev, sp);
  
@@ -60,8 +60,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 -
        master->use_gpio_descriptors = true;
        master->bits_per_word_mask = SPI_BPW_RANGE_MASK(1, 32);
-       master->setup = spi_bitbang_setup;
-       master->cleanup = spi_bitbang_cleanup;
+       master->flags = SPI_MASTER_GPIO_SS;
 -      if (pdata) {
 -              master->bus_num = pdata->bus_num;
 -              master->num_chipselect = pdata->num_chipselect;
diff --git a/target/linux/ath79/patches-5.4/0050-spi-ath79-remove-spi-master-setup-and-cleanup-assign.patch b/target/linux/ath79/patches-5.4/0050-spi-ath79-remove-spi-master-setup-and-cleanup-assign.patch
deleted file mode 100644 (file)
index a57ac24..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From b142b1beb199f62d47370c98a3dd8e13f792e9c0 Mon Sep 17 00:00:00 2001
-From: David Bauer <mail@david-bauer.net>
-Date: Thu, 27 Feb 2020 23:03:20 +0100
-Subject: [PATCH] spi: ath79: remove spi-master setup and cleanup assignment
-
-This removes the assignment of setup and cleanup functions for the ath79
-target. Assigning the setup-method will lead to 'setup_transfer' not
-being assigned in spi_bitbang_init.
-
-Also drop the redundant cleanup assignment, as this also happens in
-spi_bitbang_init.
-
-Signed-off-by: David Bauer <mail@david-bauer.net>
----
- drivers/spi/spi-ath79.c | 2 --
- 1 file changed, 2 deletions(-)
-
---- a/drivers/spi/spi-ath79.c
-+++ b/drivers/spi/spi-ath79.c
-@@ -152,8 +152,6 @@ static int ath79_spi_probe(struct platfo
-       master->use_gpio_descriptors = true;
-       master->bits_per_word_mask = SPI_BPW_RANGE_MASK(1, 32);
--      master->setup = spi_bitbang_setup;
--      master->cleanup = spi_bitbang_cleanup;
-       sp->bitbang.master = master;
-       sp->bitbang.chipselect = ath79_spi_chipselect;
index 2a6b9857fb5cc2e9327beac4231868f577586609..51a71c6ef2fdd405b8ada92560aa90c8054e8225 100644 (file)
@@ -58,7 +58,7 @@ Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
  static int ath79_spi_probe(struct platform_device *pdev)
  {
        struct spi_master *master;
-@@ -163,6 +197,7 @@ static int ath79_spi_probe(struct platfo
+@@ -164,6 +198,7 @@ static int ath79_spi_probe(struct platfo
                ret = PTR_ERR(sp->base);
                goto err_put_master;
        }
index 4f5e392d781d734d8deeee2d8242f00dada0d9de..a9f99add60c4776fcca51029c21b7aee34a97a0b 100644 (file)
@@ -222,7 +222,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  static inline int mmc_blk_part_switch(struct mmc_card *card,
                                      unsigned int part_type);
  
-@@ -2868,6 +2875,7 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2884,6 +2891,7 @@ static int mmc_blk_probe(struct mmc_card
  {
        struct mmc_blk_data *md, *part_md;
        char cap_str[10];
@@ -230,7 +230,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  
        /*
         * Check that the card supports the command class(es) we need.
-@@ -2875,7 +2883,16 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2891,7 +2899,16 @@ static int mmc_blk_probe(struct mmc_card
        if (!(card->csd.cmdclass & CCC_BLOCK_READ))
                return -ENODEV;
  
@@ -248,7 +248,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  
        card->complete_wq = alloc_workqueue("mmc_complete",
                                        WQ_MEM_RECLAIM | WQ_HIGHPRI, 0);
-@@ -2890,9 +2907,14 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2906,9 +2923,14 @@ static int mmc_blk_probe(struct mmc_card
  
        string_get_size((u64)get_capacity(md->disk), 512, STRING_UNITS_2,
                        cap_str, sizeof(cap_str));
@@ -279,7 +279,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  }
 --- a/drivers/mmc/core/host.c
 +++ b/drivers/mmc/core/host.c
-@@ -397,15 +397,30 @@ struct mmc_host *mmc_alloc_host(int extr
+@@ -434,15 +434,30 @@ struct mmc_host *mmc_alloc_host(int extr
  {
        int err;
        struct mmc_host *host;
index f6eac15a53dd1344ec993ef2c97f27cba3e1590b..49f714991c326713bb4c2dcc0adee47766d07397 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
 
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -1464,6 +1464,103 @@ command_cleanup:
+@@ -1468,6 +1468,103 @@ command_cleanup:
  }
  
  /*
@@ -119,7 +119,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
   * non-error returns are a promise to giveback() the urb later
   * we drop ownership so next owner (or urb unlink) can get it
   */
-@@ -5345,6 +5442,7 @@ static const struct hc_driver xhci_hc_dr
+@@ -5357,6 +5454,7 @@ static const struct hc_driver xhci_hc_dr
        .endpoint_reset =       xhci_endpoint_reset,
        .check_bandwidth =      xhci_check_bandwidth,
        .reset_bandwidth =      xhci_reset_bandwidth,
index 4b4766f739bd0db7e97dc4b396c9f948ece461c5..20bab47514edf9936c25a82227a8704ad734ddd5 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
 
 --- a/drivers/usb/host/xhci-mem.c
 +++ b/drivers/usb/host/xhci-mem.c
-@@ -2503,9 +2503,11 @@ int xhci_mem_init(struct xhci_hcd *xhci,
+@@ -2512,9 +2512,11 @@ int xhci_mem_init(struct xhci_hcd *xhci,
         * Event ring setup: Allocate a normal ring, but also setup
         * the event ring segment table (ERST).  Section 4.9.3.
         */
@@ -36,7 +36,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
        if (!xhci->event_ring)
                goto fail;
        if (xhci_check_trb_in_td_math(xhci) < 0)
-@@ -2518,7 +2520,7 @@ int xhci_mem_init(struct xhci_hcd *xhci,
+@@ -2527,7 +2529,7 @@ int xhci_mem_init(struct xhci_hcd *xhci,
        /* set ERST count with the number of entries in the segment table */
        val = readl(&xhci->ir_set->erst_size);
        val &= ERST_SIZE_MASK;
index 38349280bb4a61eb33a97544bd2ae553d3877f18..8acdba434e755e7ffedea56562c5efa09c67efa8 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
  
  #define MAX_TUNING_LOOP 40
  
-@@ -2756,7 +2756,7 @@ static void sdhci_timeout_timer(struct t
+@@ -2758,7 +2758,7 @@ static void sdhci_timeout_timer(struct t
        spin_lock_irqsave(&host->lock, flags);
  
        if (host->cmd && !sdhci_data_line_cmd(host->cmd)) {
@@ -31,7 +31,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
                       mmc_hostname(host->mmc));
                sdhci_dumpregs(host);
  
-@@ -2778,7 +2778,7 @@ static void sdhci_timeout_data_timer(str
+@@ -2780,7 +2780,7 @@ static void sdhci_timeout_data_timer(str
  
        if (host->data || host->data_cmd ||
            (host->cmd && sdhci_data_line_cmd(host->cmd))) {
index 483a9c0c750036d39f2953468889c8d88ef4277d..5427d7368ec511527dc71edc5aa634f80c37a5ec 100644 (file)
@@ -90,7 +90,7 @@ it on BCM4708 family.
  /*
   * Reset a halted HC.
   *
-@@ -604,10 +647,20 @@ static int xhci_init(struct usb_hcd *hcd
+@@ -608,10 +651,20 @@ static int xhci_init(struct usb_hcd *hcd
  
  static int xhci_run_finished(struct xhci_hcd *xhci)
  {
@@ -114,7 +114,7 @@ it on BCM4708 family.
        xhci->shared_hcd->state = HC_STATE_RUNNING;
        xhci->cmd_ring_state = CMD_RING_STATE_RUNNING;
  
-@@ -617,6 +670,10 @@ static int xhci_run_finished(struct xhci
+@@ -621,6 +674,10 @@ static int xhci_run_finished(struct xhci
        xhci_dbg_trace(xhci, trace_xhci_dbg_init,
                        "Finished xhci_run for USB3 roothub");
        return 0;
index 513025552d6c6a998fcbb809a4e6d195ac29e582..cd507b1e448149fe1dc2d6777db0311e196797c7 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
 
 --- a/arch/x86/Makefile
 +++ b/arch/x86/Makefile
-@@ -197,9 +197,10 @@ avx2_instr :=$(call as-instr,vpbroadcast
+@@ -198,9 +198,10 @@ avx2_instr :=$(call as-instr,vpbroadcast
  avx512_instr :=$(call as-instr,vpmovm2b %k1$(comma)%zmm5,-DCONFIG_AS_AVX512=1)
  sha1_ni_instr :=$(call as-instr,sha1msg1 %xmm0$(comma)%xmm1,-DCONFIG_AS_SHA1_NI=1)
  sha256_ni_instr :=$(call as-instr,sha256msg1 %xmm0$(comma)%xmm1,-DCONFIG_AS_SHA256_NI=1)
index a207a11ee56f7577ef8f4f091836b0867d8296fc..22bb1ac33af8f4676df52c54cef28c41416d32e6 100644 (file)
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -3224,9 +3224,11 @@ static int setup_load_info(struct load_i
+@@ -3252,9 +3252,11 @@ static int setup_load_info(struct load_i
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -125,7 +125,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
-@@ -3247,6 +3249,7 @@ static int check_modinfo(struct module *
+@@ -3275,6 +3277,7 @@ static int check_modinfo(struct module *
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }
index 848be9b5fe111ab4f8bc25d31962f2d97dea3ce0..ab9630677461431f8b9accf185e87c9716f5e21c 100644 (file)
@@ -54,7 +54,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
         * All 3.1 IP version constants are greater than the 3.0 IP
 --- a/drivers/usb/dwc3/gadget.c
 +++ b/drivers/usb/dwc3/gadget.c
-@@ -3558,6 +3558,10 @@ int dwc3_gadget_init(struct dwc3 *dwc)
+@@ -3568,6 +3568,10 @@ int dwc3_gadget_init(struct dwc3 *dwc)
        dwc->gadget.sg_supported        = true;
        dwc->gadget.name                = "dwc3-gadget";
        dwc->gadget.lpm_capable         = true;
index 0334e72d9e55bed9034eaa5d7ee228fdf49de453..58cccfff5e52987816d9b8a60164978bf88f3117 100644 (file)
@@ -174,7 +174,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
   * bursts that are required to move all packets in this TD.  Only SuperSpeed
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -5372,6 +5372,7 @@ static const struct hc_driver xhci_hc_dr
+@@ -5384,6 +5384,7 @@ static const struct hc_driver xhci_hc_dr
        .disable_usb3_lpm_timeout =     xhci_disable_usb3_lpm_timeout,
        .find_raw_port_number = xhci_find_raw_port_number,
        .clear_tt_buffer_complete = xhci_clear_tt_buffer_complete,
index 2f1d183853978cd01dbcb8acd87163137cf70ed4..3f805756fac6e0929d6483aa2ec44338c7962fc2 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
 
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -5393,6 +5393,8 @@ void xhci_init_driver(struct hc_driver *
+@@ -5405,6 +5405,8 @@ void xhci_init_driver(struct hc_driver *
                        drv->check_bandwidth = over->check_bandwidth;
                if (over->reset_bandwidth)
                        drv->reset_bandwidth = over->reset_bandwidth;
index 87247b63ad7b23deb78530b03a7d877c1a028d74..9eeddaeba1600ec86940f145f1fe377d0a75f43c 100644 (file)
@@ -82,7 +82,7 @@ Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
        pinctrl-0 = <&pcie_reset_pins &pcie_clkreq_pins>;
 --- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
 +++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
-@@ -317,7 +317,7 @@
+@@ -318,7 +318,7 @@
  
                                pcie_reset_pins: pcie-reset-pins {
                                        groups = "pcie1";
index e92393ff6f74b449d87b5b799a0e5ccbb54e57fc..0c7830cb4750dbff21421f50b56159d01768fb4e 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
        status = "disabled";
 --- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
 +++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
-@@ -493,6 +493,7 @@
+@@ -494,6 +494,7 @@
                                        <0 0 0 2 &pcie_intc 1>,
                                        <0 0 0 3 &pcie_intc 2>,
                                        <0 0 0 4 &pcie_intc 3>;
index ad918bef88761c4907f4ab4198e46c4cb0b82813..04002480cc5a07d75b1548e1008e972d9993edbd 100644 (file)
@@ -34,7 +34,7 @@ Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
        /* enabled by U-Boot if PCIe module is present */
 --- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
 +++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
-@@ -493,6 +493,7 @@
+@@ -494,6 +494,7 @@
                                        <0 0 0 2 &pcie_intc 1>,
                                        <0 0 0 3 &pcie_intc 2>,
                                        <0 0 0 4 &pcie_intc 3>;