target: Make TARGET_SERIAL independent of GRUB configuration
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Nov 2023 22:04:04 +0000 (23:04 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 29 Nov 2023 22:43:01 +0000 (23:43 +0100)
GRUB_SERIAL is also used for the default serial on the target and not
only in grub. When no grub was build it was not available and the build
fails.

Rename GRUB_SERIAL to TARGET_SERIAL and make it always available on x86
and armsr targets.

Fixes: #14063
Fixes: b10768476f9d ("x86,armsr: interpolate GRUB_SERIAL into /etc/inittab")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
config/Config-images.in
target/linux/armsr/base-files.mk
target/linux/armsr/image/Makefile
target/linux/x86/base-files.mk
target/linux/x86/image/Makefile

index c37537b1a71cdac34447f8bca7290ed4ecd4b617..c2d7af7a80b105f0c5a6a92a2caf63a9541e3984 100644 (file)
@@ -218,11 +218,6 @@ menu "Target Images"
                depends on GRUB_IMAGES || GRUB_EFI_IMAGES
                default y
 
-       config GRUB_SERIAL
-               string "Serial port device"
-               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
-               default "ttyS0"
-
        config GRUB_BAUDRATE
                int "Serial port baud rate"
                depends on GRUB_IMAGES || GRUB_EFI_IMAGES
@@ -231,7 +226,8 @@ menu "Target Images"
 
        config GRUB_FLOWCONTROL
                bool "Use RTE/CTS on serial console"
-               depends on GRUB_SERIAL != ""
+               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
+               depends on TARGET_SERIAL != ""
 
        config GRUB_BOOTOPTS
                string "Extra kernel boot options"
@@ -277,6 +273,11 @@ menu "Target Images"
                depends on GRUB_IMAGES || GRUB_EFI_IMAGES
                select PACKAGE_kmod-e1000
 
+       config TARGET_SERIAL
+               string "Serial port device"
+               depends on TARGET_x86 || TARGET_armsr
+               default "ttyS0"
+
        config TARGET_IMAGES_GZIP
                bool "GZip images"
                depends on TARGET_ROOTFS_EXT4FS || TARGET_x86 || TARGET_armsr || TARGET_malta
index 88ba97d38a3d9feff24b6b7e3ac1ea46ea463417..e2b7d05f57379e79cfec98868847b71c925aa29a 100644 (file)
@@ -1,6 +1,6 @@
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
 ifeq ($(GRUB_SERIAL),)
-$(error This platform requires CONFIG_GRUB_SERIAL be set!)
+$(error This platform requires CONFIG_TARGET_SERIAL be set!)
 endif
 
 define Package/base-files/install-target
index e5be3fbe38f426d16aa94a38f552586c6e835263..ec566c5818f8496900c61bebde00f597c24d3fbf 100644 (file)
@@ -15,7 +15,7 @@ ifneq ($(CONFIG_GRUB_CONSOLE),)
   GRUB_TERMINALS += console
 endif
 
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
 
 GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)
 GRUB_TERMINALS += serial
index 88ba97d38a3d9feff24b6b7e3ac1ea46ea463417..e2b7d05f57379e79cfec98868847b71c925aa29a 100644 (file)
@@ -1,6 +1,6 @@
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
 ifeq ($(GRUB_SERIAL),)
-$(error This platform requires CONFIG_GRUB_SERIAL be set!)
+$(error This platform requires CONFIG_TARGET_SERIAL be set!)
 endif
 
 define Package/base-files/install-target
index d95fd15f00825c06a1233625046fe37448620e23..6e59f2e465f3cb88fdcbee0cdc43f6069545e931 100644 (file)
@@ -16,7 +16,7 @@ ifneq ($(CONFIG_GRUB_CONSOLE),)
   GRUB_TERMINALS += console
 endif
 
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
 
 GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8$(if $(CONFIG_GRUB_FLOWCONTROL),r,)
 GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)