ramips: add support for Xiaomi Mi Router 4C
authorAtaberk Özen <ataberkozen123@gmail.com>
Wed, 19 Aug 2020 18:43:54 +0000 (21:43 +0300)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 25 Nov 2020 18:34:13 +0000 (19:34 +0100)
This commit adds support for Xiaomi's Mi Router 4C device.

Specifications:

- CPU: MediaTek MT7628AN (580MHz)
- Flash: 16MB
- RAM: 64MB DDR2
- 2.4 GHz: IEEE 802.11b/g/n with Integrated LNA and PA
- Antennas: 4x external single band antennas
- WAN: 1x 10/100M
- LAN: 2x 10/100M
- LEDs: 2x yellow/blue. Programmable (labelled as power on case)
                      - Non-programmable (shows WAN activity)
- Button: Reset

How to install:

1- Use OpenWRTInvasion to gain telnet and ftp access.
2- Push openwrt firmware to /tmp/ using ftp.
3- Connect to router using telnet. (IP: 192.168.31.1 -
   Username: root - No password)
4- Use command "mtd -r write /tmp/firmware.bin OS1" to flash into
   the router..
5- It takes around 2 minutes. After that router will restart itself
   to OpenWrt.

Signed-off-by: Ataberk Özen <ataberkozen123@gmail.com>
[wrap commit message, bump PKG_RELEASE for uboot-envtools, remove
dts-v1 from DTS, fix LED labels]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/ramips
target/linux/ramips/dts/mt7628an_xiaomi_mi-router-4c.dts [new file with mode: 0644]
target/linux/ramips/image/mt76x8.mk
target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
target/linux/ramips/mt76x8/base-files/etc/init.d/bootcount

index 7ab3619a850fe99bdf985fe6ce71de3a50a3bc46..398f37de120d9c4604e0448be524faff48c37535 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2020.04
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
index 3ef345d065fb5f7d19b71f4705ae77768fe311d3..a2753eed7ac90362c6649fd750111a3f6e668ecc 100644 (file)
@@ -31,6 +31,7 @@ mediatek,linkit-smart-7688|\
 samknows,whitebox-v8|\
 xiaomi,mir3g-v2|\
 xiaomi,mi-router-4a-gigabit|\
+xiaomi,mi-router-4c|\
 xiaomi,miwifi-nano|\
 zbtlink,zbt-wg2626)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x1000" "0x10000"
diff --git a/target/linux/ramips/dts/mt7628an_xiaomi_mi-router-4c.dts b/target/linux/ramips/dts/mt7628an_xiaomi_mi-router-4c.dts
new file mode 100644 (file)
index 0000000..a6445c8
--- /dev/null
@@ -0,0 +1,133 @@
+//SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "xiaomi,mi-router-4c", "mediatek,mt7628an-soc";
+       model = "Xiaomi Mi Router 4C";
+
+       aliases {
+               led-boot = &led_power_yellow;
+               led-failsafe = &led_power_yellow;
+               led-running = &led_power_blue;
+               led-upgrade = &led_power_yellow;
+               label-mac-device = &ethernet;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power_blue: power_blue {
+                       label = "blue:power";
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+               };
+
+               led_power_yellow: power_yellow {
+                       label = "yellow:power";
+                       gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "gpio", "wdt", "wled_an";
+               function = "gpio";
+       };
+};
+
+&ehci {
+       status = "disabled";
+};
+
+&ohci {
+       status = "disabled";
+};
+
+&esw {
+       mediatek,portmap = <0x3d>;
+       mediatek,portdisable = <0x29>;
+};
+
+&wmac {
+       status = "okay";
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x28>;
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <40000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "bootloader";
+                               reg = <0x0 0x20000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "config";
+                               reg = <0x20000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@30000 {
+                               label = "factory";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "crash";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               label = "cfg_bak";
+                               reg = <0x50000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "overlay";
+                               reg = <0x60000 0x100000>;
+                               read-only;
+                       };
+
+                       partition@160000 {
+                               label = "firmware";
+                               reg = <0x160000 0xea0000>;
+                               compatible = "denx,uimage";
+                       };
+               };
+       };
+};
index 72539f7a14d90378731c219a38049103c65aec57..edd42a4dd53d4608e6a08576a3f64847317a675d 100644 (file)
@@ -752,6 +752,14 @@ define Device/xiaomi_mir4a-100m
 endef
 TARGET_DEVICES += xiaomi_mir4a-100m
 
+define Device/xiaomi_mi-router-4c
+  IMAGE_SIZE := 14976k
+  DEVICE_VENDOR := Xiaomi
+  DEVICE_MODEL := Mi Router 4C
+  DEVICE_PACKAGES := uboot-envtools
+endef
+TARGET_DEVICES += xiaomi_mi-router-4c
+
 define Device/xiaomi_miwifi-nano
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Xiaomi
index f4e3fcacb5fb8de3dcdaf6d7fc27f792dded1568..6f0078c70ac4540cacc96b59dc4936026b747df8 100755 (executable)
@@ -137,6 +137,10 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "4:lan:1" "2:lan:2" "0:wan" "6@eth0"
                ;;
+       xiaomi,mi-router-4c)
+               ucidef_add_switch "switch0" \
+                       "4:lan:1" "2:lan:2" "1:wan" "6@eth0"
+               ;;
        xiaomi,miwifi-nano)
                ucidef_add_switch "switch0" \
                        "0:lan:2" "2:lan:1" "4:wan" "6@eth0"
@@ -234,6 +238,7 @@ ramips_setup_macs()
                label_mac=$(mtd_get_mac_binary factory 0x4)
                wan_mac=$(mtd_get_mac_binary factory 0x28)
                ;;
+       xiaomi,mi-router-4c|\
        xiaomi,mir4a-100m)
                wan_mac=$(mtd_get_mac_binary factory 0x4)
                ;;
index 3c21433cc55a9b32dcc0160d6f755144fadc4af1..23f1e71b41809c63ba9a0256be0100476f339344 100755 (executable)
@@ -8,6 +8,7 @@ boot() {
                [ -n "$(fw_printenv bootcount bootchanged 2>/dev/null)" ] &&\
                        echo -e "bootcount\nbootchanged\n" | /usr/sbin/fw_setenv -s -
                ;;
+       xiaomi,mi-router-4c|\
        xiaomi,miwifi-nano)
                fw_setenv flag_boot_success 1
                ;;