mediatek: fix broken UniFi 6 LR image
authorDavid Bauer <mail@david-bauer.net>
Wed, 17 Mar 2021 23:56:02 +0000 (00:56 +0100)
committerDavid Bauer <mail@david-bauer.net>
Wed, 17 Mar 2021 23:56:33 +0000 (00:56 +0100)
Ubiquiti's own bootloader expects the configuration mode to be present
with a "@" instead of a "-" for the sperator character. Otherwise
booting of the image fails.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/mediatek/image/mt7622.mk

index fd043ed85fad1662df480f82195b21ec9e8a6537..88d71600b2d4f65f354440361c911503423f2fab 100644 (file)
@@ -193,6 +193,7 @@ TARGET_DEVICES += mediatek_mt7622-rfb1-ubi
 define Device/ubnt_unifi-6-lr
   DEVICE_VENDOR := Ubiquiti
   DEVICE_MODEL := UniFi 6 LR
+  DEVICE_DTS_CONFIG := config@1
   DEVICE_DTS := mt7622-ubnt-unifi-6-lr
   DEVICE_DTS_DIR := ../dts
   DEVICE_PACKAGES := kmod-mt7915e