ramips: rename to D-Team Newifi D2 and Lenovo Newifi D1
authorArınç ÜNAL <arinc.unal@arinc9.com>
Tue, 18 Apr 2023 13:42:41 +0000 (16:42 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 18 May 2023 12:44:07 +0000 (14:44 +0200)
Rename Newifi D2 to D-Team Newifi D2, and Newifi D1 to Lenovo Newifi D1.
Let's not make naming exceptions because of marketing whims.

Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
target/linux/ramips/dts/mt7621_d-team_newifi-d2.dts
target/linux/ramips/dts/mt7621_lenovo_newifi-d1.dts
target/linux/ramips/image/mt7621.mk

index c04fe9e245daa45bf2a0a787ce9489495278c3ce..33deb21dcaa061d07b19c28b391817e79bb57a63 100644 (file)
@@ -5,7 +5,7 @@
 
 / {
        compatible = "d-team,newifi-d2", "mediatek,mt7621-soc";
-       model = "Newifi-D2";
+       model = "D-Team Newifi D2";
 
        aliases {
                led-boot = &led_power_blue;
index a6e38234dafba49c758b5e8cc8c29b1a7e290d0e..810ca3361af51f83dbd2a613861fe81c787f093a 100644 (file)
@@ -5,7 +5,7 @@
 
 / {
        compatible = "lenovo,newifi-d1", "mediatek,mt7621-soc";
-       model = "Newifi-D1";
+       model = "Lenovo Newifi D1";
 
        aliases {
                led-boot = &led_blue;
index f717fea5d4979e002bc1622a3085ee50913f244e..7c2152a9812fd5eb1b5269761c9bbaf40cc477fa 100644 (file)
@@ -774,8 +774,8 @@ define Device/d-team_newifi-d2
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 32448k
-  DEVICE_VENDOR := Newifi
-  DEVICE_MODEL := D2
+  DEVICE_VENDOR := D-Team
+  DEVICE_MODEL := Newifi D2
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 \
        kmod-usb-ledtrig-usbport -uboot-envtools
 endef
@@ -1425,8 +1425,8 @@ define Device/lenovo_newifi-d1
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 32448k
-  DEVICE_VENDOR := Newifi
-  DEVICE_MODEL := D1
+  DEVICE_VENDOR := Lenovo
+  DEVICE_MODEL := Newifi D1
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-sdhci-mt7620 \
        kmod-usb-ledtrig-usbport -uboot-envtools
   SUPPORTED_DEVICES += newifi-d1