uboot-sunxi: rename Sinovoip BPI M2 Plus to Bananapi M2 Plus H3
authorPetr Štetiar <ynezz@true.cz>
Wed, 25 Mar 2020 11:55:45 +0000 (12:55 +0100)
committerPetr Štetiar <ynezz@true.cz>
Sat, 28 Mar 2020 12:03:02 +0000 (13:03 +0100)
Rename the board as done in upstream commit 268ae6548779 ("sunxi: Rename
Sinovoip BPI M2 Plus to Bananapi M2 Plus H3") which backs the rename
with the following reasoning:

 The brand Sinovoip is used for Sinovoip's original VOIP products, while
 the Bananapi brand is for the single board computers they produce.  This
 has been verified by Bananapi. Rename the board from "Sinovoip BPI M2
 Plus" to "Bananapi M2 Plus". For the defconfig file, all lowercase is
 used.

 To support the H5 variant of this board, the "H3" suffix is added to
 the defconfig name.

This has to be done in order to allow building U-Boot past v2019.04
release where this change was introduced.

Ref: https://github.com/openwrt/openwrt/pull/2849#discussion_r396401489
Suggested-by: Pawel Dembicki <paweldembicki@gmail.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/boot/uboot-sunxi/Makefile

index 9bb61b14178299f29b7a9a23efdca9c61045694b..bdbefecf013aa489697c45f30f81d06835dc18c7 100644 (file)
@@ -222,9 +222,9 @@ define U-Boot/pine64_plus
   UENV:=a64
 endef
 
-define U-Boot/Sinovoip_BPI_M2_Plus
+define U-Boot/bananapi_m2_plus_h3
   BUILD_SUBTARGET:=cortexa7
-  NAME:=Bananapi M2 Plus
+  NAME:=Bananapi M2 Plus H3
   BUILD_DEVICES:=sinovoip_bananapi-m2-plus
 endef
 
@@ -266,6 +266,7 @@ UBOOT_TARGETS := \
        A20-OLinuXino-Lime2 \
        A20-OLinuXino-Lime2-eMMC \
        A20-OLinuXino_MICRO \
+       bananapi_m2_plus_h3 \
        Bananapi \
        Bananapi_M2_Ultra \
        Bananapro \
@@ -294,7 +295,6 @@ UBOOT_TARGETS := \
        orangepi_pc2 \
        pangolin \
        pine64_plus \
-       Sinovoip_BPI_M2_Plus \
        sopine_baseboard \
        orangepi_zero_plus