brcm63xx: move dg834g v4 to dts
authorJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:35:43 +0000 (15:35 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:35:43 +0000 (15:35 +0000)
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 44989

33 files changed:
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/dts/dg834g_v4.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch
target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/568-board_DGND3700v1_3800B.patch
target/linux/brcm63xx/patches-3.18/525-board_96348w3.patch
target/linux/brcm63xx/patches-3.18/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.18/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.18/528-board_nb6.patch
target/linux/brcm63xx/patches-3.18/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.18/534-board_hw556.patch
target/linux/brcm63xx/patches-3.18/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.18/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.18/565-board_hw520.patch
target/linux/brcm63xx/patches-3.18/568-board_DGND3700v1_3800B.patch
target/linux/brcm63xx/patches-3.18/569-board_homehub2a.patch
target/linux/brcm63xx/profiles/netgear.mk

index 324ea184047c2d5ec938011232145e21dcdd6f0c..991e3636a6a79764a164ff0dde0a0c7e95cffac3 100755 (executable)
@@ -144,6 +144,9 @@ brcm63xx_dt_detect() {
        "Netgear DG834GT/PN")
                board_name="dg834gt"
                ;;
+       "Netgear DG834G v4")
+               board_name="dg834g_v4"
+               ;;
        "Netgear DGND3700v1/DGND3800B")
                board_name="dgnd3700v1_dgnd3800b"
                ;;
@@ -213,9 +216,6 @@ brcm63xx_legacy_detect() {
        local board_name
 
        case "$1" in
-       96348W3)
-               board_name="dg834g_v4"
-               ;;
        CPVA502+)
                board_name="cpva502p"
                ;;
diff --git a/target/linux/brcm63xx/dts/dg834g_v4.dts b/target/linux/brcm63xx/dts/dg834g_v4.dts
new file mode 100644 (file)
index 0000000..8cbb3f3
--- /dev/null
@@ -0,0 +1,66 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+       model = "Netgear DG834G v4";
+       compatible = "netgear,dg834g-v4", "brcm,bcm6348";
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               debounce-interval = <60>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 6 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power_green {
+                       label = "96348W3:green:power";
+                       gpios = <&gpio0 0 1>;
+                       default-state = "on";
+               };
+               status {
+                       label = "96348W3:red:power";
+                       gpios = <&gpio0 1 1>;
+               };
+               inet_green {
+                       label = "96348W3::adsl";
+                       gpios = <&gpio0 2 1>;
+               };
+               inet_red {
+                       label = "96348W3::internet";
+                       gpios = <&gpio0 3 1>;
+               };
+       };
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x3e0000>;
+       };
+
+       nvram@3f0000 {
+               label = "nvram";
+               reg = <0x3f0000 0x010000>;
+       };
+};
index bc633a7160191f739b9a3bcb588af976ffa4d440..0c164770a1a628caf312cfaf55ef01ae9a8721ad 100755 (executable)
@@ -332,6 +332,8 @@ $(eval $(call ImageDTB,RedBootDTB,Livebox,livebox,livebox-blue-5g))
 $(eval $(call ImageDTB,Dummy,CVG834G,cvg834g,cvg834g,a020,0001,0022,vmlinux-cvg834g))
 # Netgear DG834GT/PN
 $(eval $(call ImageDTB,CFEDTB,DG834GTPN,DG834GT_PN,dg834gtpn,96348GW-10,6348))
+# Netgear DG834G v4
+$(eval $(call ImageDTB,Dummy,DG834GV4,DG834GTv4,dg834g_v4,96348W3,6348))
 # Netgear DGND3700 v1 / DGND3800B
 $(eval $(call ImageDTB,CFEDTB,DGND3700v1_3800B,DGND3700v1_3800B,dgnd3700v1,96368MVWG,6368,--image-offset 0x20000 --block-size 0x20000))
 #Netgear DGND3700 v1 factory firmware
index 676f704996cbe4ce81eecb0d457460c4cd8a7ba0..c0b14572c1dea7d4590bfb7b634f0f08b930623c 100644 (file)
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
+@@ -1443,6 +1463,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
+       { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
+       { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
++      { .compatible = "netgear,dg834g-v4", .data = &board_96348W3, },
+       { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
+       { .compatible = "t-com,spw500v", .data = &board_spw500v, },
+       { .compatible = "tecom,gw6000", .data = &board_gw6000, },
index 6b296ee47998231b3f47e7bb55bd78d41ddce333..11e4ff4be56ccbfc9d3ebbb9d974e647f68370b0 100644 (file)
@@ -40,7 +40,7 @@
        &board_HW553,
        &board_spw303v,
  #endif
-@@ -1474,6 +1500,7 @@ static struct of_device_id const bcm963x
+@@ -1475,6 +1501,7 @@ static struct of_device_id const bcm963x
        { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
index d1c703c9d1e9dacb5525290b1b1b98c3f891b5b7..4ac9d2db5cca8e9826d4fe725e02a30b0bf8c8a9 100644 (file)
@@ -45,7 +45,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -1503,6 +1534,7 @@ static struct of_device_id const bcm963x
+@@ -1504,6 +1535,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
index 7788622fc002279cef4a22435556fd0580fc0095..68c1dc36969da30e598b77fa9dae82969808e07d 100644 (file)
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
-@@ -1545,6 +1617,9 @@ static struct of_device_id const bcm963x
+@@ -1546,6 +1618,9 @@ static struct of_device_id const bcm963x
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
index ae81e3124686fdae54d997933580cfcf72ccf483..11a4f6aaf8c8d553d4c3c8e0709ee2a05dd2ab1c 100644 (file)
@@ -32,9 +32,9 @@
        &board_DV201AMR,
        &board_96348gw_a,
        &board_rta1025w_16,
-@@ -1593,6 +1611,7 @@ static struct of_device_id const bcm963x
-       { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
+@@ -1594,6 +1612,7 @@ static struct of_device_id const bcm963x
        { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
+       { .compatible = "netgear,dg834g-v4", .data = &board_96348W3, },
        { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
 +      { .compatible = "sagem,f@st2604", .data = &board_FAST2604, },
        { .compatible = "t-com,spw500v", .data = &board_spw500v, },
index 7ea7297bb6c829ab6198969de085f4b87516e70c..280ac79f67e76862d8843b938ae2c1d4d464bafa 100644 (file)
        &board_spw303v,
        &board_DVAG3810BN,
  #endif
-@@ -1855,6 +1946,9 @@ static struct of_device_id const bcm963x
+@@ -1856,6 +1947,9 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
index 7c877527ba45478c1a119c4b15cec82a3e54398c..c83e5b7ae0dfb7c13a2afeab1297aa597eb4aa84 100644 (file)
@@ -58,7 +58,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -2054,6 +2092,7 @@ static struct of_device_id const bcm963x
+@@ -2055,6 +2093,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6362
index 986f85b3fd8f3e74aef3e3bf8cf435b7eec054a8..ca7ed5519c38dfb9f92f80b05fc04a113419642c 100644 (file)
@@ -75,7 +75,7 @@
        &board_963269bhr,
        &board_vw6339gu,
  #endif
-@@ -2236,6 +2297,7 @@ static struct of_device_id const bcm963x
+@@ -2237,6 +2298,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 56a620d51cd6e66a032c2fcc23c2614d3eded96b..803ccc9c3d31425cd0024bb5ae601a5915b16f05 100644 (file)
@@ -84,7 +84,7 @@
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -2295,6 +2357,7 @@ static struct of_device_id const bcm963x
+@@ -2296,6 +2358,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 67f7bae67473bbe42f15628142a5581a0e7a1960..8660a6dfcbed457f16328576d386bbd34a0dedb7 100644 (file)
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2357,6 +2412,7 @@ static struct of_device_id const bcm963x
+@@ -2358,6 +2413,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 5745e7b4f3db944d854c06828e4295861551124a..e63b5e22203e1c382847993231a66385344348c6 100644 (file)
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2413,6 +2468,7 @@ static struct of_device_id const bcm963x
+@@ -2414,6 +2469,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index ba9595019f57d6e3c523f5d202efd146dca77a10..8078200a9d2c40ed6f80ebca007fe3c2929fd3fb 100644 (file)
@@ -58,7 +58,7 @@
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -2470,6 +2514,7 @@ static struct of_device_id const bcm963x
+@@ -2471,6 +2515,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 2d135b444935b3eace83205277afcd8fc5b97bf6..19d5807b33f3c43920d694abebc8cdb42fe58da0 100644 (file)
@@ -46,7 +46,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -2491,6 +2523,7 @@ static struct of_device_id const bcm963x
+@@ -2492,6 +2524,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
index 5ae9ec5f42baed4f17f7cee669bfed612e6994e1..c9463f00973da9db90288d0ed222fe9a5cc79d3f 100644 (file)
@@ -57,7 +57,7 @@
        &board_P870HW51A_V2,
        &board_VR3025u,
        &board_VR3025un,
-@@ -2729,6 +2772,7 @@ static struct of_device_id const bcm963x
+@@ -2730,6 +2773,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 676f704996cbe4ce81eecb0d457460c4cd8a7ba0..c0b14572c1dea7d4590bfb7b634f0f08b930623c 100644 (file)
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
+@@ -1443,6 +1463,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
+       { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
+       { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
++      { .compatible = "netgear,dg834g-v4", .data = &board_96348W3, },
+       { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
+       { .compatible = "t-com,spw500v", .data = &board_spw500v, },
+       { .compatible = "tecom,gw6000", .data = &board_gw6000, },
index 6b296ee47998231b3f47e7bb55bd78d41ddce333..11e4ff4be56ccbfc9d3ebbb9d974e647f68370b0 100644 (file)
@@ -40,7 +40,7 @@
        &board_HW553,
        &board_spw303v,
  #endif
-@@ -1474,6 +1500,7 @@ static struct of_device_id const bcm963x
+@@ -1475,6 +1501,7 @@ static struct of_device_id const bcm963x
        { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
index d1c703c9d1e9dacb5525290b1b1b98c3f891b5b7..4ac9d2db5cca8e9826d4fe725e02a30b0bf8c8a9 100644 (file)
@@ -45,7 +45,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -1503,6 +1534,7 @@ static struct of_device_id const bcm963x
+@@ -1504,6 +1535,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
index 7788622fc002279cef4a22435556fd0580fc0095..68c1dc36969da30e598b77fa9dae82969808e07d 100644 (file)
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
-@@ -1545,6 +1617,9 @@ static struct of_device_id const bcm963x
+@@ -1546,6 +1618,9 @@ static struct of_device_id const bcm963x
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
index ae81e3124686fdae54d997933580cfcf72ccf483..11a4f6aaf8c8d553d4c3c8e0709ee2a05dd2ab1c 100644 (file)
@@ -32,9 +32,9 @@
        &board_DV201AMR,
        &board_96348gw_a,
        &board_rta1025w_16,
-@@ -1593,6 +1611,7 @@ static struct of_device_id const bcm963x
-       { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
+@@ -1594,6 +1612,7 @@ static struct of_device_id const bcm963x
        { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
+       { .compatible = "netgear,dg834g-v4", .data = &board_96348W3, },
        { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
 +      { .compatible = "sagem,f@st2604", .data = &board_FAST2604, },
        { .compatible = "t-com,spw500v", .data = &board_spw500v, },
index 7ea7297bb6c829ab6198969de085f4b87516e70c..280ac79f67e76862d8843b938ae2c1d4d464bafa 100644 (file)
        &board_spw303v,
        &board_DVAG3810BN,
  #endif
-@@ -1855,6 +1946,9 @@ static struct of_device_id const bcm963x
+@@ -1856,6 +1947,9 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
index 7c877527ba45478c1a119c4b15cec82a3e54398c..c83e5b7ae0dfb7c13a2afeab1297aa597eb4aa84 100644 (file)
@@ -58,7 +58,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -2054,6 +2092,7 @@ static struct of_device_id const bcm963x
+@@ -2055,6 +2093,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6362
index 986f85b3fd8f3e74aef3e3bf8cf435b7eec054a8..ca7ed5519c38dfb9f92f80b05fc04a113419642c 100644 (file)
@@ -75,7 +75,7 @@
        &board_963269bhr,
        &board_vw6339gu,
  #endif
-@@ -2236,6 +2297,7 @@ static struct of_device_id const bcm963x
+@@ -2237,6 +2298,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 56a620d51cd6e66a032c2fcc23c2614d3eded96b..803ccc9c3d31425cd0024bb5ae601a5915b16f05 100644 (file)
@@ -84,7 +84,7 @@
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -2295,6 +2357,7 @@ static struct of_device_id const bcm963x
+@@ -2296,6 +2358,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 67f7bae67473bbe42f15628142a5581a0e7a1960..8660a6dfcbed457f16328576d386bbd34a0dedb7 100644 (file)
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2357,6 +2412,7 @@ static struct of_device_id const bcm963x
+@@ -2358,6 +2413,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 5745e7b4f3db944d854c06828e4295861551124a..e63b5e22203e1c382847993231a66385344348c6 100644 (file)
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2413,6 +2468,7 @@ static struct of_device_id const bcm963x
+@@ -2414,6 +2469,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index ba9595019f57d6e3c523f5d202efd146dca77a10..8078200a9d2c40ed6f80ebca007fe3c2929fd3fb 100644 (file)
@@ -58,7 +58,7 @@
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -2470,6 +2514,7 @@ static struct of_device_id const bcm963x
+@@ -2471,6 +2515,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 2d135b444935b3eace83205277afcd8fc5b97bf6..19d5807b33f3c43920d694abebc8cdb42fe58da0 100644 (file)
@@ -46,7 +46,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -2491,6 +2523,7 @@ static struct of_device_id const bcm963x
+@@ -2492,6 +2524,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
index 5ae9ec5f42baed4f17f7cee669bfed612e6994e1..c9463f00973da9db90288d0ed222fe9a5cc79d3f 100644 (file)
@@ -57,7 +57,7 @@
        &board_P870HW51A_V2,
        &board_VR3025u,
        &board_VR3025un,
-@@ -2729,6 +2772,7 @@ static struct of_device_id const bcm963x
+@@ -2730,6 +2773,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 429d0be9fe91124bca22e5744997a7f5cd560b70..ba304eac7e4c5fe619cb804ab47bab40d81e6a73 100644 (file)
@@ -41,7 +41,7 @@
        &board_HW520,
        &board_HW553,
        &board_HW556_A,
-@@ -2761,6 +2788,7 @@ static struct of_device_id const bcm963x
+@@ -2762,6 +2789,7 @@ static struct of_device_id const bcm963x
        { .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
index 20224a259a4be1a72925b450233e7bcbee0aed7b..bc345bb347e35fd3e1f60d6795c95ad5e40fa770 100644 (file)
@@ -23,6 +23,15 @@ define Profile/DG834GTPN/Description
 endef
 $(eval $(call Profile,DG834GTPN))
 
+define Profile/DG834GV4
+  NAME:=Netgear DG834G v4
+  PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/DG834GTPN/Description
+  Package set optimized for DG834G v4.
+endef
+$(eval $(call Profile,DG834GV4))
+
 define Profile/DGND3700v1_3800B
   NAME:=Netgear DGND3700 v1 / DGND3800B
   PACKAGES:=kmod-b43 wpad-mini \