uboot-sunxi: bump to 2020.01
authorPetr Štetiar <ynezz@true.cz>
Mon, 16 Mar 2020 13:47:07 +0000 (14:47 +0100)
committerPetr Štetiar <ynezz@true.cz>
Sat, 28 Mar 2020 12:03:02 +0000 (13:03 +0100)
Refreshed patches, removed following, probably obsolete patches:

 221-compatible-old-dtc.patch
 240-sun50i-h5-Orange-Pi-Zero-Plus-Fix-SdCard-detection.patch

Signed-off-by: Petr Štetiar <ynezz@true.cz>
13 files changed:
package/boot/uboot-sunxi/Makefile
package/boot/uboot-sunxi/patches/003-add-theobroma-a31-pangolin.patch
package/boot/uboot-sunxi/patches/062-A20-improve-gmac-upload.patch
package/boot/uboot-sunxi/patches/063-fix-lime2-revK-add-micrel-PHY.patch
package/boot/uboot-sunxi/patches/091-sun6i-sync-PLL1-multdiv-with-Boot1.patch
package/boot/uboot-sunxi/patches/100-sun6i-alternate-on-UART2.patch
package/boot/uboot-sunxi/patches/101-sun6i-support-console-on-UART2.patch
package/boot/uboot-sunxi/patches/102-sunxi-make_CONS_INDEX-configurable.patch
package/boot/uboot-sunxi/patches/200-mkimage-check-environment-for-dtc-binary-location.patch
package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch
package/boot/uboot-sunxi/patches/221-compatible-old-dtc.patch [deleted file]
package/boot/uboot-sunxi/patches/230-disable-axp209-on-a13-olinuxino.diff
package/boot/uboot-sunxi/patches/240-sun50i-h5-Orange-Pi-Zero-Plus-Fix-SdCard-detection.patch [deleted file]

index eef4c56f532124e7add87b86e17f4cde1aba9628..69d5d9269b2dd0939e238ff25c0e0b1224e1dec7 100644 (file)
@@ -9,9 +9,9 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-PKG_VERSION:=2019.01
+PKG_VERSION:=2020.01
 
-PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
+PKG_HASH:=aa453c603208b1b27bd03525775a7f79b443adec577fdc6e8f06974025a135f1
 
 PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
index 899bcb12994c2466c587e34a0e46ae93d68f96e5..518f882d209529ba9377325f5e5342a2f51ab778 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -313,6 +313,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
+@@ -446,6 +446,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
        sun6i-a31-m9.dtb \
        sun6i-a31-mele-a1000g-quad.dtb \
        sun6i-a31-mixtile-loftq.dtb \
 +CONFIG_SUNXI_SPI=y
 --- a/arch/arm/mach-sunxi/Kconfig
 +++ b/arch/arm/mach-sunxi/Kconfig
-@@ -875,6 +875,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
+@@ -895,6 +895,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
        Set the SCL pin for the LCD i2c interface. This takes a string in the
        format understood by sunxi_name_to_gpio, e.g. PH1 for pin 1 of port H.
  
index a1caf18a184a54d22ce5ad4567bf94ae8f77417c..13a703f307d21500dcc9e69ac4314062b2174f5c 100644 (file)
@@ -2,7 +2,7 @@
 
 --- a/configs/A20-OLinuXino-Lime2_defconfig
 +++ b/configs/A20-OLinuXino-Lime2_defconfig
-@@ -25,6 +25,7 @@ CONFIG_ETH_DESIGNWARE=y
+@@ -26,6 +26,7 @@ CONFIG_ETH_DESIGNWARE=y
  CONFIG_RGMII=y
  CONFIG_MII=y
  CONFIG_SUN7I_GMAC=y
index 9ea0642537b7dfe3fb1827aad0bd45481d23739f..d5536345564f69664fb66cfc3f916b3c346e65e6 100644 (file)
@@ -1,17 +1,17 @@
 --- a/configs/A20-OLinuXino-Lime2-eMMC_defconfig
 +++ b/configs/A20-OLinuXino-Lime2-eMMC_defconfig
-@@ -8,6 +8,8 @@ CONFIG_MMC_SUNXI_SLOT_EXTRA=2
+@@ -9,6 +9,8 @@ CONFIG_MMC_SUNXI_SLOT_EXTRA=2
  CONFIG_USB0_VBUS_PIN="PC17"
  CONFIG_USB0_VBUS_DET="PH5"
  CONFIG_I2C1_ENABLE=y
 +CONFIG_PHY_MICREL=y
 +CONFIG_PHY_MICREL_KSZ90X1=y
  CONFIG_SATAPWR="PC3"
+ CONFIG_SPL_SPI_SUNXI=y
  CONFIG_AHCI=y
- CONFIG_NR_DRAM_BANKS=1
 --- a/configs/A20-OLinuXino-Lime2_defconfig
 +++ b/configs/A20-OLinuXino-Lime2_defconfig
-@@ -7,6 +7,8 @@ CONFIG_MMC0_CD_PIN="PH1"
+@@ -8,6 +8,8 @@ CONFIG_MMC0_CD_PIN="PH1"
  CONFIG_USB0_VBUS_PIN="PC17"
  CONFIG_USB0_VBUS_DET="PH5"
  CONFIG_I2C1_ENABLE=y
 +CONFIG_PHY_MICREL_KSZ90X1=y
  CONFIG_SATAPWR="PC3"
  CONFIG_AHCI=y
- CONFIG_NR_DRAM_BANKS=1
+ # CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
 --- a/drivers/net/phy/micrel_ksz90x1.c
 +++ b/drivers/net/phy/micrel_ksz90x1.c
-@@ -13,6 +13,8 @@
+@@ -14,6 +14,8 @@
  #include <errno.h>
  #include <micrel.h>
  #include <phy.h>
@@ -31,7 +31,7 @@
  
  /*
   * KSZ9021 - KSZ9031 common
-@@ -329,6 +331,10 @@ static int ksz9031_phy_extwrite(struct p
+@@ -344,6 +346,10 @@ static int ksz9031_phy_extwrite(struct p
  static int ksz9031_config(struct phy_device *phydev)
  {
        int ret;
index bcf2faa186dd169f04924e49d8c2bcd278abc4a8..f2a2b5e48fc94bc41f5aa7cc8fa68d2a741fcdf4 100644 (file)
@@ -28,5 +28,5 @@ More specifically, the following settings are now used:
 +              k = 4;
 +              m = 2;
        } else if (clk > 768000000) {
-               k = 3;
+               k = 4;
                m = 2;
index 8bab220518852d78e80930ef3245ebe60205071a..a7afa51304192d575a6d6c7598e9e90855d3770e 100644 (file)
@@ -6,7 +6,7 @@ Subject: sun6i: define alternate-function for UART2 on GPG
 
 --- a/arch/arm/include/asm/arch-sunxi/gpio.h
 +++ b/arch/arm/include/asm/arch-sunxi/gpio.h
-@@ -186,6 +186,7 @@ enum sunxi_gpio_number {
+@@ -190,6 +190,7 @@ enum sunxi_gpio_number {
  #define SUN6I_GPG_SDC1                2
  #define SUN8I_GPG_SDC1                2
  #define SUN6I_GPG_TWI3                2
index b9226908454924233a82591fcc102afce36b9b6a..823c1568090b7acd80102173af9c7b6ffb3465ac 100644 (file)
@@ -6,7 +6,7 @@ Subject: ARM: sun6i: Support console on UART2 (GPG6/GPG7)
 
 --- a/arch/arm/mach-sunxi/board.c
 +++ b/arch/arm/mach-sunxi/board.c
-@@ -127,6 +127,10 @@ static int gpio_init(void)
+@@ -129,6 +129,10 @@ static int gpio_init(void)
        sunxi_gpio_set_cfgpin(SUNXI_GPG(3), SUN5I_GPG_UART1);
        sunxi_gpio_set_cfgpin(SUNXI_GPG(4), SUN5I_GPG_UART1);
        sunxi_gpio_set_pull(SUNXI_GPG(4), SUNXI_GPIO_PULL_UP);
@@ -19,7 +19,7 @@ Subject: ARM: sun6i: Support console on UART2 (GPG6/GPG7)
        sunxi_gpio_set_cfgpin(SUNXI_GPB(1), SUN8I_GPB_UART2);
 --- a/include/configs/sunxi-common.h
 +++ b/include/configs/sunxi-common.h
-@@ -258,6 +258,8 @@ extern int soft_i2c_gpio_scl;
+@@ -244,6 +244,8 @@ extern int soft_i2c_gpio_scl;
  #endif
  #elif CONFIG_CONS_INDEX == 2 && defined(CONFIG_MACH_SUN5I)
  #define OF_STDOUT_PATH                "/soc@01c00000/serial@01c28400:115200"
index 4e35d582fafd52df336993aacc79b85499d35559..b8c1253dcd700138b505d7039396517eb3c2c88e 100644 (file)
@@ -6,7 +6,7 @@ Subject: ARM: sunxi: Make CONS_INDEX configurable
 
 --- a/arch/arm/mach-sunxi/Kconfig
 +++ b/arch/arm/mach-sunxi/Kconfig
-@@ -538,6 +538,14 @@ config SYS_BOARD
+@@ -558,6 +558,14 @@ config SYS_BOARD
  config SYS_SOC
        default "sunxi"
  
index 12f47259c323eca969beacdeaa41635cabe55831..fe8eac78488dfd503ab7900ef8ed7c35b34e735c 100644 (file)
@@ -17,7 +17,7 @@ Cc: Simon Glass <sjg@chromium.org>
 
 --- a/tools/fit_image.c
 +++ b/tools/fit_image.c
-@@ -656,9 +656,14 @@ static int fit_handle_file(struct image_
+@@ -662,9 +662,14 @@ static int fit_handle_file(struct image_
                }
                *cmd = '\0';
        } else if (params->datafile) {
index d86097858aa89d557a202500d7670b12b20c3357..c6be8369154a9f833fcc1a4af47919be3f22ed0b 100644 (file)
@@ -12,7 +12,7 @@ old way of generating images.
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1344,8 +1344,10 @@ endif
+@@ -1525,8 +1525,10 @@ endif
  
  ifneq ($(CONFIG_ARCH_SUNXI),)
  ifeq ($(CONFIG_ARM64),)
@@ -27,7 +27,7 @@ old way of generating images.
        $(call if_changed,cat)
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -842,7 +842,6 @@ config ARCH_SOCFPGA
+@@ -945,7 +945,6 @@ config ARCH_SOCFPGA
  
  config ARCH_SUNXI
        bool "Support sunxi (Allwinner) SoCs"
diff --git a/package/boot/uboot-sunxi/patches/221-compatible-old-dtc.patch b/package/boot/uboot-sunxi/patches/221-compatible-old-dtc.patch
deleted file mode 100644 (file)
index 4056d98..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-Revert the commit c0e032e0090d65 ("scripts/dtc: Update to upstream 
-version v1.4.3")
-OpenWrt uses the dtc from the kernel also in u-boot, but when we compile 
-against kernel 4.9 we run into some errors because it is too old now. 
-Add the options only when they are supported to make it compatible with 
-dtc from kernel 4.9.
-
---- a/scripts/Kbuild.include
-+++ b/scripts/Kbuild.include
-@@ -173,6 +173,11 @@ ld-version = $(shell $(LD) --version | $
- # Usage:  $(call ld-ifversion, -ge, 22252, y)
- ld-ifversion = $(shell [ $(ld-version) $(1) $(2) ] && echo $(3) || echo $(4))
-+# dtc-option
-+# Usage:  DTC_FLAGS += $(call dtc-option,-Wno-unit_address_vs_reg)
-+dtc-option = $(call try-run,\
-+      echo '/dts-v1/; / {};' | $(DTC) $(1),$(1),$(2))
-+
- ######
- ###
---- a/scripts/Makefile.extrawarn
-+++ b/scripts/Makefile.extrawarn
-@@ -56,8 +56,8 @@ endif
- KBUILD_CFLAGS += $(warning)
--dtc-warning-2 += -Wnode_name_chars_strict
--dtc-warning-2 += -Wproperty_name_chars_strict
-+dtc-warning-2 += $(call dtc-option,-Wnode_name_chars_strict)
-+dtc-warning-2 += $(call dtc-option,-Wproperty_name_chars_strict)
- dtc-warning := $(dtc-warning-$(findstring 1, $(KBUILD_ENABLE_EXTRA_GCC_CHECKS)))
- dtc-warning += $(dtc-warning-$(findstring 2, $(KBUILD_ENABLE_EXTRA_GCC_CHECKS)))
-@@ -68,11 +68,11 @@ DTC_FLAGS += $(dtc-warning)
- else
- # Disable noisy checks by default
--DTC_FLAGS += -Wno-unit_address_vs_reg
--DTC_FLAGS += -Wno-simple_bus_reg
--DTC_FLAGS += -Wno-unit_address_format
--DTC_FLAGS += -Wno-pci_bridge
--DTC_FLAGS += -Wno-pci_device_bus_num
--DTC_FLAGS += -Wno-pci_device_reg
-+DTC_FLAGS += $(call dtc-option,-Wno-unit_address_vs_reg)
-+DTC_FLAGS += $(call dtc-option,-Wno-simple_bus_reg)
-+DTC_FLAGS += $(call dtc-option,-Wno-unit_address_format)
-+DTC_FLAGS += $(call dtc-option,-Wno-pci_bridge)
-+DTC_FLAGS += $(call dtc-option,-Wno-pci_device_bus_num)
-+DTC_FLAGS += $(call dtc-option,-Wno-pci_device_reg)
- endif
index 9ce6adeb352da73761005ce55dfe882d205f1b04..ce5ea8f01c0b7547b944d952b46773925ddddda6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configs/A13-OLinuXino_defconfig
 +++ b/configs/A13-OLinuXino_defconfig
-@@ -7,7 +7,6 @@ CONFIG_DRAM_EMR1=0
+@@ -8,7 +8,6 @@ CONFIG_DRAM_EMR1=0
  CONFIG_MMC0_CD_PIN="PG0"
  CONFIG_USB0_VBUS_DET="PG1"
  CONFIG_USB1_VBUS_PIN="PG11"
@@ -8,12 +8,12 @@
  # CONFIG_VIDEO_HDMI is not set
  CONFIG_VIDEO_VGA_VIA_LCD=y
  CONFIG_VIDEO_VGA_VIA_LCD_FORCE_SYNC_ACTIVE_HIGH=y
-@@ -24,7 +23,7 @@ CONFIG_CMD_USB_MASS_STORAGE=y
- CONFIG_DEFAULT_DEVICE_TREE="sun5i-a13-olinuxino"
+@@ -25,7 +24,7 @@ CONFIG_DEFAULT_DEVICE_TREE="sun5i-a13-ol
+ CONFIG_SYS_RELOC_GD_ENV_ADDR=y
  CONFIG_DFU_RAM=y
  CONFIG_FASTBOOT_CMD_OEM_FORMAT=y
 -CONFIG_AXP_ALDO3_VOLT=3300
 +CONFIG_SUNXI_NO_PMIC=y
  CONFIG_CONS_INDEX=2
  CONFIG_USB_EHCI_HCD=y
- CONFIG_USB_MUSB_GADGET=y
+ CONFIG_USB_OHCI_HCD=y
diff --git a/package/boot/uboot-sunxi/patches/240-sun50i-h5-Orange-Pi-Zero-Plus-Fix-SdCard-detection.patch b/package/boot/uboot-sunxi/patches/240-sun50i-h5-Orange-Pi-Zero-Plus-Fix-SdCard-detection.patch
deleted file mode 100644 (file)
index 2feab76..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From ad320d4d6ad03af5ff730546113d53a47ef6a22e Mon Sep 17 00:00:00 2001
-From: Hauke Mehrtens <hauke@hauke-m.de>
-Date: Sun, 13 Jan 2019 17:05:09 +0100
-Subject: [PATCH] sun50i: h5: Orange Pi Zero Plus: Fix SdCard detection
-
-The Detection pin is at PF6 and not at PH13 like defined before. I
-checked the schematics and now I am am not seeing this error message any
-more:
-Loading Environment from FAT... Card did not respond to voltage select!
-
-Fixes: 76d69eb01de ("sun50i: h5: Add initial Orange Pi Zero Plus support")
-Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
----
- configs/orangepi_zero_plus_defconfig | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
---- a/configs/orangepi_zero_plus_defconfig
-+++ b/configs/orangepi_zero_plus_defconfig
-@@ -4,8 +4,7 @@ CONFIG_SPL=y
- CONFIG_MACH_SUN50I_H5=y
- CONFIG_DRAM_CLK=624
- CONFIG_DRAM_ZQ=3881977
--CONFIG_MMC0_CD_PIN="PH13"
--CONFIG_MMC_SUNXI_SLOT_EXTRA=2
-+CONFIG_MMC0_CD_PIN="PF6"
- CONFIG_NR_DRAM_BANKS=1
- # CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
- # CONFIG_CMD_FLASH is not set