hostapd: add config symbol to enable MBO
authorStijn Tintel <stijn@linux-ipv6.be>
Mon, 20 Jun 2022 16:23:18 +0000 (19:23 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Tue, 28 Jun 2022 00:23:50 +0000 (03:23 +0300)
Multi Band Operation aka Agile Multiband introduces new Transition
and Transition Rejection Reason Codes that should improve client
steering. Add a config symbol to enable it, and enable it by default for
the full variants.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Acked-by: David Bauer <mail@david-bauer.net>
package/network/services/hostapd/Config.in
package/network/services/hostapd/Makefile

index 5c00f3e24ea375423d1d0f1887aaf3e7cfb134a0..e22bbff83a3c424b191ae83f54292031097c3dd2 100644 (file)
@@ -87,3 +87,17 @@ config WPA_ENABLE_WEP
          for anything anymore. The functionality needed to use WEP is available in the
          current hostapd release under this optional build parameter and completely
          removed in a future release.
+
+config WPA_MBO_SUPPORT
+       bool "Multi Band Operation (Agile Multiband)"
+       default PACKAGE_wpa-supplicant || \
+               PACKAGE_wpa-supplicant-openssl || \
+               PACKAGE_wpa-supplicant-wolfssl || \
+               PACKAGE_wpad || \
+               PACKAGE_wpad-openssl || \
+               PACKAGE_wpad-wolfssl
+       help
+         Multi Band Operation aka (Agile Multiband) enables features
+         that facilitate efficient use of multiple frequency bands.
+         Enabling MBO on an AP using RSN requires 802.11w to be enabled.
+         Hostapd will refuse to start if MBO and RSN are enabled without 11w.
index a3274c8d4d3a7d7a409a0b0a3bf6193d95c2626f..c69d2a826bed1bb10c891fb2fb5302902704b3b9 100644 (file)
@@ -91,6 +91,7 @@ DRIVER_MAKEOPTS= \
        CONFIG_IEEE80211AC=$(HOSTAPD_IEEE80211AC) \
        CONFIG_IEEE80211AX=$(HOSTAPD_IEEE80211AX) \
        CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
+       CONFIG_MBO=$(CONFIG_WPA_MBO_SUPPORT)
 
 ifeq ($(SSL_VARIANT),openssl)
   DRIVER_MAKEOPTS += CONFIG_TLS=openssl CONFIG_SAE=y