bcm53xx: Add support for D-Link DWL-8610AP
authorLinus Walleij <linus.walleij@linaro.org>
Fri, 16 Dec 2022 20:52:27 +0000 (21:52 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Feb 2023 21:22:48 +0000 (22:22 +0100)
The D-Link DWL-8610AP is a pretty straight-forward BC53016
device, D-Link has invented a firmware package format which
is a tar file, and we implement this for the factory image.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
target/linux/bcm53xx/image/Makefile

index ed2e9c6821203c2b480f1c44299c5aa969037024..1cb08effce25b588697a77fb52569362bbde5e79 100644 (file)
@@ -105,6 +105,22 @@ define Build/seama-nand
                -i $@.entity
 endef
 
+define Build/dwl8610ap-image
+       mkdir -p $@.tmptar
+       # The DWL8610AP pretends to be a Broadcom reference design
+       echo "bcm953012er" > $@.tmptar/board
+       echo "LVL7" > $@.tmptar/model
+       # Something high beyond what D-Link has put out
+       echo "5.0.0.0" > $@.tmptar/version
+       # Create rootfs.bin, this is just a NAND image including everything
+       cp $@ $@.tmptar/rootfs.bin
+       # Hash the rootfs.bin
+       cat $@.tmptar/rootfs.bin | md5sum > $@.tmptar/rootfs.md5
+       cd $@.tmptar && tar -c -f $@.new *
+       rm -rf $@.tmptar
+       mv $@.new $@
+endef
+
 DEVICE_VARS += ASUS_PRODUCTID
 DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
 DEVICE_VARS += SIGNATURE
@@ -250,6 +266,15 @@ define Device/dlink_dir-885l
 endef
 TARGET_DEVICES += dlink_dir-885l
 
+define Device/dlink_dwl-8610ap
+  DEVICE_VENDOR := D-Link
+  DEVICE_MODEL := DWL-8610AP
+  DEVICE_PACKAGES := $(B43)
+  IMAGES := factory.tar
+  IMAGE/factory.tar := append-ubi | trx-nand | dwl8610ap-image
+endef
+TARGET_DEVICES += dlink_dwl-8610ap
+
 define Device/linksys_ea6300-v1
   DEVICE_VENDOR := Linksys
   DEVICE_MODEL := EA6300