mediatek: bpi-r64: make initramfs/recovery optional
authorDaniel Golle <daniel@makrotopia.org>
Thu, 8 Sep 2022 01:44:30 +0000 (02:44 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 8 Sep 2022 01:51:11 +0000 (02:51 +0100)
Only include recovery image in SD card image generated for the
BananaPi BPi-R64 if building with CONFIG_TARGET_ROOTFS_INITRAMFS
This allows to build images larger than 32 MB (the limit for
initramfs/recovery image) by deselecting initramfs.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mediatek/image/mt7622.mk

index 810645067a22d03472f6ee75d189f325334994c2..d92c72294a597fc10956dd2014a62f72a32b6a04 100644 (file)
@@ -86,13 +86,18 @@ define Device/bananapi_bpi-r64
   ARTIFACT/sdcard.img.gz       := mt7622-gpt sdmmc |\
                                   pad-to 512k | bl2 sdmmc-2ddr |\
                                   pad-to 2048k | bl31-uboot bananapi_bpi-r64-sdmmc |\
-                                  pad-to 6144k | append-image-stage initramfs-recovery.itb |\
+                               $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),\
+                                  pad-to 6144k | append-image-stage initramfs-recovery.itb | checksize 38912k |\
+                               ) \
                                   pad-to 38912k | mt7622-gpt emmc |\
                                   pad-to 39424k | bl2 emmc-2ddr |\
                                   pad-to 40960k | bl31-uboot bananapi_bpi-r64-emmc |\
                                   pad-to 43008k | bl2 snand-2ddr |\
                                   pad-to 43520k | bl31-uboot bananapi_bpi-r64-snand |\
-                                  pad-to 46080k | append-image squashfs-sysupgrade.itb | gzip
+                               $(if $(CONFIG_TARGET_ROOTFS_SQUASHFS),\
+                                  pad-to 46080k | append-image squashfs-sysupgrade.itb | check-size | gzip \
+                               )
+  IMAGE_SIZE := $$(shell expr 45 + $$(CONFIG_TARGET_ROOTFS_PARTSIZE))m
   KERNEL                       := kernel-bin | gzip
   KERNEL_INITRAMFS             := kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb with-initrd | pad-to 128k
   IMAGE/sysupgrade.itb         := append-kernel | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb external-static-with-rootfs | append-metadata