openssl: passing cflags to configure
authorJitao Lu <dianlujitao@gmail.com>
Wed, 14 Jun 2023 09:25:03 +0000 (17:25 +0800)
committerJitao Lu <dianlujitao@gmail.com>
Wed, 14 Jun 2023 13:16:15 +0000 (21:16 +0800)
openssl sets additional cflags in its configuration script. We need to
make it aware of our custom cflags to avoid adding conflicting cflags.

Fixes: #12866
Signed-off-by: Jitao Lu <dianlujitao@gmail.com>
package/libs/openssl/Makefile

index a34a7849733c1d225ff07933bd859d8c412e9e52..0d09114f06e3073ba55d83d33eca1b114d52766b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 PKG_VERSION:=3.0.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_BUILD_FLAGS:=no-mips16 gc-sections
 
 PKG_BUILD_PARALLEL:=1
@@ -366,6 +366,7 @@ define Build/Configure
                        --libdir=lib \
                        --openssldir=/etc/ssl \
                        --cross-compile-prefix="$(TARGET_CROSS)" \
+                       $(TARGET_CFLAGS) \
                        $(TARGET_CPPFLAGS) \
                        $(TARGET_LDFLAGS) \
                        $(OPENSSL_OPTIONS) && \