ramips: add support for Xiaomi Mi Wi-Fi Router 3G v2
authorPaul Fertser <fercerpav@gmail.com>
Fri, 25 Oct 2019 10:18:43 +0000 (13:18 +0300)
committerJohn Crispin <john@phrozen.org>
Sun, 27 Oct 2019 11:25:56 +0000 (12:25 +0100)
- CMIIT ID: 2019AP2581
- SoC:      MediaTek MT7621
- Flash:    16MiB NOR SPI (GigaDevice GD25Q128B)
- RAM:      128MiB DDR3 (ESMT M15T1G1664A)
- Serial:   As marked on PCB, 3V3 logic, baudrate is 115200, 8n1
- Ethernet: 3x 10/100/1000 Mbps (switched, 2xLAN + WAN)
- WIFI0:    MT7603E 2.4GHz 802.11b/g/n
- WIFI1:    MT7612E 5GHz 802.11ac
- Antennas: 4x external (2 per radio), non-detachable
- LEDs:     Programmable "power" LED (two-coloured, yellow/blue)
            Non-programmable "internet" LED (shows WAN activity)
- Buttons:  Reset

INSTALLATION:

Bootloader won't accept any serial input unless "boot_wait" u-boot
environment variable is changed to "on". Vendor firmware (looks like
an illegal OpenWrt fork) won't accept any serial input unless
"uart_en" is set to "1". Tricks to force u-boot to use default
environment do not help as it's restricted in the same way.

With bootloader unlocked the easiest way would be to TFTP the
sysupgrade image or to sysupgrade after loading an initramfs one.

For porting the flash contents were changed externally with an SPI
programmer (after lifting Vcc flash IC pin away from the PCB).

Forum thread [0] indicates that this device is identical to "Xiaomi Mi
Router 4A Gigabit Edition".

[0] https://forum.openwrt.org/t/xiaomi-mi-router-4a-gigabit-edition-r4ag-r4a-gigabit-fully-supported-but-requires-overwriting-spi-flash-with-programmer/36685

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/dts/mt7621_xiaomi_mir3g-v2.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

index 3c73a63aaeae088cad1146531079092ea624b997..480726a870e1a155d6b8857a3ed4a3a619987169 100755 (executable)
@@ -297,7 +297,8 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "4:lan" "6@eth0"
                ;;
-       cudy,wr1000)
+       cudy,wr1000|\
+       xiaomi,mir3g-v2)
                ucidef_add_switch "switch0" \
                        "2:lan:2" "3:lan:1" "4:wan" "6@eth0"
                ;;
@@ -720,6 +721,10 @@ ramips_setup_macs()
        xiaomi,mir3g)
                lan_mac=$(mtd_get_mac_binary factory 0xe006)
                ;;
+       xiaomi,mir3g-v2)
+               wan_mac=$(mtd_get_mac_binary factory 0xe006)
+               label_mac=$wan_mac
+               ;;
        xiaomi,mir3p)
                lan_mac=$(mtd_get_mac_binary factory 0xe006)
                label_mac=$lan_mac
diff --git a/target/linux/ramips/dts/mt7621_xiaomi_mir3g-v2.dts b/target/linux/ramips/dts/mt7621_xiaomi_mir3g-v2.dts
new file mode 100644 (file)
index 0000000..58da88a
--- /dev/null
@@ -0,0 +1,147 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "xiaomi,mir3g-v2", "mediatek,mt7621-soc";
+       model = "Xiaomi Mi Router 3G v2";
+
+       aliases {
+               led-boot = &led_status_yellow;
+               led-failsafe = &led_status_yellow;
+               led-running = &led_status_blue;
+               led-upgrade = &led_status_yellow;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status_blue: status_blue {
+                       label = "mir3gv2:blue:status";
+                       gpios = <&gpio0 8 GPIO_ACTIVE_LOW>;
+               };
+
+               led_status_yellow: status_yellow {
+                       label = "mir3gv2:yellow:status";
+                       gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       button {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <80000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "Bdata";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@50000 {
+                               label = "factory";
+                               reg = <0x50000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "crash";
+                               reg = <0x60000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@70000 {
+                               label = "cfg_bak";
+                               reg = <0x70000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@80000 {
+                               label = "overlay";
+                               reg = <0x80000 0x100000>;
+                               read-only;
+                       };
+
+                       firmware: partition@180000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x180000 0xe80000>;
+                       };
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "pci14c3,7662";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "pci14c3,7603";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+               ieee80211-freq-limit = <2400000 2500000>;
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe000>;
+       mediatek,portmap = "lllwl";
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "jtag", "uart2", "uart3", "wdt";
+                       ralink,function = "gpio";
+               };
+       };
+};
index 60d0131dc6c475504d38f8e07285e46bc7c3407f..09d3b1d866b6bf3d6f0108e6287736e4bc14f04b 100644 (file)
@@ -763,6 +763,19 @@ define Device/xiaomi_mir3g
 endef
 TARGET_DEVICES += xiaomi_mir3g
 
+define Device/xiaomi_mir3g-v2
+  MTK_SOC := mt7621
+  IMAGE_SIZE := 14848k
+  DEVICE_VENDOR := Xiaomi
+  DEVICE_MODEL := Mi Router 3G
+  DEVICE_VARIANT := v2
+  DEVICE_ALT0_VENDOR := Xiaomi
+  DEVICE_ALT0_MODEL := Mi Router 4A
+  DEVICE_ALT0_VARIANT := Gigabit Edition
+  DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 wpad-basic
+endef
+TARGET_DEVICES += xiaomi_mir3g-v2
+
 define Device/xiaomi_mir3p
   MTK_SOC := mt7621
   BLOCKSIZE := 128k