fixes tapi dependencies
authorJohn Crispin <john@openwrt.org>
Mon, 6 Aug 2012 18:56:38 +0000 (18:56 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 6 Aug 2012 18:56:38 +0000 (18:56 +0000)
SVN-Revision: 33029

package/ltq-tapi/Makefile
package/ltq-tapidemo/Makefile
package/ltq-vmmc/Makefile
package/owsip/Makefile

index ecaac2eeb457044d291329652b2ba6c71b66d520..3027ec490a9b56bfae9f4c67fd3f6e41bf0f2041 100644 (file)
@@ -22,7 +22,7 @@ define KernelPackage/ltq-tapi
   SUBMENU:=Voice over IP
   TITLE:=Lantiq TAPI subsystem
   URL:=http://www.lantiq.com/
-  DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq
+  DEPENDS:=+kmod-ltq-ifxos @(TARGET_lantiq_danube||TARGET_lantiq_falcon)
   FILES:=$(PKG_BUILD_DIR)/src/drv_tapi.ko
   AUTOLOAD:=$(call AutoLoad,20,drv_tapi)
   MAINTAINER:=John Crispin <blogic@openwrt.org>
index 0fbcce0c596b212f886eba91d8dcae33698ae7d2..1c1d2b4356c214fddf393cccfe63ded6bb7354e4 100644 (file)
@@ -26,7 +26,7 @@ define Package/ltq-tapidemo
   CATEGORY:=Network
   TITLE:=TAPIdemo application for Lantiq boards
   URL:=http://www.lantiq.com/
-  DEPENDS:=+kmod-ltq-tapi +kmod-ltq-vmmc +libpthread
+  DEPENDS:=+kmod-ltq-tapi +kmod-ltq-vmmc +libpthread @(TARGET_lantiq_danube||TARGET_lantiq_falcon)
   MAINTAINER:=John Crispin <blogic@openwrt.org>
   MENU:=1
 endef
index a0af1e53041484d13d39dec5c0dcec7530260292..74724eb8befa4938ee2ce8623ee3245c618953dc 100644 (file)
@@ -22,7 +22,7 @@ define KernelPackage/ltq-vmmc
   SUBMENU:=Voice over IP
   TITLE:=TAPI LL driver for Voice Macro
   URL:=http://www.lantiq.com/
-  DEPENDS:=+kmod-ltq-tapi @(TARGET_lantiq_danube||TARGET_lantiq_falcon||TARGET_lantiq_falcon_stable)
+  DEPENDS:=+kmod-ltq-tapi @(TARGET_lantiq_danube||TARGET_lantiq_falcon)
   FILES:=$(PKG_BUILD_DIR)/src/drv_vmmc.ko
   AUTOLOAD:=$(call AutoLoad,25,drv_vmmc)
   MAINTAINER:=John Crispin <blogic@openwrt.org>
index d36036b9d80b84040e9e5a6419becd3befaf318c..37d5d8cee922ee5af70f41de594ff43b8c9a2ea6 100644 (file)
@@ -34,7 +34,7 @@ define Package/owsip-template
 endef
 
 Package/owsip-oss=$(call Package/owsip-template,oss,OSS,BROKEN)
-Package/owsip-ltq-tapi=$(call Package/owsip-template,ltq-tapi,Lantiq VMMC,@TARGET_lantiq +kmod-ltq-kpi2udp)
+Package/owsip-ltq-tapi=$(call Package/owsip-template,ltq-tapi,Lantiq VMMC,@(TARGET_lantiq_danube||TARGET_lantiq_falcon) +kmod-ltq-kpi2udp)
 
 define Package/owsip-$(BUILD_VARIANT)/description
        OpenWrt sip daemon - $(BUILD_VARIANT)