kernel: update 3.10 to 3.10.12
authorGabor Juhos <juhosg@openwrt.org>
Sun, 15 Sep 2013 16:00:41 +0000 (16:00 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 15 Sep 2013 16:00:41 +0000 (16:00 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38000

39 files changed:
include/kernel-version.mk
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.10/404-mtd-wrt160nl-trx-parser.patch
target/linux/ar71xx/patches-3.10/405-mtd-tp-link-partition-parser.patch
target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/brcm2708/patches-3.10/002-Main-bcm2708-linux-port.patch
target/linux/brcm47xx/Makefile
target/linux/brcm47xx/patches-3.10/790-tg3-phylib.patch
target/linux/brcm63xx/Makefile
target/linux/brcm63xx/patches-3.10/202-MTD-DEVICES-m25p80-use-parsers-if-provided-in-flash-.patch
target/linux/brcm63xx/patches-3.10/203-MTD-DEVICES-m25p80-add-support-for-limiting-reads.patch
target/linux/brcm63xx/patches-3.10/414-MTD-m25p80-allow-passing-pp_data.patch
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.10/030-timer_list_fix.patch [deleted file]
target/linux/generic/patches-3.10/259-regmap_dynamic.patch
target/linux/generic/patches-3.10/411-mtd-partial_eraseblock_write.patch
target/linux/generic/patches-3.10/412-mtd-partial_eraseblock_unlock.patch
target/linux/generic/patches-3.10/430-mtd-add-myloader-partition-parser.patch
target/linux/generic/patches-3.10/620-sched_esfq.patch
target/linux/generic/patches-3.10/630-packet_socket_type.patch
target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/generic/patches-3.10/902-debloat_proc.patch
target/linux/imx23/Makefile
target/linux/imx6/Makefile
target/linux/imx6/patches-3.10/200-imx6_pcie.patch
target/linux/ixp4xx/Makefile
target/linux/malta/Makefile
target/linux/mpc85xx/Makefile
target/linux/octeon/Makefile
target/linux/ppc40x/Makefile
target/linux/ramips/Makefile
target/linux/ramips/patches-3.10/0001-MTD-m25p80-allow-loading-mtd-name-from-OF.patch
target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch
target/linux/realview/Makefile
target/linux/x86/alix2/target.mk
target/linux/xburst/Makefile

index b662f62bb5379342cf715fab135561c86c7b4fb6..52bb309ecfbd2d218d7f62555cba42013dafa6e8 100644 (file)
@@ -17,8 +17,8 @@ endif
 ifeq ($(LINUX_VERSION),3.9.11)
   LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
 endif
-ifeq ($(LINUX_VERSION),3.10.10)
-  LINUX_KERNEL_MD5SUM:=647f76225dd6bc112369ba573ba3de18
+ifeq ($(LINUX_VERSION),3.10.12)
+  LINUX_KERNEL_MD5SUM:=16e43b3c9957cf5af44863d6809efe38
 endif
 
 # disable the md5sum check for unknown kernel versions
index 20464f81a2caed0baeafd0e04c35e8a65c530915..ba63ded1ded8f83682c78b0d644bc0e4c9c2003e 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs targz mips16
 CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 6584c19e70ffe78616cd0c1e18e058431218bd7f..e55018ba7f4a014df22e0fed89fc3500e02f6c1c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/Kconfig
 +++ b/drivers/mtd/Kconfig
-@@ -172,6 +172,12 @@ config MTD_BCM47XX_PARTS
+@@ -176,6 +176,12 @@ config MTD_BCM47XX_PARTS
          This provides partitions parser for devices based on BCM47xx
          boards.
  
index 96fe34203c82706733a46689266face30d86bb61..f0d26b74347a23ee949f3504b3fef2bf440c6891 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/Kconfig
 +++ b/drivers/mtd/Kconfig
-@@ -174,7 +174,7 @@ config MTD_BCM47XX_PARTS
+@@ -178,7 +178,7 @@ config MTD_BCM47XX_PARTS
  
  config MTD_WRT160NL_PARTS
        tristate "Linksys WRT160NL partitioning support"
@@ -9,7 +9,7 @@
        ---help---
           Linksys WRT160NL partitioning support
  
-@@ -194,6 +194,12 @@ config MTD_MYLOADER_PARTS
+@@ -198,6 +198,12 @@ config MTD_MYLOADER_PARTS
          You will still need the parsing functions to be called by the driver
          for your particular device. It won't happen automatically.
  
index 2e07b14ca13989727919add4dabed26b25d26b8b..fa4ff47d3c9fab2795151e5a15946ba03d42546a 100644 (file)
                tpi->seq = 0;
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3592,13 +3592,14 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3592,14 +3592,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
 -              tp->rx_opt.rcv_tsval = ntohl(*ptr);
 +              tp->rx_opt.rcv_tsval = get_unaligned_be32(ptr);
                ++ptr;
--              tp->rx_opt.rcv_tsecr = ntohl(*ptr) - tp->tsoffset;
-+              tp->rx_opt.rcv_tsecr = get_unaligned_be32(ptr) - tp->tsoffset;
+               if (*ptr)
+-                      tp->rx_opt.rcv_tsecr = ntohl(*ptr) - tp->tsoffset;
++                      tp->rx_opt.rcv_tsecr = get_unaligned_be32(ptr) -
++                                             tp->tsoffset;
+               else
+                       tp->rx_opt.rcv_tsecr = 0;
                return true;
-       }
-       return false;
 --- a/include/uapi/linux/if_pppox.h
 +++ b/include/uapi/linux/if_pppox.h
 @@ -47,6 +47,7 @@ struct pppoe_addr {
index 31e745c252c1fd2a9864e40b23d56f6756a4e92e..591cc99fde0eab60dee926fa17f3a9e96214e296 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
 FEATURES:=squashfs usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 0a262488a18c7c093a08d368875d3f676efaf420..ad0d1fb806ee47c326544e924d73f26794580779 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Broadcom BCM2708/BCM2835
 FEATURES:=ext4 audio usb usbgadget display gpio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
index 9800298aa0d7b361c7303e7d4f4b67dc8ce91c72..baab5fbde5ceb7fae9d86ea733a6b3db7e483a17 100644 (file)
 +ENDPROC(__FIQ_Branch)
 --- a/arch/arm/kernel/fiq.c
 +++ b/arch/arm/kernel/fiq.c
-@@ -145,6 +145,7 @@ void disable_fiq(int fiq)
+@@ -141,6 +141,7 @@ void disable_fiq(int fiq)
  EXPORT_SYMBOL(set_fiq_handler);
  EXPORT_SYMBOL(__set_fiq_regs);        /* defined in fiqasm.S */
  EXPORT_SYMBOL(__get_fiq_regs);        /* defined in fiqasm.S */
index 7719ae82f899c21a4a9725eb38b98d1cd6343618..535e7033ca26c2f55ec9db02df3f6591f7bede58 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += swconfig kmod-diag wpad-mini nvram
index 4a7b116745a279d83d77f60b0a8c674b1f4d60df..19ab8fef2fcc0a5c540add882bea83289cf9e343 100644 (file)
                tp->phy_flags &= ~TG3_PHYFLG_IS_CONNECTED;
        }
  }
-@@ -3985,7 +3992,7 @@ static int tg3_power_down_prepare(struct
+@@ -3999,7 +4006,7 @@ static int tg3_power_down_prepare(struct
                        struct phy_device *phydev;
                        u32 phyid, advertising;
  
  
                        tp->phy_flags |= TG3_PHYFLG_IS_LOW_POWER;
  
-@@ -11769,7 +11776,7 @@ static int tg3_get_settings(struct net_d
+@@ -11783,7 +11790,7 @@ static int tg3_get_settings(struct net_d
                struct phy_device *phydev;
                if (!(tp->phy_flags & TG3_PHYFLG_IS_CONNECTED))
                        return -EAGAIN;
                return phy_ethtool_gset(phydev, cmd);
        }
  
-@@ -11836,7 +11843,7 @@ static int tg3_set_settings(struct net_d
+@@ -11850,7 +11857,7 @@ static int tg3_set_settings(struct net_d
                struct phy_device *phydev;
                if (!(tp->phy_flags & TG3_PHYFLG_IS_CONNECTED))
                        return -EAGAIN;
                return phy_ethtool_sset(phydev, cmd);
        }
  
-@@ -11993,7 +12000,7 @@ static int tg3_nway_reset(struct net_dev
+@@ -12007,7 +12014,7 @@ static int tg3_nway_reset(struct net_dev
        if (tg3_flag(tp, USE_PHYLIB)) {
                if (!(tp->phy_flags & TG3_PHYFLG_IS_CONNECTED))
                        return -EAGAIN;
        } else {
                u32 bmcr;
  
-@@ -12109,7 +12116,7 @@ static int tg3_set_pauseparam(struct net
+@@ -12123,7 +12130,7 @@ static int tg3_set_pauseparam(struct net
                u32 newadv;
                struct phy_device *phydev;
  
  
                if (!(phydev->supported & SUPPORTED_Pause) ||
                    (!(phydev->supported & SUPPORTED_Asym_Pause) &&
-@@ -13543,7 +13550,7 @@ static int tg3_ioctl(struct net_device *
+@@ -13557,7 +13564,7 @@ static int tg3_ioctl(struct net_device *
                struct phy_device *phydev;
                if (!(tp->phy_flags & TG3_PHYFLG_IS_CONNECTED))
                        return -EAGAIN;
                return phy_mii_ioctl(phydev, ifr, cmd);
        }
  
-@@ -17176,8 +17183,10 @@ static int tg3_init_one(struct pci_dev *
+@@ -17190,8 +17197,10 @@ static int tg3_init_one(struct pci_dev *
                        tg3_flag_set(tp, FLUSH_POSTED_WRITES);
                if (ssb_gige_one_dma_at_once(pdev))
                        tg3_flag_set(tp, ONE_DMA_AT_ONCE);
                if (ssb_gige_is_rgmii(pdev))
                        tg3_flag_set(tp, RGMII_MODE);
        }
-@@ -17447,7 +17456,7 @@ static int tg3_init_one(struct pci_dev *
+@@ -17461,7 +17470,7 @@ static int tg3_init_one(struct pci_dev *
  
        if (tp->phy_flags & TG3_PHYFLG_IS_CONNECTED) {
                struct phy_device *phydev;
index 6fce7fdc4c36f062d9bab0ee0644a1944599995f..1fcbc8174fbb0616eb6700aee150032f05cde506 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index b5df076dbc09b86de54ed0eb4909ee91d2e04984..04b5f2f4a0b3c1bda0f548eb5d91211721c05cf4 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
 
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -1088,7 +1088,8 @@ static int m25p_probe(struct spi_device
+@@ -1091,7 +1091,8 @@ static int m25p_probe(struct spi_device
        /* partitions should match sector boundaries; and it may be good to
         * use readonly partitions for writeprotected sectors (BP2..BP0).
         */
index 7ac1b2fb10b0abd3a156c12277a74c476619bd59..0e4ca9daa6115d8aa0f2eb05974554dd37dfe0b6 100644 (file)
@@ -60,7 +60,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  /*
   * Write an address range to the flash chip.  Data must be written in
   * FLASH_PAGESIZE chunks.  The address range may be any size provided
-@@ -983,6 +1005,9 @@ static int m25p_probe(struct spi_device
+@@ -986,6 +1008,9 @@ static int m25p_probe(struct spi_device
                return -ENOMEM;
        }
  
index 6818a4d9cc44c27e08011a3b5f9cefb393737c0c..ca0ee6fc850ba5397026d1aaf3545d2dfd041b7b 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH 64/79] MTD: m25p80: allow passing pp_data
 
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -972,6 +972,9 @@ static int m25p_probe(struct spi_device
+@@ -975,6 +975,9 @@ static int m25p_probe(struct spi_device
                        dev_warn(&spi->dev, "unrecognized id %s\n", data->type);
        }
  
index ed64d9f090a2fd06a49dd207515f75d6f22a9054..3ecc4762755d1b017195ef2b561f1611594509e4 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/generic/patches-3.10/030-timer_list_fix.patch b/target/linux/generic/patches-3.10/030-timer_list_fix.patch
deleted file mode 100644 (file)
index ef3c798..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-Patch by: Nathan Zimmer <nzimmer@sgi.com>
-
-Fixes a regression in the commit
-"timer_list: Convert timer list to be a proper seq_file" which causes
-/proc/timer_list to return an infinite amount of data
-
-
---- a/kernel/time/timer_list.c
-+++ b/kernel/time/timer_list.c
-@@ -305,24 +305,26 @@ static void *timer_list_start(struct seq
-       if (!*offset) {
-               iter->cpu = -1;
-               iter->now = ktime_to_ns(ktime_get());
--      } else if (iter->cpu >= nr_cpu_ids) {
-+      } else {
-+              iter->cpu = cpumask_next(iter->cpu, cpu_online_mask);
-+              if (iter->cpu >= nr_cpu_ids) {
- #ifdef CONFIG_GENERIC_CLOCKEVENTS
--              if (!iter->second_pass) {
--                      iter->cpu = -1;
--                      iter->second_pass = true;
--              } else
--                      return NULL;
-+                      if (!iter->second_pass) {
-+                              iter->cpu = -1;
-+                              iter->second_pass = true;
-+                      } else
-+                              return NULL;
- #else
--              return NULL;
-+                      return NULL;
- #endif
-+              }
-       }
-+
-       return iter;
- }
- static void *timer_list_next(struct seq_file *file, void *v, loff_t *offset)
- {
--      struct timer_list_iter *iter = file->private;
--      iter->cpu = cpumask_next(iter->cpu, cpu_online_mask);
-       ++*offset;
-       return timer_list_start(file, offset);
- }
index 5282b076c1f3b3aa46ca25004e4942c9e3f04c74..8627bcc3c5090dbd453231f8e87b077f7fdfb7d2 100644 (file)
@@ -31,7 +31,7 @@
        bool
 --- a/include/linux/regmap.h
 +++ b/include/linux/regmap.h
-@@ -46,7 +46,7 @@ struct reg_default {
+@@ -47,7 +47,7 @@ struct reg_default {
        unsigned int def;
  };
  
index fbc2d5f0e1f234d44553615f734400f3107f81ff..07db13706197fb5bc8f68009d05f4a8087721ccd 100644 (file)
@@ -9,7 +9,7 @@
  /* Our partition linked list */
  static LIST_HEAD(mtd_partitions);
  static DEFINE_MUTEX(mtd_partitions_mutex);
-@@ -232,13 +234,60 @@ static int part_erase(struct mtd_info *m
+@@ -231,13 +233,60 @@ static int part_erase(struct mtd_info *m
        struct mtd_part *part = PART(mtd);
        int ret;
  
@@ -70,7 +70,7 @@
        return ret;
  }
  
-@@ -246,7 +295,25 @@ void mtd_erase_callback(struct erase_inf
+@@ -245,7 +294,25 @@ void mtd_erase_callback(struct erase_inf
  {
        if (instr->mtd->_erase == part_erase) {
                struct mtd_part *part = PART(instr->mtd);
@@ -96,7 +96,7 @@
                if (instr->fail_addr != MTD_FAIL_ADDR_UNKNOWN)
                        instr->fail_addr -= part->offset;
                instr->addr -= part->offset;
-@@ -506,18 +573,24 @@ static struct mtd_part *allocate_partiti
+@@ -505,18 +572,24 @@ static struct mtd_part *allocate_partiti
        if ((slave->mtd.flags & MTD_WRITEABLE) &&
            mtd_mod_by_eb(slave->offset, &slave->mtd)) {
                /* Doesn't start on a boundary of major erase size */
index 87c8257fe115d55ae72c1476d01f9288591ecc59..134f65715e95bd320a449d3fcfb99a11d7b391b5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -332,7 +332,14 @@ static int part_lock(struct mtd_info *mt
+@@ -331,7 +331,14 @@ static int part_lock(struct mtd_info *mt
  static int part_unlock(struct mtd_info *mtd, loff_t ofs, uint64_t len)
  {
        struct mtd_part *part = PART(mtd);
index 026ba2b41a9413da50cde6a136f7569bbf1b1a3d..4b61307c3774d2ed3777ccda07a15cb188b4de37 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/Kconfig
 +++ b/drivers/mtd/Kconfig
-@@ -172,6 +172,22 @@ config MTD_BCM47XX_PARTS
+@@ -176,6 +176,22 @@ config MTD_BCM47XX_PARTS
          This provides partitions parser for devices based on BCM47xx
          boards.
  
index e037dcf38b707d9517f57d4f260e5f2910035024..41969865bfe8495753b4a553995460bbc4ca5af9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/uapi/linux/pkt_sched.h
 +++ b/include/uapi/linux/pkt_sched.h
-@@ -214,6 +214,33 @@ struct tc_sfq_xstats {
+@@ -222,6 +222,33 @@ struct tc_sfq_xstats {
        __s32           allot;
  };
  
index e7f05def7fef3225ce44c0a7b4681d09e2131243..48a9bb912637206cc8ffd903eea9e527256f6f42 100644 (file)
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3275,6 +3288,13 @@ static int packet_getsockopt(struct sock
+@@ -3277,6 +3290,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index 5f88e6b8b6a1a0940903dcf2a85a94301641f128..010c6048afecf7f736dee9df127be75d19c7ecc9 100644 (file)
@@ -32,7 +32,7 @@
 +obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_stubs.o
 --- a/net/ipv6/addrconf.c
 +++ b/net/ipv6/addrconf.c
-@@ -1321,7 +1321,7 @@ out:
+@@ -1319,7 +1319,7 @@ out:
        return ret;
  }
  
@@ -41,7 +41,7 @@
                       const struct in6_addr *daddr, unsigned int prefs,
                       struct in6_addr *saddr)
  {
-@@ -1446,7 +1446,6 @@ try_nextdev:
+@@ -1444,7 +1444,6 @@ try_nextdev:
        in6_ifa_put(hiscore->ifa);
        return 0;
  }
@@ -49,7 +49,7 @@
  
  int __ipv6_get_lladdr(struct inet6_dev *idev, struct in6_addr *addr,
                      unsigned char banned_flags)
-@@ -5145,6 +5144,9 @@ int __init addrconf_init(void)
+@@ -5143,6 +5142,9 @@ int __init addrconf_init(void)
  
        ipv6_addr_label_rtnl_register();
  
@@ -59,7 +59,7 @@
        return 0;
  errout:
        rtnl_af_unregister(&inet6_ops);
-@@ -5163,6 +5165,9 @@ void addrconf_cleanup(void)
+@@ -5161,6 +5163,9 @@ void addrconf_cleanup(void)
        struct net_device *dev;
        int i;
  
index 0a933416720103807cefc2fa8b89aed3b3573136..556adcc935cf5054d3ba3d62ef5e084fbe3a56ae 100644 (file)
        __FR_ACT_MAX,
  };
  
---- a/include/uapi/linux/icmpv6.h
-+++ b/include/uapi/linux/icmpv6.h
-@@ -115,6 +115,7 @@ struct icmp6hdr {
- #define ICMPV6_NOT_NEIGHBOUR          2
- #define ICMPV6_ADDR_UNREACH           3
- #define ICMPV6_PORT_UNREACH           4
-+#define ICMPV6_FAILED_POLICY          5
- /*
-  *    Codes for Time Exceeded
 --- a/include/uapi/linux/rtnetlink.h
 +++ b/include/uapi/linux/rtnetlink.h
 @@ -203,6 +203,7 @@ enum {
@@ -69,7 +59,7 @@
  static void rt_fibinfo_free(struct rtable __rcu **rtp)
 --- a/net/ipv4/fib_trie.c
 +++ b/net/ipv4/fib_trie.c
-@@ -2334,6 +2334,7 @@ static const char *const rtn_type_names[
+@@ -2331,6 +2331,7 @@ static const char *const rtn_type_names[
        [RTN_THROW] = "THROW",
        [RTN_NAT] = "NAT",
        [RTN_XRESOLVE] = "XRESOLVE",
  
 +static int ip6_pkt_failed_policy(struct sk_buff *skb)
 +{
-+      return ip6_pkt_drop(skb, ICMPV6_FAILED_POLICY, IPSTATS_MIB_INNOROUTES);
++      return ip6_pkt_drop(skb, ICMPV6_POLICY_FAIL, IPSTATS_MIB_INNOROUTES);
 +}
 +
 +static int ip6_pkt_failed_policy_out(struct sk_buff *skb)
 +{
 +      skb->dev = skb_dst(skb)->dev;
-+      return ip6_pkt_drop(skb, ICMPV6_FAILED_POLICY, IPSTATS_MIB_OUTNOROUTES);
++      return ip6_pkt_drop(skb, ICMPV6_POLICY_FAIL, IPSTATS_MIB_OUTNOROUTES);
 +}
 +
  #endif
index 67ea753a1067e72b6fda2a0fdd43cf91585f3606..907e04624c5bfeaec1fb8c57897f2db5eca91bb2 100644 (file)
        if (!root_irq_dir)
 --- a/kernel/time/timer_list.c
 +++ b/kernel/time/timer_list.c
-@@ -357,6 +357,8 @@ static int __init init_timer_list_procfs
+@@ -362,6 +362,8 @@ static int __init init_timer_list_procfs
  {
        struct proc_dir_entry *pe;
  
  
 --- a/net/ipv4/fib_trie.c
 +++ b/net/ipv4/fib_trie.c
-@@ -2590,10 +2590,12 @@ static const struct file_operations fib_
+@@ -2587,10 +2587,12 @@ static const struct file_operations fib_
  
  int __net_init fib_proc_init(struct net *net)
  {
                         &fib_triestat_fops))
                goto out2;
  
-@@ -2603,17 +2605,21 @@ int __net_init fib_proc_init(struct net
+@@ -2600,17 +2602,21 @@ int __net_init fib_proc_init(struct net
        return 0;
  
  out3:
index def0a7ab77d8971a698cd880b6fe92e4193912f3..21c33f9cd398cf08b4937cb971a4b341a91c31e0 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale i.MX23 series
 FEATURES:=ext4 rtc usb gpio
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 KERNELNAME:="zImage dtbs"
 
 define Target/Description
index b26e4818c1b2640e5d7756e54c467704cc2dad9e..6eccacbaf7e79988cc9d520bf78e8aed5eeef999 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=audio display gpio pcie usb usbgadget squashfs targz
 CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 6aee13fb70b42b4ff750a488629c6fde1af94405..534ce9e9f87baf7dafea51c79a502718d09d1f2f 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/arm/boot/dts/imx6q.dtsi
 +++ b/arch/arm/boot/dts/imx6q.dtsi
-@@ -382,6 +382,15 @@
-                       };
+@@ -391,6 +391,15 @@
+                       status = "disabled";
                };
  
 +              pcie: pcie@01ffc000 {
index 6be0098625d7a8cc14f294c6f5d11aee44d2cf98..7bc839ac49cdb211c6d10c5ba7696464cf42c8f8 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
index bc1dfff818f54553a6f9f2a55cdd9c69a6608bc1..c05a30246fc93244dca51bc4a63d562fc3783f01 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 DEVICE_TYPE:=developerboard
 
index 93ba2c6143df7cc1ddd43e9cbaf12aa3c8f289f6..c8ae94daf0f4cb79a9808e4195f36ad858c07af1 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 0085d22689ea2f91524e9fd6486d445ee76298cd..12fcacb58554cf6d8329ce846e881b42945ac40c 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 pci usb
 CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 55ecbd0578d2866a5ad958877a106dff38768ef1..29982df1907bc05f2a0d271229bb8c78f582a673 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
index f806f2482aff6da3c525899c5583f4a77391733f..e3e5ecc67588ae32c8c574bc063f7197bd7f78c6 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883 mt7620a
 CFLAGS:=-Os -pipe -mno-branch-likely
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 6826463266cf4c3026887f60c81aac771db6b67f..e9c992e2a17fabd04ec47dcc9c0a17e71e0d87ba 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -922,10 +922,13 @@ static int m25p_probe(struct spi_device
+@@ -925,10 +925,13 @@ static int m25p_probe(struct spi_device
        unsigned                        i;
        struct mtd_part_parser_data     ppdata;
        struct device_node __maybe_unused *np = spi->dev.of_node;
@@ -28,7 +28,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  #endif
  
        /* Platform data helps sort out which chip type we have, as
-@@ -1001,6 +1004,8 @@ static int m25p_probe(struct spi_device
+@@ -1004,6 +1007,8 @@ static int m25p_probe(struct spi_device
  
        if (data && data->name)
                flash->mtd.name = data->name;
index f7da13a6d82789c95386899016f614cd1525c895..4d1a4ce6fb2c88e05094e181667653ed83a5d988 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -807,10 +807,6 @@ static void split_uimage(struct mtd_info
+@@ -808,10 +808,6 @@ static void split_uimage(struct mtd_info
                return;
  
        len = be32_to_cpu(hdr.size) + 0x40;
index 84054bd4e661b0229afa24630f7e59d7e69533c0..ab284be246c3fcfcdbc859639b9c0672d8b9f826 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 DEVICE_TYPE:=developerboard
 
index 780f471ca4c67578e6b60ea0a61a83d7d466c83a..561aba6bcf5b0901dd420c21b47321b821666cb7 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index ce1677f73134690e3398725990bb236accab0f8f..b799b7c70b7cc4f1facdad653180ebb808fa4b4d 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.10.10
+LINUX_VERSION:=3.10.12
 
 DEVICE_TYPE=other