Should fix edimax generation
authorFlorian Fainelli <florian@openwrt.org>
Thu, 29 Mar 2007 10:49:52 +0000 (10:49 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 29 Mar 2007 10:49:52 +0000 (10:49 +0000)
SVN-Revision: 6752

target/linux/adm5120-2.6/image/Makefile

index 35bdbee249bd7e502f2f0f23eb985fadcbc52695..2a5e8e8693b8829956f14a73f2954b28ecdd8750 100644 (file)
@@ -41,7 +41,7 @@ endef
 define Image/Build/Edimax
        # FIXME : not tested (hardware ?)
        $(STAGING_DIR)/bin/mksyshdr $(KDIR)/csys $(KDIR)/vmlinux
-       cat $(KDIR)/csys $(KDIR)/vmlinux $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+       cat $(KDIR)/csys $(KDIR)/loader.gz $(KDIR)/vmlinux.lzma $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
 endef
 
 define Image/Build/MyLoader