ath79: add support for Araknis AN-300-AP-I-N
authorMichael Pratt <mcpratt@pm.me>
Fri, 26 Mar 2021 06:12:26 +0000 (02:12 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Mar 2022 18:54:57 +0000 (19:54 +0100)
FCC ID: U2M-AN300APIN

Araknis AN-300-AP-I-N is an indoor wireless access point with
1 Gb ethernet port, dual-band wireless,
internal antenna plates, and 802.3at PoE+

this board is a Senao device:
the hardware is equivalent to EnGenius EWS310AP
the software is modified Senao SDK which is based on openwrt and uboot
including image checksum verification at boot time,
and a failsafe image that boots if checksum fails

**Specification:**

  - AR9344 SOC MIPS 74kc, 2.4 GHz WMAC, 2x2
  - AR9382 WLAN PCI on-board 168c:0030, 5 GHz, 2x2
  - AR8035-A PHY RGMII GbE with PoE+ IN
  - 40 MHz clock
  - 16 MB FLASH MX25L12845EMI-10G
  - 2x 64 MB RAM 1839ZFG V59C1512164QFJ25
  - UART console J10, populated, RX shorted to ground
  - 4 antennas 5 dBi, internal omni-directional plates
  - 4 LEDs power, 2G, 5G, wps
  - 1 button reset

  NOTE: all 4 gpio controlled LEDS are viewed through the same lightguide
therefore, the power LED is off for default state

**MAC addresses:**

  MAC address labeled as ETH
  Only one Vendor MAC address in flash at art 0x0

  eth0 ETH  *:7d art 0x0
  phy1 2.4G *:7e ---
  phy0 5GHz *:7f ---

**Serial Access:**

  the RX line on the board for UART is shorted to ground by resistor R176
  therefore it must be removed to use the console
  but it is not necessary to remove to view boot log

  optionally, R175 can be replaced with a solder bridge short

  the resistors R175 and R176 are next to the UART RX pin at J10

**Installation:**

  Method 1: Firmware upgrade page:

    (if you cannot access the APs webpage)
    factory reset with the reset button
    connect ethernet to a computer
    OEM webpage at 192.168.20.253
    username and password 'araknis'
    make a new password, login again...

    Navigate to 'File Management' page from left pane
    Click Browse and select the factory.bin image
    Upload and verify checksum
    Click Continue to confirm
    wait about 3 minutes

  Method 2: Serial to load Failsafe webpage:

    After connecting to serial console and rebooting...
    Interrupt uboot with any key pressed rapidly
    execute `run failsafe_boot` OR `bootm 0x9fd70000`
    wait a minute
    connect to ethernet and navigate to
    192.168.20.253
    Select the factory.bin image and upload
    wait about 3 minutes

**Return to OEM:**

  Method 1: Serial to load Failsafe webpage (above)

  Method 2: delete a checksum from uboot-env
  this will make uboot load the failsafe image at next boot
  because it will fail the checksum verification of the image

    ssh into openwrt and run
    `fw_setenv rootfs_checksum 0`
    reboot, wait a minute
    connect to ethernet and navigate to
    192.168.20.253
    select OEM firmware image and click upgrade

  Method 3: backup mtd partitions before upgrade

**TFTP recovery:**

  Requires serial console, reset button does nothing

  rename initramfs-kernel.bin to '0101A8C0.img'
  make available on TFTP server at 192.168.1.101
  power board, interrupt boot with serial console
  execute `tftpboot` and `bootm 0x81000000`

  NOTE: TFTP may not be reliable due to bugged bootloader
set MTU to 600 and try many times

**Format of OEM firmware image:**

  The OEM software is built using SDKs from Senao
  which is based on a heavily modified version
  of Openwrt Kamikaze or Altitude Adjustment.
  One of the many modifications is sysupgrade being performed by a custom script.
  Images are verified through successful unpackaging, correct filenames
  and size requirements for both kernel and rootfs files, and that they
  start with the correct magic numbers (first 2 bytes) for the respective headers.

  Newer Senao software requires more checks but their script
  includes a way to skip them.

  The OEM upgrade script is at
  /etc/fwupgrade.sh

  OKLI kernel loader is required because the OEM software
  expects the kernel to be less than 1536k
  and the OEM upgrade procedure would otherwise
  overwrite part of the kernel when writing rootfs.

Note on PLL-data cells:

  The default PLL register values will not work
  because of the external AR8035 switch between
  the SOC and the ethernet port.

  For QCA955x series, the PLL registers for eth0 and eth1
  can be see in the DTSI as 0x28 and 0x48 respectively.
  Therefore the PLL registers can be read from uboot
  for each link speed after attempting tftpboot
  or another network action using that link speed
  with `md 0x18050028 1` and `md 0x18050048 1`.

  The clock delay required for RGMII can be applied at the PHY side,
  using the at803x driver `phy-mode` setting through the DTS.
  Therefore, the Ethernet Configuration registers for GMAC0
  do not need the bits for RGMII delay on the MAC side.
  This is possible due to fixes in at803x driver
  since Linux 5.1 and 5.3

Signed-off-by: Michael Pratt <mcpratt@pm.me>
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/ar9344_araknis_an-300-ap-i-n.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index bc02f4517c31e603e76ecc296fea7d4f0acede3d..c5f398ffc7ceabeb3a44c7404dbcf899c1c93615 100644 (file)
@@ -20,6 +20,7 @@ alfa-network,pi-wifi4|\
 alfa-network,r36a|\
 alfa-network,tube-2hq|\
 allnet,all-wap02860ac|\
+araknis,an-300-ap-i-n|\
 arduino,yun|\
 buffalo,bhr-4grv2|\
 devolo,magic-2-wifi|\
diff --git a/target/linux/ath79/dts/ar9344_araknis_an-300-ap-i-n.dts b/target/linux/ath79/dts/ar9344_araknis_an-300-ap-i-n.dts
new file mode 100644 (file)
index 0000000..a886b4c
--- /dev/null
@@ -0,0 +1,120 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9344.dtsi"
+#include "ar934x_senao_loader.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "araknis,an-300-ap-i-n", "qca,ar9344";
+       model = "Araknis AN-300-AP-I-N";
+
+       aliases {
+               label-mac-device = &eth0;
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-upgrade = &led_power;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       label = "amber:power";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               wifi5g {
+                       label = "blue:wifi5g";
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wps {
+                       label = "blue:wps";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       ath9k-leds {
+               compatible = "gpio-leds";
+
+               wifi2g {
+                       label = "blue:wifi2g";
+                       gpios = <&ath9k 0 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+               eee-broken-100tx;
+               eee-broken-1000t;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       nvmem-cells = <&macaddr_art_0>;
+       nvmem-cell-names = "mac-address";
+
+       phy-handle = <&phy0>;
+       phy-mode = "rgmii-txid";
+
+       pll-data = <0x02000000 0x00000101 0x00001313>;
+};
+
+&pcie {
+       status = "okay";
+
+       ath9k: wifi@0,0,0 {
+               compatible = "pci168c,0030";
+               reg = <0x0 0 0 0 0>;
+               nvmem-cells = <&macaddr_art_0>;
+               nvmem-cell-names = "mac-address";
+               mac-address-increment = <1>;
+               qca,disable-5ghz;
+               qca,no-eeprom;
+               #gpio-cells = <2>;
+               gpio-controller;
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       qca,disable-2ghz;
+
+       mtd-cal-data = <&art 0x1000>;
+
+       nvmem-cells = <&macaddr_art_0>;
+       nvmem-cell-names = "mac-address";
+       mac-address-increment = <2>;
+};
+
+&art {
+       compatible = "nvmem-cells";
+       #address-cells = <1>;
+       #size-cells = <1>;
+
+       macaddr_art_0: macaddr@0 {
+               reg = <0x0 0x6>;
+       };
+};
index 86ce8f5bd726ceff21c10dbde1847d860292000d..41e52c674850be254aab9cb52ecf11d291edf4e2 100644 (file)
@@ -14,6 +14,7 @@ ath79_setup_interfaces()
        alfa-network,ap121f|\
        alfa-network,pi-wifi4|\
        alfa-network,tube-2hq|\
+       araknis,an-300-ap-i-n|\
        arduino,yun|\
        aruba,ap-105|\
        asus,rp-ac66|\
index 31b872e618f8dbac12238d90aee32a65b954b435..22e162692e62f307fafb5a0d38d3066798b5b5e9 100644 (file)
@@ -72,6 +72,7 @@ case "$FIRMWARE" in
        ;;
 "ath9k-eeprom-pci-0000:00:00.0.bin")
        case $board in
+       araknis,an-300-ap-i-n|\
        atheros,db120|\
        engenius,eap600|\
        engenius,ecb600|\
index 67e53c5fdebf29e71b920753be829fa4e41ca207..cf851965197fb871591b95d15c2771cbabdd9da5 100644 (file)
@@ -48,6 +48,7 @@ platform_do_upgrade() {
                redboot_fis_do_upgrade "$1" vmlinux_2
                ;;
        allnet,all-wap02860ac|\
+       araknis,an-300-ap-i-n|\
        engenius,eap1200h|\
        engenius,eap300-v2|\
        engenius,eap600|\
index 27a9860d287b604d92f3da1e0580e527eccc44a4..e6d4450bde825c803445bf2fb7c71324a8bb269f 100644 (file)
@@ -320,6 +320,17 @@ define Device/allnet_all-wap02860ac
 endef
 TARGET_DEVICES += allnet_all-wap02860ac
 
+define Device/araknis_an-300-ap-i-n
+  $(Device/senao_loader_okli)
+  SOC := ar9344
+  DEVICE_VENDOR := Araknis
+  DEVICE_MODEL := AN-300-AP-I-N
+  IMAGE_SIZE := 12096k
+  LOADER_FLASH_OFFS := 0x220000
+  SENAO_IMGNAME := senao-an300
+endef
+TARGET_DEVICES += araknis_an-300-ap-i-n
+
 define Device/arduino_yun
   SOC := ar9331
   DEVICE_VENDOR := Arduino