mpc85xx: rename generic subtarget to p1010
authorDavid Bauer <mail@david-bauer.net>
Mon, 18 May 2020 19:10:40 +0000 (21:10 +0200)
committerDavid Bauer <mail@david-bauer.net>
Mon, 18 May 2020 19:11:22 +0000 (21:11 +0200)
The mpc85xx-generic subtarget supports the QorIQ SoCs of the p1010
family. Rename the subtarget to reflect this affiliation as it's the
case with the other mpc85xx subtargets.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/mpc85xx/Makefile
target/linux/mpc85xx/generic/config-default [deleted file]
target/linux/mpc85xx/generic/profiles/00-default.mk [deleted file]
target/linux/mpc85xx/generic/target.mk [deleted file]
target/linux/mpc85xx/image/Makefile
target/linux/mpc85xx/p1010/config-default [new file with mode: 0644]
target/linux/mpc85xx/p1010/profiles/00-default.mk [new file with mode: 0644]
target/linux/mpc85xx/p1010/target.mk [new file with mode: 0644]

index 4bb4d8812d1bbf44b3138616931ea0ac4d7b32d8..2ffdfeddcd98e1b905ae375ed59d5691168cc17b 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
 FEATURES:=squashfs ramdisk
-SUBTARGETS:=generic p1020 p2020
+SUBTARGETS:=p1010 p1020 p2020
 
 KERNEL_PATCHVER:=5.4
 
diff --git a/target/linux/mpc85xx/generic/config-default b/target/linux/mpc85xx/generic/config-default
deleted file mode 100644 (file)
index e25d51a..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-# CONFIG_FSL_CORENET_CF is not set
-CONFIG_MTD_NAND_FSL_IFC=y
-CONFIG_MTD_SPLIT_FIRMWARE=y
-CONFIG_MTD_SPLIT_TPLINK_FW=y
-CONFIG_MTD_UBI=y
-CONFIG_MTD_UBI_BEB_LIMIT=20
-CONFIG_MTD_UBI_BLOCK=y
-# CONFIG_MTD_UBI_FASTMAP is not set
-# CONFIG_MTD_UBI_GLUEBI is not set
-CONFIG_MTD_UBI_WL_THRESHOLD=4096
-CONFIG_REALTEK_PHY=y
-CONFIG_RED_15W_REV1=y
-CONFIG_TL_WDR4900_V1=y
-CONFIG_UBIFS_FS=y
-CONFIG_UBIFS_FS_ADVANCED_COMPR=y
-CONFIG_UBIFS_FS_LZO=y
-CONFIG_UBIFS_FS_ZLIB=y
-CONFIG_UBIFS_FS_ZSTD=y
diff --git a/target/linux/mpc85xx/generic/profiles/00-default.mk b/target/linux/mpc85xx/generic/profiles/00-default.mk
deleted file mode 100644 (file)
index 67507ac..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-  NAME:=Default Profile
-  PRIORITY:=1
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most MPC85xx boards.
-endef
-
-$(eval $(call Profile,Default))
diff --git a/target/linux/mpc85xx/generic/target.mk b/target/linux/mpc85xx/generic/target.mk
deleted file mode 100644 (file)
index f826fe4..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-BOARDNAME:=Generic
-FEATURES+=nand
-KERNELNAME:=simpleImage.tl-wdr4900-v1
-
-define Target/Description
-       Build firmware images for generic MPC85xx based boards.
-endef
-
index 40002c13c47537194b76f27b55366ff7b6910c69..225f871699ffc58fc7c4ce6a2c865885970c0dc4 100644 (file)
@@ -21,7 +21,7 @@ define Device/Default
   SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
-ifeq ($(SUBTARGET),generic)
+ifeq ($(SUBTARGET),p1010)
 
 define Device/tplink_tl-wdr4900-v1
   DEVICE_VENDOR := TP-Link
diff --git a/target/linux/mpc85xx/p1010/config-default b/target/linux/mpc85xx/p1010/config-default
new file mode 100644 (file)
index 0000000..e25d51a
--- /dev/null
@@ -0,0 +1,18 @@
+# CONFIG_FSL_CORENET_CF is not set
+CONFIG_MTD_NAND_FSL_IFC=y
+CONFIG_MTD_SPLIT_FIRMWARE=y
+CONFIG_MTD_SPLIT_TPLINK_FW=y
+CONFIG_MTD_UBI=y
+CONFIG_MTD_UBI_BEB_LIMIT=20
+CONFIG_MTD_UBI_BLOCK=y
+# CONFIG_MTD_UBI_FASTMAP is not set
+# CONFIG_MTD_UBI_GLUEBI is not set
+CONFIG_MTD_UBI_WL_THRESHOLD=4096
+CONFIG_REALTEK_PHY=y
+CONFIG_RED_15W_REV1=y
+CONFIG_TL_WDR4900_V1=y
+CONFIG_UBIFS_FS=y
+CONFIG_UBIFS_FS_ADVANCED_COMPR=y
+CONFIG_UBIFS_FS_LZO=y
+CONFIG_UBIFS_FS_ZLIB=y
+CONFIG_UBIFS_FS_ZSTD=y
diff --git a/target/linux/mpc85xx/p1010/profiles/00-default.mk b/target/linux/mpc85xx/p1010/profiles/00-default.mk
new file mode 100644 (file)
index 0000000..5356aaa
--- /dev/null
@@ -0,0 +1,15 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+  NAME:=Default Profile
+  PRIORITY:=1
+endef
+
+define Profile/Default/Description
+       Default package set compatible with most P1010 boards.
+endef
+
+$(eval $(call Profile,Default))
diff --git a/target/linux/mpc85xx/p1010/target.mk b/target/linux/mpc85xx/p1010/target.mk
new file mode 100644 (file)
index 0000000..12ed78a
--- /dev/null
@@ -0,0 +1,8 @@
+BOARDNAME:=P1010
+FEATURES+=nand
+KERNELNAME:=simpleImage.tl-wdr4900-v1
+
+define Target/Description
+       Build firmware images for P1010 based boards.
+endef
+